aboutsummaryrefslogtreecommitdiff
path: root/news/fidogate
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2020-02-04 10:41:41 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2020-02-04 10:41:41 +0000
commit5037eb16010e0502027c76667ca8e3f8807e5f92 (patch)
tree42f63ed0323033af5cdd051ff2b6223bbe858701 /news/fidogate
parente7e9048f05bcdf07315743df7dc5d58623983dc6 (diff)
downloadports-5037eb16010e0502027c76667ca8e3f8807e5f92.tar.gz
ports-5037eb16010e0502027c76667ca8e3f8807e5f92.zip
- move fidogate to fidogate4
- update to 5.7 PR: 243761 Submitted by: Sergey Anokhin
Notes
Notes: svn path=/head/; revision=525142
Diffstat (limited to 'news/fidogate')
-rw-r--r--news/fidogate/Makefile147
-rw-r--r--news/fidogate/distinfo5
-rw-r--r--news/fidogate/files/fidogate.conf-newsyslog6
-rw-r--r--news/fidogate/files/patch-Makefile11
-rw-r--r--news/fidogate/files/patch-config.make52
-rw-r--r--news/fidogate/files/patch-dbz.c13
-rw-r--r--news/fidogate/files/patch-log.c12
-rw-r--r--news/fidogate/files/patch-rfc2ftn.c11
-rw-r--r--news/fidogate/pkg-descr3
-rw-r--r--news/fidogate/pkg-plist304
10 files changed, 218 insertions, 346 deletions
diff --git a/news/fidogate/Makefile b/news/fidogate/Makefile
index 1a7595b1d34a..d0dd0b513f07 100644
--- a/news/fidogate/Makefile
+++ b/news/fidogate/Makefile
@@ -1,75 +1,106 @@
# $FreeBSD$
PORTNAME= fidogate
-PORTVERSION= 4.4.10
-PORTREVISION= 1
+DISTVERSIONPREFIX= v
+DISTVERSION= 5.7
CATEGORIES= news mail
-MASTER_SITES= SF \
- ftp://ftp.fu-berlin.de/unix/news/fidogate/
-MAINTAINER= dinoex@FreeBSD.org
+MAINTAINER= admin@5034.ru
COMMENT= Fido-Internet Gateway and Tosser
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-MAKE_JOBS_UNSAFE= yes
-
-USES= gmake perl5
-MAKE_ARGS= OWNER=${UID} GROUP=$$(id -g)
-PLIST_SUB= FIDOGATE_USER=${FIDOGATE_RUNAS}
-
-FIXDEST= . doc doc/gatebau doc/html scripts/areas \
- scripts/maintenance scripts/misc scripts/nodelist \
- scripts/outbound scripts/run scripts/www src/areafix \
- src/charset src/ffx src/gate src/tick src/toss src/util
-DOCLIST= fidogate.texi fidogate.txt gatebau94.txt kludge-rfc.doc \
- msgid.doc qmail.txt texinfo.tex dirs.html index.html \
- template.html fido howto misc rfc gatebau/msgid.sgml \
- gatebau/msgid.tex gatebau/msgid.txt
-
-OPTIONS_DEFINE= DOCS EXAMPLES
-
-FIDOGATE_RUNAS?= news
-
-.include <bsd.port.options.mk>
-
-post-patch:
- ${REINPLACE_CMD} -e 's| .(PREFIX)| $$(DESTDIR)$$(PREFIX)|g' \
- ${FIXDEST:S,$,/Makefile,S,^,${WRKSRC}/,}
-
-pre-configure:
- ${TOUCH} ${WRKSRC}/doc/fidogate.info
- ${RM} ${WRKSRC}/doc/fidogate.info-?
- ${RM} ${WRKSRC}/doc/fidogate.txt
- ${REINPLACE_CMD} -e "s|[.]info-|.info|" ${WRKSRC}/doc/Makefile
- ${REINPLACE_CMD} -e "s|.{PREFIX}|${PREFIX}|g" \
- -e "s|.{LOCALBASE}|${LOCALBASE}|g" \
- -e "s|^CC|#CC|" ${WRKSRC}/config.make
-.if !${PORT_OPTIONS:MDOCS}
- ${REINPLACE_CMD} -e "s|test doc|test|" \
- -e "s|cp ANNOUNCE|#cp ANNOUNCE|" \
- ${WRKSRC}/Makefile
- ${REINPLACE_CMD} -e "s|run www|run|" ${WRKSRC}/scripts/Makefile
-.endif
-
-pre-install:
- ${MKDIR} ${STAGEDIR}${PREFIX}/libexec/fidogate
-
-pre-install-DOCS-on:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}/html \
- ${STAGEDIR}${DOCSDIR}/info \
- ${STAGEDIR}${DOCSDIR}/fido \
- ${STAGEDIR}${DOCSDIR}/howto \
- ${STAGEDIR}${DOCSDIR}/misc \
- ${STAGEDIR}${DOCSDIR}/gatebau
+USES= autoreconf perl5 iconv
+
+CONFLICTS= fidogate-4* fidogate4-4*
+
+USE_GITHUB= yes
+GH_ACCOUNT= ykaliuta
+GH_PROJECT= fidogate
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --libexec=${PREFIX}/libexec/fidogate \
+ --sysconfdir=${PREFIX}/etc/fido/gate \
+ --with-lockdir=${LOCKDIR} \
+ --with-logdir=${LOGDIR} \
+ --with-vardir=${VARDIR} \
+ --with-spooldir=${SPOOLDIR} \
+ --with-btbasedir=${BTBASEDIR} \
+ ${ICONV_CONFIGURE_BASE}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+INSTALL_TARGET= install-strip
+
+DOCS= doc/README.ru doc/README doc/FAQ.ru doc/old/ChangeLog doc/old/Changes.ru \
+ doc/old/FAQ_fidogate doc/old/FIDOGATE_ftrack doc/old/README.snp \
+ doc/old/fidogate.txt doc/old/fidogate.texi doc/old/msgid.doc
+
+PLIST_SUB+= SPOOLDIR=${SPOOLDIR} \
+ SPOOLDIR2=${SPOOLDIR:S=/gate$==} \
+ BTBASEDIR=${BTBASEDIR} \
+ LOGDIR=${LOGDIR} \
+ LOGDIR2=${LOGDIR:S=/gate$==} \
+ LOCKDIR=${LOCKDIR} \
+ VARDIR=${VARDIR} \
+ PREFIX=${PREFIX}
+
+OPTIONS_DEFINE= INN DESCDIR ALIASES DBC DNT_NETMAIL FMSGID AVAIL BEST_AKA DOCS EXAMPLES
+SPOOLDIR?= /var/spool/fido/gate
+BTBASEDIR?= /var/spool/fido/bt
+LOCKDIR?= /var/run/fidogate
+LOGDIR?= /var/log/fido/gate
+VARDIR?= /var/db/fidogate
+
+OPTIONS_DEFAULT= INN DESCDIR FMSGID AVAIL BEST_AKA
+NO_OPTIONS_SORT=yes
+
+INN_BUILD_DEPENDS= ${PREFIX}/news/bin/innconfval:news/inn
+INN_CONFIGURE_OFF= --without-news
+DESCDIR_CONFIGURE_OFF= --disable-desc-dir
+ALIASES_CONFIGURE_ON= --enable-aliases-local
+DBC_CONFIGURE_ON= --enable-dbc-history
+DNT_NETMAIL_CONFIGURE_ON= --enable-dnt-netmail
+FMSGID_CONFIGURE_OFF= --disable-fs-msgid
+AVAIL_CONFIGURE_OFF= --disable-af-avail
+BEST_AKA_CONFIGURE_ON= --enable-best-aka
+
+INN_DESC= INN news server support
+DESCDIR_DESC= put file descriptions into files.bbs
+ALIASES_DESC= rewrite addresses found in ALIASES
+DBC_DESC= use msgid correspond data base
+DNT_NETMAIL_DESC= do not toss netmail
+FMSGID_DESC= set gate msgid into outgoing messages
+AVAIL_DESC= change behaviour of areafix command "%list" and "%avail"
+BEST_AKA_DESC= best AKA select
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${LOGDIR}
+ ${MKDIR} ${STAGEDIR}${LOCKDIR}
+ ${MKDIR} ${STAGEDIR}${VARDIR}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/newsyslog.conf.d
+ ${INSTALL_DATA} ${FILESDIR}/fidogate.conf-newsyslog \
+ ${STAGEDIR}${PREFIX}/etc/newsyslog.conf.d/fidogate.conf
+ ${MKDIR} ${STAGEDIR}${BTBASEDIR}/fbox \
+ ${STAGEDIR}${BTBASEDIR}/out
post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${TAR} -C ${WRKSRC}/doc -cf - ${DOCLIST} | ${TAR} -C ${STAGEDIR}${DOCSDIR} -xf -
+.for a in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${a} ${STAGEDIR}${DOCSDIR}
+.endfor
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+.for a in exim inn postfix sendmail
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/${a}
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/doc/news/inn/newsfeeds.fidogate ${STAGEDIR}${EXAMPLESDIR}/inn/newsfeeds.fidogate
+ ${INSTALL_DATA} ${WRKSRC}/doc/mailer/postfix/master.cf ${STAGEDIR}${EXAMPLESDIR}/postfix/master.cf
+ ${INSTALL_DATA} ${WRKSRC}/doc/mailer/postfix/transport ${STAGEDIR}${EXAMPLESDIR}/postfix/transport
+ ${INSTALL_DATA} ${WRKSRC}/doc/mailer/sendmail/mailer/ftn.m4 ${STAGEDIR}${EXAMPLESDIR}/sendmail/ftn.m4
+ ${INSTALL_DATA} ${WRKSRC}/doc/mailer/exim/exim.conf.in ${STAGEDIR}${EXAMPLESDIR}/exim/exim.conf.in
+ ${INSTALL_DATA} ${WRKSRC}/doc/mailer/exim/ftntable_1304 ${STAGEDIR}${EXAMPLESDIR}/exim/ftntable_1304
+ ${INSTALL_DATA} ${WRKSRC}/doc/mailer/exim/ftntable_1309 ${STAGEDIR}${EXAMPLESDIR}/exim/ftntable_1309
+ ${INSTALL_DATA} ${WRKSRC}/doc/mailer/exim/ftntable_local ${STAGEDIR}${EXAMPLESDIR}/exim/ftntable_local
post-install-EXAMPLES-on:
- ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${TAR} -C ${WRKSRC}/examples -cf - . | ${TAR} -C ${STAGEDIR}${EXAMPLESDIR} -xf -
.include <bsd.port.mk>
diff --git a/news/fidogate/distinfo b/news/fidogate/distinfo
index 46ff2767f7ad..d4c704ec0f87 100644
--- a/news/fidogate/distinfo
+++ b/news/fidogate/distinfo
@@ -1,2 +1,3 @@
-SHA256 (fidogate-4.4.10.tar.gz) = b56bd77b9f8ccebf4d0289d8f5ffaaf36570b3f08872cb9ce927a2c0faf8b488
-SIZE (fidogate-4.4.10.tar.gz) = 1191524
+TIMESTAMP = 1580469011
+SHA256 (ykaliuta-fidogate-v5.7_GH0.tar.gz) = 54af68727b44934ebf0b85ba618a312720adbe1fac92020c25883ce2237fd4f8
+SIZE (ykaliuta-fidogate-v5.7_GH0.tar.gz) = 806408
diff --git a/news/fidogate/files/fidogate.conf-newsyslog b/news/fidogate/files/fidogate.conf-newsyslog
new file mode 100644
index 000000000000..17eed19f8770
--- /dev/null
+++ b/news/fidogate/files/fidogate.conf-newsyslog
@@ -0,0 +1,6 @@
+/var/log/fido/gate/afixlog news:news 644 4 1000 @T23 X
+/var/log/fido/gate/binkd2.log news:news 644 4 1000 @T23 X
+/var/log/fido/gate/log news:news 644 4 1000 @T23 X
+/var/log/fido/gate/log-in news:news 644 4 1000 @T23 X
+/var/log/fido/gate/log-news news:news 644 4 1000 @T23 X
+/var/log/fido/gate/send-fidogate.log news:news 660 4 1000 @T23 X
diff --git a/news/fidogate/files/patch-Makefile b/news/fidogate/files/patch-Makefile
deleted file mode 100644
index f939fe83dacd..000000000000
--- a/news/fidogate/files/patch-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig 2003-06-08 21:01:25 UTC
-+++ Makefile
-@@ -9,7 +9,7 @@ TOPDIR = .
- include $(TOPDIR)/config.make
- include $(TOPDIR)/rules.make
-
--SUBDIRS = src scripts test doc sendmail
-+SUBDIRS = src scripts test doc
-
- INSTALLDIRS = $(DEFAULT_V_CONFIGDIR) \
- $(DEFAULT_V_LIBDIR) \
diff --git a/news/fidogate/files/patch-config.make b/news/fidogate/files/patch-config.make
deleted file mode 100644
index 9af666154063..000000000000
--- a/news/fidogate/files/patch-config.make
+++ /dev/null
@@ -1,52 +0,0 @@
---- config.make.orig 2003-04-15 18:45:20 UTC
-+++ config.make
-@@ -57,13 +57,13 @@
-
- # variable parameters, can be changed at run-time, DO NOT DELETE ANYTHING!!!
- DEFAULT_V_CONFIGDIR = /etc/fidogate
--DEFAULT_V_LIBDIR = /usr/lib/fidogate
--DEFAULT_V_BINDIR = $(DEFAULT_V_LIBDIR)/bin
--DEFAULT_V_LOGDIR = /var/log/fidogate
-+DEFAULT_V_LIBDIR = ${PREFIX}/libexec/fidogate
-+DEFAULT_V_BINDIR = ${PREFIX}/libexec/fidogate
-+DEFAULT_V_LOGDIR = /var/spool/fidogate/log
- DEFAULT_V_VARDIR = /var/lib/fidogate
--DEFAULT_V_LOCKDIR = /var/lock/fidogate
-+DEFAULT_V_LOCKDIR = /var/spool/fidogate/lock
- DEFAULT_V_SPOOLDIR = /var/spool/fidogate
--DEFAULT_V_BTBASEDIR = /var/spool/bt
-+DEFAULT_V_BTBASEDIR = /var/spool/fidogate/bt
- DEFAULT_V_INBOUND = $(DEFAULT_V_BTBASEDIR)/in
- DEFAULT_V_PINBOUND = $(DEFAULT_V_BTBASEDIR)/pin
- DEFAULT_V_UUINBOUND = $(DEFAULT_V_BTBASEDIR)/uuin
-@@ -87,7 +87,7 @@ DEFAULT_F_NEWSETCDIR = /etc/news
- DEFAULT_F_NEWSVARDIR = /var/lib/news
- # INN 1.7
- #DEFAULT_F_NEWSLIBDIR = /usr/lib/news
--#DEFAULT_F_NEWSSPOOLDIR = /var/spool/news
-+#DEFAULT_F_NEWSSPOOLDIR = /var/spool/news/articles
- # INN 2.2
- #DEFAULT_F_NEWSLIBDIR = /usr/lib
- #DEFAULT_F_NEWSSPOOLDIR = /var/spool/news/articles
-@@ -149,7 +149,7 @@ DEFAULT_A_UUINBOUND = %U
-
-
- # The perl interpreter used by subst.pl
--PERL = /usr/bin/perl
-+PERL = ${LOCALBASE}/bin/perl
-
- # Directory with sendmail m4 configuration files
- # RedHat 6.x
-@@ -158,9 +158,9 @@ PERL = /usr/bin/perl
- SENDMAIL_CF_DIR = /usr/share/sendmail-cf
-
- # Directories for installing documentation, not used by subst.pl
--INFODIR = /usr/info
--HTMLDIR = /html/fidogate
--HTMLLOGDIR = /html/log
-+INFODIR = ${PREFIX}/share/doc/fidogate/info
-+HTMLDIR = ${PREFIX}/share/doc/fidogate/html
-+HTMLLOGDIR = ${PREFIX}/share/doc/fidogate/html
-
- # RedHat RPM related dirs
- RPMBASEDIR = /usr/src/redhat
diff --git a/news/fidogate/files/patch-dbz.c b/news/fidogate/files/patch-dbz.c
deleted file mode 100644
index fb07c6eb309a..000000000000
--- a/news/fidogate/files/patch-dbz.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/toss/dbz.c.orig 2000-10-18 21:53:57 UTC
-+++ src/toss/dbz.c
-@@ -300,8 +300,10 @@ static int debug; /* controlled by dbz
- #endif
-
- /* externals used */
-+#ifndef __FreeBSD__
- extern char *malloc();
- extern char *calloc();
-+#endif
- extern void free(); /* ANSI C; some old implementations say int */
- extern int atoi();
- extern long atol();
diff --git a/news/fidogate/files/patch-log.c b/news/fidogate/files/patch-log.c
deleted file mode 100644
index 5059853894ec..000000000000
--- a/news/fidogate/files/patch-log.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/common/log.c.orig 2004-08-26 20:56:20 UTC
-+++ src/common/log.c
-@@ -69,8 +69,8 @@ static int must_openlog = TRUE;
- char *strerror(int errnum)
- {
- #ifndef OS2
-- extern int sys_nerr;
- # ifndef __FreeBSD__
-+ extern int sys_nerr;
- extern char *sys_errlist[];
- # endif
- #endif
diff --git a/news/fidogate/files/patch-rfc2ftn.c b/news/fidogate/files/patch-rfc2ftn.c
deleted file mode 100644
index 0803694862e5..000000000000
--- a/news/fidogate/files/patch-rfc2ftn.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/gate/rfc2ftn.c.orig 2004-08-22 20:19:12 UTC
-+++ src/gate/rfc2ftn.c
-@@ -99,7 +99,7 @@ void usage (void);
- static char *o_flag = NULL; /* -o --out-packet-file */
- static char *w_flag = NULL; /* -w --write-outbound */
- static int W_flag = FALSE; /* -W --write-crash */
--static int i_flag = FALSE; /* -i --ignore-hosts */
-+int i_flag = FALSE; /* -i --ignore-hosts */
-
- static int maxmsg = 0; /* Process maxmsg messages */
-
diff --git a/news/fidogate/pkg-descr b/news/fidogate/pkg-descr
index a72012fd64dc..9c30753eede6 100644
--- a/news/fidogate/pkg-descr
+++ b/news/fidogate/pkg-descr
@@ -3,5 +3,4 @@
* Fido Mail Processor
* Fido File Processor
* Fido Areafix/Filefix
-
-WWW: http://fidogate.sourceforge.net/
+WWW: https://github.com/ykaliuta/fidogate
diff --git a/news/fidogate/pkg-plist b/news/fidogate/pkg-plist
index de6c5965fb66..c6e0244217e9 100644
--- a/news/fidogate/pkg-plist
+++ b/news/fidogate/pkg-plist
@@ -1,202 +1,136 @@
-libexec/fidogate/areafix.help
-libexec/fidogate/areasbbssync
-libexec/fidogate/charset.bin
-libexec/fidogate/charset.map
-@(%%FIDOGATE_USER%%,news,4755) libexec/fidogate/ffx
-libexec/fidogate/ffxmail
-libexec/fidogate/ffxnews
-libexec/fidogate/ffxqt
-libexec/fidogate/ffxrmail
+@owner news
+@group news
+bin/areasbbssync
+bin/areassucksync
+bin/ftnaf
+bin/ftnafutil
+bin/ftnexpire
+bin/ftnfattach
+bin/ftngenpkt
+bin/ftnhatch
+bin/ftnoutpkt
+bin/hosts2dns
+bin/logcheck
+bin/logdaily
+bin/logreport
+bin/logsendmail
+bin/logstat
+bin/ngoper
+bin/nl-autoupd
+bin/nl-del
+bin/nl-diff
+bin/out-attach
+bin/out-freq
+bin/out-ls
+bin/out-manip
+bin/out-rm0
+bin/out-rmbsy
+bin/outb
+bin/outb-kill
+bin/pktdebug
+bin/pktmore
+bin/pkttmpl
+bin/recvuu
+bin/runchklock
+bin/runinc
+bin/senduu
+bin/senduumail
+bin/sumcrc
+etc/fido/gate/areafix.help.rus
+etc/fido/gate/areas.sample
+etc/fido/gate/bounce.acl
+etc/fido/gate/bounce.acl_netmail
+etc/fido/gate/bounce.addrinto
+etc/fido/gate/bounce.down
+etc/fido/gate/bounce.insecure
+etc/fido/gate/bounce.noto
+etc/fido/gate/bounce.restricted
+@sample etc/fido/gate/acl.sample
+@sample etc/fido/gate/aliases.sample
+@sample etc/fido/gate/areafix.help.sample
+@sample etc/fido/gate/fidogate.conf.sample
+@sample etc/fido/gate/fidokill.sample
+@sample etc/fido/gate/ftnacl.sample
+@sample etc/fido/gate/hosts.sample
+@sample etc/fido/gate/packing.sample
+@sample etc/fido/gate/passwd.sample
+@sample etc/fido/gate/routing.sample
+@sample etc/fido/gate/spyes.sample
+@sample etc/fido/gate/uplinks.sample
+etc/newsyslog.conf.d/fidogate.conf
+libexec/fidogate/confval
libexec/fidogate/ftn2ftn
libexec/fidogate/ftn2rfc
-libexec/fidogate/ftnaf
-@(%%FIDOGATE_USER%%,news,4755) libexec/fidogate/ftnafmail
+libexec/fidogate/ftnafmail
libexec/fidogate/ftnafpkt
-libexec/fidogate/ftnafutil
-libexec/fidogate/ftnbsy
-libexec/fidogate/ftnconfig
-libexec/fidogate/ftnexpire
-libexec/fidogate/ftnfattach
libexec/fidogate/ftnflo
-libexec/fidogate/ftnhatch
libexec/fidogate/ftnin
libexec/fidogate/ftninpost
libexec/fidogate/ftninrecomb
-libexec/fidogate/ftnlock
-libexec/fidogate/ftnlog
-@(%%FIDOGATE_USER%%,news,4755) libexec/fidogate/ftnmail
-libexec/fidogate/ftnoutpkt
+libexec/fidogate/ftnmail
libexec/fidogate/ftnpack
libexec/fidogate/ftnroute
-libexec/fidogate/ftnseq
libexec/fidogate/ftntick
libexec/fidogate/ftntickpost
libexec/fidogate/ftntoss
-libexec/fidogate/latest
-libexec/fidogate/logcheck
-libexec/fidogate/logdaily
-libexec/fidogate/logreport
-libexec/fidogate/logsendmail
-libexec/fidogate/logsendmail2
-libexec/fidogate/logstat
-libexec/fidogate/nl-autoupd
-libexec/fidogate/nl-check
-libexec/fidogate/nl-del
-libexec/fidogate/nl-diff
-libexec/fidogate/out-freq
-libexec/fidogate/out-ls
-libexec/fidogate/out-manip
-libexec/fidogate/out-rm0
-libexec/fidogate/out-rmbsy
-libexec/fidogate/outb
-libexec/fidogate/outb-kill
-libexec/fidogate/pktdebug
-libexec/fidogate/pktmore
+libexec/fidogate/report_traffic
libexec/fidogate/rfc2ftn
-libexec/fidogate/runafutil
-libexec/fidogate/runchklock
-libexec/fidogate/runffx
-libexec/fidogate/rungate
-libexec/fidogate/runin
-libexec/fidogate/runmail
-libexec/fidogate/runnews
-libexec/fidogate/runout
-libexec/fidogate/runpoll
-libexec/fidogate/runpoll-binkd
-libexec/fidogate/runpoll-orodruin
-libexec/fidogate/runtoss
-libexec/fidogate/rununpack
-libexec/fidogate/send-ffx
libexec/fidogate/send-fidogate
-libexec/fidogate/sumcrc
-%%PORTDOCS%%%%DOCSDIR%%/dirs.html
-%%PORTDOCS%%%%DOCSDIR%%/fido/fsc-0018.txt
-%%PORTDOCS%%%%DOCSDIR%%/fido/fsc-0028.txt
-%%PORTDOCS%%%%DOCSDIR%%/fido/fsc-0035.txt
-%%PORTDOCS%%%%DOCSDIR%%/fido/fsc-0039.004
-%%PORTDOCS%%%%DOCSDIR%%/fido/fsc-0043.002
-%%PORTDOCS%%%%DOCSDIR%%/fido/fsc-0047.001
-%%PORTDOCS%%%%DOCSDIR%%/fido/fsc-0048.002
-%%PORTDOCS%%%%DOCSDIR%%/fido/fsc-0054.txt
-%%PORTDOCS%%%%DOCSDIR%%/fido/fsc-0057.002
-%%PORTDOCS%%%%DOCSDIR%%/fido/fts-0001.015
-%%PORTDOCS%%%%DOCSDIR%%/fido/fts-0004.txt
-%%PORTDOCS%%%%DOCSDIR%%/fido/fts-0009.001
+@dir %%BTBASEDIR%%
+@dir %%BTBASEDIR%%/fbox
+@dir %%BTBASEDIR%%/in
+@dir %%BTBASEDIR%%/in/bad
+@dir %%BTBASEDIR%%/in/tmpunpack
+@dir %%BTBASEDIR%%/out
+@dir %%BTBASEDIR%%/pin
+@dir %%BTBASEDIR%%/pin/bad
+@dir %%BTBASEDIR%%/pin/tmpunpack
+@dir %%BTBASEDIR%%/tick
+@dir %%LOCKDIR%%
+@dir %%LOGDIR2%%
+@dir %%LOGDIR%%
+@dir %%SPOOLDIR2%%
+@dir %%SPOOLDIR%%
+@dir %%SPOOLDIR%%/ftpin
+@dir %%SPOOLDIR%%/outpkt
+@dir %%SPOOLDIR%%/outpkt/mail
+@dir %%SPOOLDIR%%/outpkt/news
+@dir %%SPOOLDIR%%/outrfc/mail
+@dir %%SPOOLDIR%%/outrfc
+@dir %%SPOOLDIR%%/outrfc/news
+@dir %%SPOOLDIR%%/toss
+@dir %%SPOOLDIR%%/toss/bad
+@dir %%SPOOLDIR%%/toss/pack
+@dir %%SPOOLDIR%%/toss/route
+@dir %%SPOOLDIR%%/toss/toss
+@dir %%SPOOLDIR%%/uuin
+@dir %%VARDIR%%
+@dir %%VARDIR%%/seq
+@sample %%VARDIR%%/areas.bbs.sample
+@sample %%VARDIR%%/fareas.bbs.sample
+@owner
+@group
+%%PORTDOCS%%@dir %%DOCSDIR%%
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/Changes.ru
+%%PORTDOCS%%%%DOCSDIR%%/FAQ.ru
+%%PORTDOCS%%%%DOCSDIR%%/FAQ_fidogate
+%%PORTDOCS%%%%DOCSDIR%%/FIDOGATE_ftrack
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/README.ru
+%%PORTDOCS%%%%DOCSDIR%%/README.snp
%%PORTDOCS%%%%DOCSDIR%%/fidogate.texi
%%PORTDOCS%%%%DOCSDIR%%/fidogate.txt
-%%PORTDOCS%%%%DOCSDIR%%/gatebau/msgid.sgml
-%%PORTDOCS%%%%DOCSDIR%%/gatebau/msgid.tex
-%%PORTDOCS%%%%DOCSDIR%%/gatebau/msgid.txt
-%%PORTDOCS%%%%DOCSDIR%%/gatebau94.txt
-%%PORTDOCS%%%%DOCSDIR%%/howto/FidoNode-1.html
-%%PORTDOCS%%%%DOCSDIR%%/howto/FidoNode-10.html
-%%PORTDOCS%%%%DOCSDIR%%/howto/FidoNode-11.html
-%%PORTDOCS%%%%DOCSDIR%%/howto/FidoNode-12.html
-%%PORTDOCS%%%%DOCSDIR%%/howto/FidoNode-13.html
-%%PORTDOCS%%%%DOCSDIR%%/howto/FidoNode-2.html
-%%PORTDOCS%%%%DOCSDIR%%/howto/FidoNode-3.html
-%%PORTDOCS%%%%DOCSDIR%%/howto/FidoNode-4.html
-%%PORTDOCS%%%%DOCSDIR%%/howto/FidoNode-5.html
-%%PORTDOCS%%%%DOCSDIR%%/howto/FidoNode-6.html
-%%PORTDOCS%%%%DOCSDIR%%/howto/FidoNode-7.html
-%%PORTDOCS%%%%DOCSDIR%%/howto/FidoNode-8.html
-%%PORTDOCS%%%%DOCSDIR%%/howto/FidoNode-9.html
-%%PORTDOCS%%%%DOCSDIR%%/howto/FidoNode.html
-%%PORTDOCS%%%%DOCSDIR%%/howto/FidoNode.sgml
-%%PORTDOCS%%%%DOCSDIR%%/howto/Makefile
-%%PORTDOCS%%%%DOCSDIR%%/html/ANNOUNCE
-%%PORTDOCS%%%%DOCSDIR%%/html/fidogate_1.html
-%%PORTDOCS%%%%DOCSDIR%%/html/fidogate_2.html
-%%PORTDOCS%%%%DOCSDIR%%/html/fidogate_3.html
-%%PORTDOCS%%%%DOCSDIR%%/html/fidogate_4.html
-%%PORTDOCS%%%%DOCSDIR%%/html/fidogate_5.html
-%%PORTDOCS%%%%DOCSDIR%%/html/fidogate_6.html
-%%PORTDOCS%%%%DOCSDIR%%/html/fidogate_7.html
-%%PORTDOCS%%%%DOCSDIR%%/html/fidogate_8.html
-%%PORTDOCS%%%%DOCSDIR%%/html/fidogate_abt.html
-%%PORTDOCS%%%%DOCSDIR%%/html/fidogate_ovr.html
-%%PORTDOCS%%%%DOCSDIR%%/html/fidogate_toc.html
-%%PORTDOCS%%%%DOCSDIR%%/html/gate.cgi
-%%PORTDOCS%%%%DOCSDIR%%/html/msgid-1.html
-%%PORTDOCS%%%%DOCSDIR%%/html/msgid-2.html
-%%PORTDOCS%%%%DOCSDIR%%/html/msgid-3.html
-%%PORTDOCS%%%%DOCSDIR%%/html/msgid-4.html
-%%PORTDOCS%%%%DOCSDIR%%/html/msgid-5.html
-%%PORTDOCS%%%%DOCSDIR%%/html/msgid-6.html
-%%PORTDOCS%%%%DOCSDIR%%/html/msgid-7.html
-%%PORTDOCS%%%%DOCSDIR%%/html/msgid.html
-%%PORTDOCS%%%%DOCSDIR%%/index.html
-%%PORTDOCS%%%%DOCSDIR%%/info/fidogate.info
-%%PORTDOCS%%%%DOCSDIR%%/kludge-rfc.doc
-%%PORTDOCS%%%%DOCSDIR%%/misc/ifmail-and-fidogate.doc
-%%PORTDOCS%%%%DOCSDIR%%/misc/roland.doc
-%%PORTDOCS%%%%DOCSDIR%%/misc/smail.doc
-%%PORTDOCS%%%%DOCSDIR%%/misc/smail2.doc
-%%PORTDOCS%%%%DOCSDIR%%/misc/smail3.doc
-%%PORTDOCS%%%%DOCSDIR%%/misc/unpack-script.doc
%%PORTDOCS%%%%DOCSDIR%%/msgid.doc
-%%PORTDOCS%%%%DOCSDIR%%/qmail.txt
-%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc-index.txt
-%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc1036.txt
-%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc1123.txt
-%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc2045.txt
-%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc2046.txt
-%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc2047.txt
-%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc2048.txt
-%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc2049.txt
-%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc822.txt
-%%PORTDOCS%%%%DOCSDIR%%/rfc/son-of-1036.html
-%%PORTDOCS%%%%DOCSDIR%%/template.html
-%%PORTDOCS%%%%DOCSDIR%%/texinfo.tex
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/morannon/aliases
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/morannon/areas
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/morannon/bounce.down
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/morannon/bounce.insecure
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/morannon/bounce.noto
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/morannon/bounce.restricted
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/morannon/fidogate.conf
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/morannon/hosts
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/morannon/packing
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/morannon/passwd
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/morannon/routing
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/orodruin/README
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/orodruin/aliases
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/orodruin/areas
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/orodruin/areas.bbs
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/orodruin/fareas.bbs
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/orodruin/fidogate.conf
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/orodruin/hosts
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/orodruin/packing
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/orodruin/passwd
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/orodruin/routing
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/point/areas
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/point/areas.bbs
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/point/fidogate.conf
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/point/newsfeeds
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/point/packing
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/point/routing
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rpm/Makefile
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rpm/README
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rpm/aliases
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rpm/areas
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rpm/areas.bbs
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rpm/fareas.bbs
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rpm/fidogate.conf
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rpm/hosts
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rpm/newsfeeds.fidogate
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rpm/packing
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rpm/passwd
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rpm/routing
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/win32/README.WIN32
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/win32/aliases
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/win32/areas
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/win32/areas.bbs
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/win32/config.make
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/win32/fareas.bbs
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/win32/fidogate.conf
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/win32/hosts
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/win32/packing
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/win32/passwd
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/win32/routing
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/win32/test-win32
+%%PORTEXAMPLES%%@dir %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%@dir %%EXAMPLESDIR%%/inn
+%%PORTEXAMPLES%%@dir %%EXAMPLESDIR%%/postfix
+%%PORTEXAMPLES%%@dir %%EXAMPLESDIR%%/sendmail
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/exim/exim.conf.in
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/exim/ftntable_1304
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/exim/ftntable_1309
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/exim/ftntable_local
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/inn/newsfeeds.fidogate
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/postfix/master.cf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/postfix/transport
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sendmail/ftn.m4