aboutsummaryrefslogtreecommitdiff
path: root/news/inn
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-08-08 13:46:50 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-08-08 13:46:50 +0000
commitf037e396011534f1ed63b7b625f818aaba3b07b6 (patch)
tree509f9c56f6c9e206681219518e92866874b3ae54 /news/inn
parent8d571a7a02a3fde266288ca6716fa8521b8ab0a0 (diff)
downloadports-f037e396011534f1ed63b7b625f818aaba3b07b6.tar.gz
ports-f037e396011534f1ed63b7b625f818aaba3b07b6.zip
USE_BDB cleanup.
- USE_BDB=4x+ -> USES=bdb. - USE_BDB=yes -> USES=bdb. - USE_BDB=xx -> USES=bdb:xx. Other modernisations when I see them. PR: 209183 Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=419843
Diffstat (limited to 'news/inn')
-rw-r--r--news/inn/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/news/inn/Makefile b/news/inn/Makefile
index a797102f3195..e7155897d8e4 100644
--- a/news/inn/Makefile
+++ b/news/inn/Makefile
@@ -60,7 +60,7 @@ PLIST_SUB+= LIBVER=${LIBVER_LONG:R:R} LIBVER_LONG=${LIBVER_LONG}
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MBERKELEYDB}
-USE_BDB= 44+
+USES+= bdb
CONFIGURE_ARGS+= --with-bdb=${LOCALBASE} \
--with-bdb-lib=${LOCALBASE}/lib \
--with-bdb-include=${BDB_INCLUDE_DIR}
@@ -108,7 +108,7 @@ PLIST_SUB+= WITHOUT_TAGGED_HASH=""
SUB_LIST+= DBZ_FILES="${DBZ_FILES}"
.if ${PORT_OPTIONS:MOPENSSL}
-USE_OPENSSL= yes
+USES+= ssl
CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
.endif