aboutsummaryrefslogtreecommitdiff
path: root/news/newsstar
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-08-14 06:16:49 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-08-14 06:16:49 +0000
commit277d9b2dfe415321f78f0b62b40f48ed5caacb71 (patch)
tree28b7dd12c184e4b98beac1809c19f91257c3aa20 /news/newsstar
parent78ca5dbe86fe00b8f29a1ce6024cf059ec6626ce (diff)
downloadports-277d9b2dfe415321f78f0b62b40f48ed5caacb71.tar.gz
ports-277d9b2dfe415321f78f0b62b40f48ed5caacb71.zip
Change option WITH_SN to WITH_INN and remove RUN_DEPENDS.
Add s-news to COMMENT. Fix autosearch paths to newsservers. Fix running overview program if using s-news. Fix path to sendmail. Bump portrevision. PR: ports/70437 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=116174
Diffstat (limited to 'news/newsstar')
-rw-r--r--news/newsstar/Makefile13
-rw-r--r--news/newsstar/files/patch-newsstar.in88
2 files changed, 93 insertions, 8 deletions
diff --git a/news/newsstar/Makefile b/news/newsstar/Makefile
index 264bbb8e1ca3..00d32e950dc6 100644
--- a/news/newsstar/Makefile
+++ b/news/newsstar/Makefile
@@ -7,17 +7,16 @@
PORTNAME= newsstar
PORTVERSION= 1.1.1
+PORTREVISION= 1
CATEGORIES= news
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= anray@inet.ua
-COMMENT= Transfer news between a local NNTP server (INN or sn)
+COMMENT= Transfer news between a local NNTP server (INN, sn, s-news)
-.if !defined(WITH_SN)
-RUN_DEPENDS= ${LOCALBASE}/news/bin/innd:${PORTSDIR}/news/inn
-.else
-RUN_DEPENDS= ${LOCALBASE}/sbin/snntpd:${PORTSDIR}/news/sn
+.if exists(${LOCALBASE}/news/bin/innd)
+WITH_INN=yes
.endif
.if defined(WITHOUT_SSL)
@@ -26,7 +25,7 @@ CONFIGURE_ARGS+=--disable-ssl
USE_OPENSSL= yes
.endif
-.if !defined(WITH_SN)
+.if defined(WITH_INN)
CONFIGURE_ARGS+=--with-inn-path=${PREFIX}/news/bin
.endif
@@ -35,7 +34,7 @@ CONFIGURE_ARGS+=--prefix=${PREFIX} \
--with-rc-dir=/var/spool/newsstar/lib \
--with-incoming-dir=/var/spool/newsstar/incoming
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
USE_PERL5= yes
diff --git a/news/newsstar/files/patch-newsstar.in b/news/newsstar/files/patch-newsstar.in
index 1bb2cb3b8b41..16a2f053b983 100644
--- a/news/newsstar/files/patch-newsstar.in
+++ b/news/newsstar/files/patch-newsstar.in
@@ -1,5 +1,5 @@
--- newsstar.in.orig Sun Jul 4 00:21:24 2004
-+++ newsstar.in Mon Jul 12 21:38:49 2004
++++ newsstar.in Fri Aug 13 13:21:10 2004
@@ -29,7 +29,6 @@
$NEWS_PATH = '@NEWS_PATH@';
$prefix = "@prefix@";
@@ -17,3 +17,89 @@
$OUTGOING_DIR = $SPOOL_DIR . "/.outgoing" if ($OUTGOING_DIR eq "");
$OUTGOING_NEWSSTAR_DIR = $OUTGOING_DIR . "/.newsstar";
$ARTICLES_DIR = $SPOOL_DIR if ($ARTICLES_DIR eq "");
+@@ -209,7 +208,8 @@
+ $SPOOL_DIR = "/var/spool/news" if ($SPOOL_DIR eq "");
+ if ($USE_SNEWS)
+ {
+- $OUTGOING_DIR = "/var/lib/news/suck" if ($OUTGOING_DIR eq "");
++ $ARTICLES_DIR = "/var/spool/s-news" if ($ARTICLES_DIR eq "");
++ $OUTGOING_DIR = "${prefix}/etc/s-news/suck" if ($OUTGOING_DIR eq "");
+ }
+ elsif ($OUTGOING_DIR eq "")
+ {
+@@ -223,7 +223,17 @@
+ }
+ }
+ $OUTGOING_NEWSSTAR_DIR = $OUTGOING_DIR . "/newsstar";
+- $ACTIVE_FILE = "/var/lib/news/active" if ($ACTIVE_FILE eq "");
++ if ($ACTIVE_FILE eq "")
++ {
++ if ($USE_SNEWS)
++ {
++ $ACTIVE_FILE = "${prefix}/etc/s-news/active";
++ }
++ else
++ {
++ $ACTIVE_FILE = "${prefix}/news/db/active";
++ }
++ }
+ if ($ARTICLES_DIR eq "")
+ {
+ if (-d "$SPOOL_DIR/articles")
+@@ -243,21 +253,9 @@
+ {
+ if ($SNSTORE eq "")
+ {
+- if (-x "/usr/sbin/snstore")
+- {
+- $SNSTORE = "/usr/sbin/snstore"
+- }
+- elsif (-x "/usr/local/sbin/snstore")
++ if (-x "${prefix}/sbin/snstore")
+ {
+- $SNSTORE = "/usr/local/sbin/snstore"
+- }
+- elsif (-x "/usr/bin/snstore")
+- {
+- $SNSTORE = "/usr/bin/snstore"
+- }
+- elsif (-x "/usr/local/bin/snstore")
+- {
+- $SNSTORE = "/usr/local/bin/snstore"
++ $SNSTORE = "${prefix}/sbin/snstore"
+ }
+ else
+ {
+@@ -274,21 +272,9 @@
+ {
+ if ($OVERVIEW eq "")
+ {
+- if (-x "/usr/sbin/overview")
+- {
+- $overview = "/usr/sbin/overview"
+- }
+- elsif (-x "/usr/local/sbin/overview")
+- {
+- $overview = "/usr/local/sbin/overview"
+- }
+- elsif (-x "/usr/bin/overview")
+- {
+- $overview = "/usr/bin/overview"
+- }
+- elsif (-x "/usr/local/bin/overview")
++ if (-x "${prefix}/sbin/overview")
+ {
+- $overview = "/usr/local/bin/overview"
++ $OVERVIEW = "${prefix}/sbin/overview"
+ }
+ else
+ {
+@@ -908,7 +894,7 @@
+ # $NEWS_USER may also contain group
+ my $news_from = $NEWS_USER;
+ $news_from =~ s/\..*//;
+- if (!open(SENDMAIL, "|/usr/lib/sendmail -oi -t"))
++ if (!open(SENDMAIL, "|/usr/sbin/sendmail -oi -t"))
+ {
+ print STDERR "Can't run sendmail to bounce rejected posting\n";
+ return;