aboutsummaryrefslogtreecommitdiff
path: root/news/newsstar
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2013-01-20 16:27:40 +0000
committerMatthias Andree <mandree@FreeBSD.org>2013-01-20 16:27:40 +0000
commit3e5d5cf5f56c1ed75fbc44a170828f651f425135 (patch)
treef437d9ff5cb06c5d71beb084b1f902809ffc37e7 /news/newsstar
parent6fa1da1ab6275867c10ed176c810f18f250f3bc3 (diff)
downloadports-3e5d5cf5f56c1ed75fbc44a170828f651f425135.tar.gz
ports-3e5d5cf5f56c1ed75fbc44a170828f651f425135.zip
Convert to OptionsNG.
Fix an installation error to fresh PREFIX directories, where a file was installed one directory level too close to the root (lib/newsstar) and renamed.
Notes
Notes: svn path=/head/; revision=310700
Diffstat (limited to 'news/newsstar')
-rw-r--r--news/newsstar/Makefile23
1 files changed, 16 insertions, 7 deletions
diff --git a/news/newsstar/Makefile b/news/newsstar/Makefile
index c59354b8f1bf..e78401522918 100644
--- a/news/newsstar/Makefile
+++ b/news/newsstar/Makefile
@@ -3,6 +3,7 @@
PORTNAME= newsstar
PORTVERSION= 1.5.5
+PORTREVISION= 1
CATEGORIES= news
MASTER_SITES= SF
@@ -11,7 +12,7 @@ COMMENT= Transfer news between a local NNTP server (INN, sn, s-news)
LICENSE= GPLv3
-LIB_DEPENDS= gdbm.4:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS= gdbm:${PORTSDIR}/databases/gdbm
BUILD_DEPENDS= xmlto:${PORTSDIR}/textproc/xmlto \
${LOCALBASE}/share/xml/docbook/4.5/docbookx.dtd:${PORTSDIR}/textproc/docbook-xml
@@ -20,6 +21,9 @@ GNU_CONFIGURE= yes
USE_ICONV= yes
MAKE_JOBS_SAFE= yes
+OPTIONS_DEFINE= SSL
+OPTIONS_DEFAULT= SSL
+
CONFIGURE_ARGS+=--prefix=${PREFIX} \
--with-conf-dir=${PREFIX}/etc/newsstar \
--with-rc-dir=/var/spool/newsstar/lib \
@@ -28,14 +32,16 @@ CONFIGURE_ARGS+=--prefix=${PREFIX} \
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
-.if defined(NOPORTDOCS)
+.include <bsd.port.options.mk>
+
+.if ! ${PORT_OPTIONS:MDOCS}
INSTALL_TARGET= install-am
.endif
-.if defined(WITHOUT_SSL)
-CONFIGURE_ARGS+=--disable-ssl
-.else
+.if ${PORT_OPTIONS:MSSL}
USE_OPENSSL= yes
+.else
+CONFIGURE_ARGS+=--disable-ssl
.endif
.include <bsd.port.pre.mk>
@@ -65,14 +71,17 @@ DOCS= AUTHORS INSTALL NEWS README TODO docs/QuickStart docs/manual.txt \
EX_CONFIGS= cf.server.sample curses.cf.sample filter.pl.sample main.cf.sample \
master.ignore.sample master.score.sample newsrc.sample
+pre-install:
+ ${MKDIR} ${PREFIX}/lib/${PORTNAME}
+
post-install:
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${EXAMPLESDIR}
.for i in ${EX_CONFIGS}
${INSTALL_DATA} ${WRKSRC}/sample_config/${i} ${EXAMPLESDIR}
.endfor
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for i in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}