aboutsummaryrefslogtreecommitdiff
path: root/news/newsstar
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-14 17:54:04 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-14 17:54:04 +0000
commit5d58a5f47f28ec00b748062937187c402133e846 (patch)
tree355e532e36290c70353b88487b313f0714afe13a /news/newsstar
parentb01443da5b84aa714cf0ba69f13b3832ba035fbf (diff)
downloadports-5d58a5f47f28ec00b748062937187c402133e846.tar.gz
ports-5d58a5f47f28ec00b748062937187c402133e846.zip
Add newsstar, a program that fetches news from a number of remote NNTP servers
and posts it to a local server (INN or sn), and also posts outgoing articles from the local server to the remote ones. It uses a configurable number of multiple processes or "threads" to maximise bandwidth utilisation. The threads are coordinated to avoid downloading multiple copies of the same article. PR: ports/66441 Submitted by: Andrey Slusar <vasallia@ukr.net>
Notes
Notes: svn path=/head/; revision=109152
Diffstat (limited to 'news/newsstar')
-rw-r--r--news/newsstar/Makefile61
-rw-r--r--news/newsstar/distinfo2
-rw-r--r--news/newsstar/pkg-descr20
-rw-r--r--news/newsstar/pkg-plist30
4 files changed, 113 insertions, 0 deletions
diff --git a/news/newsstar/Makefile b/news/newsstar/Makefile
new file mode 100644
index 000000000000..d53e42b88aad
--- /dev/null
+++ b/news/newsstar/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: newsstar
+# Date created: 9 May 2004
+# Whom: Andrey Slusar <vasallia@ukr.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= newsstar
+PORTVERSION= 1.1
+CATEGORIES= news
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= vasallia@ukr.net
+COMMENT= Transfer news between a local NNTP server (INN or sn)
+
+.if !defined(WITH_SN)
+RUN_DEPENDS= ${LOCALBASE}/news/bin/innd:${PORTSDIR}/news/inn
+.else
+RUN_DEPENDS= ${LOCALBASE}/sbin/snntpd:${PORTSDIR}/news/sn
+.endif
+
+.if defined(WITHOUT_SSL)
+CONFIGURE_ARGS+=--disable-ssl
+.else
+USE_OPENSSL= yes
+.endif
+
+.if !defined(WITH_SN)
+CONFIGURE_ARGS+=--with-inn-path=${PREFIX}/news/bin
+.endif
+
+CONFIGURE_ARGS+=--with-conf-dir=${PREFIX}/etc/newsstar \
+ --with-rc-dir=/var/spool/newsstar/lib \
+ --with-incoming-dir=/var/spool/newsstar/incoming
+
+USE_PERL5= yes
+HAS_CONFIGURE= yes
+
+MAN1= newsstar.1
+DOCS= AUTHORS INSTALL NEWS README TODO docs/QuickStart docs/manual.txt \
+ docs/index.html docs/ar01s02.html docs/ar01s03.html docs/ar01s04.html \
+ docs/ar01s05.html docs/ar01s06.html docs/ar01s07.html docs/ar01s08.html \
+ docs/ar01s09.html docs/ar01s10.html docs/ar01s11.html docs/ar01s12.html
+
+EX_CONFIGS= cf.server.sample curses.cf.sample filter.pl.sample main.cf.sample \
+ master.ignore.sample master.score.sample newsrc.sample
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${EXAMPLESDIR}
+.for i in ${EX_CONFIGS}
+ ${INSTALL_DATA} ${WRKSRC}/sample_config/${i} ${EXAMPLESDIR}
+.endfor
+ ${MKDIR} ${DOCSDIR}
+.for i in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/news/newsstar/distinfo b/news/newsstar/distinfo
new file mode 100644
index 000000000000..8c1750de16c6
--- /dev/null
+++ b/news/newsstar/distinfo
@@ -0,0 +1,2 @@
+MD5 (newsstar-1.1.tar.gz) = 8ed424249e5cd91e99c06ab5eb0df285
+SIZE (newsstar-1.1.tar.gz) = 255633
diff --git a/news/newsstar/pkg-descr b/news/newsstar/pkg-descr
new file mode 100644
index 000000000000..43ed7f32d44a
--- /dev/null
+++ b/news/newsstar/pkg-descr
@@ -0,0 +1,20 @@
+Newsstar fetches news and posts it to a local server; INN, s-news and sn are
+supported, and it should be easy to adapt for other servers with some
+configuration and extra scripts. It's designed for Unix-like systems, and all
+the development was done on Linux.
+
+There are already plenty of other programs to do this, but what makes newsstar
+special is that it can make multiple simultaneous connections, not only to
+one server, but to several, supporting up to 10 threads. Before fetching each
+article it checks that it hasn't already been downloaded by another thread or
+in a previous session. It can also pipeline article requests to make better
+use of available bandwidth.
+
+I wrote it because a number of ISPs I have used suffer from unreliable
+newsfeeds. There is an excellent free server made available by
+news.individual.net, but it can be a bit slow at times, and using external
+servers uses more bandwidth. Therefore I wanted a program which could fetch
+whatever articles my ISP has available, but use the foreign server to avoid
+missing posts or getting them very late, and to do it as fast as possible.
+
+WWW: http://newsstar.sourceforge.net/
diff --git a/news/newsstar/pkg-plist b/news/newsstar/pkg-plist
new file mode 100644
index 000000000000..947945cdbd1d
--- /dev/null
+++ b/news/newsstar/pkg-plist
@@ -0,0 +1,30 @@
+bin/newsstar
+libexec/newsstar.bin
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/QuickStart
+%%PORTDOCS%%%%DOCSDIR%%/manual.txt
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/ar01s02.html
+%%PORTDOCS%%%%DOCSDIR%%/ar01s03.html
+%%PORTDOCS%%%%DOCSDIR%%/ar01s04.html
+%%PORTDOCS%%%%DOCSDIR%%/ar01s05.html
+%%PORTDOCS%%%%DOCSDIR%%/ar01s06.html
+%%PORTDOCS%%%%DOCSDIR%%/ar01s07.html
+%%PORTDOCS%%%%DOCSDIR%%/ar01s08.html
+%%PORTDOCS%%%%DOCSDIR%%/ar01s09.html
+%%PORTDOCS%%%%DOCSDIR%%/ar01s10.html
+%%PORTDOCS%%%%DOCSDIR%%/ar01s11.html
+%%PORTDOCS%%%%DOCSDIR%%/ar01s12.html
+%%PORTDOCS%%%%EXAMPLESDIR%%/cf.server.sample
+%%PORTDOCS%%%%EXAMPLESDIR%%/curses.cf.sample
+%%PORTDOCS%%%%EXAMPLESDIR%%/filter.pl.sample
+%%PORTDOCS%%%%EXAMPLESDIR%%/main.cf.sample
+%%PORTDOCS%%%%EXAMPLESDIR%%/master.ignore.sample
+%%PORTDOCS%%%%EXAMPLESDIR%%/master.score.sample
+%%PORTDOCS%%%%EXAMPLESDIR%%/newsrc.sample
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%