aboutsummaryrefslogtreecommitdiff
path: root/news/nntp
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-11-26 18:22:26 +0000
committerSteve Price <steve@FreeBSD.org>1999-11-26 18:22:26 +0000
commitc07b4c504794cc77beeb762f367862e853461b4c (patch)
treeb5c9dd36fb67813ab4c99dc1579f195c28d30315 /news/nntp
parent69b1385a3fc546da92c70c2fc0680f919d59b570 (diff)
downloadports-c07b4c504794cc77beeb762f367862e853461b4c.tar.gz
ports-c07b4c504794cc77beeb762f367862e853461b4c.zip
Update to reflect the new configuration of the cnews port.
PR: 14421 Submitted by: Dirk Meyer <dirk.meyer@dinoex.sub.org>
Notes
Notes: svn path=/head/; revision=23366
Diffstat (limited to 'news/nntp')
-rw-r--r--news/nntp/Makefile26
1 files changed, 25 insertions, 1 deletions
diff --git a/news/nntp/Makefile b/news/nntp/Makefile
index 5dcfd08adc94..0cd37cff6ed3 100644
--- a/news/nntp/Makefile
+++ b/news/nntp/Makefile
@@ -14,12 +14,36 @@ MASTER_SITES= ftp://ftp.abs.net/unix/ \
MAINTAINER= adam@veda.is
-BUILD_DEPENDS= ${PREFIX}/lib/libcnews.a:${PORTSDIR}/news/cnews
+BUILD_DEPENDS= ${LOCALBASE}/lib/libcnews.a:${PORTSDIR}/news/cnews
MAN1= nntpxmit.1
MAN8= nntpd.8c mkgrdates.8c
+PLIST= ${WRKDIR}/.PLIST.sed
+
+MODIFY= conf.h xfer/Makefile xmit/Makefile
+
+NEWSBIN?= ${PREFIX}/news/cnewsbin
+NEWSCTL?= ${PREFIX}/news/lib
+NEWSARTS?= /var/news
+NEWSOV?= /var/news/over.view
post-extract:
@${CP} ${WRKSRC}/conf.h.dist ${WRKSRC}/conf.h
+pre-configure:
+.for i in ${MODIFY}
+ @${MV} ${WRKSRC}/${i} ${WRKSRC}/${i}.sed
+ ${SED} \
+ -e "s=/usr/local/news/lib/bin/config=${NEWSBIN}/config=" \
+ -e "s=/usr/local/news/cnewsbin=${NEWSBIN}=" \
+ -e "s=/usr/local/news/lib=${NEWSCTL}=" \
+ -e "s=/var/news/over.view=${NEWSOV}=" \
+ -e "s=/var/news=${NEWSARTS}=" \
+ -e "s=/usr/local/bin=${PREFIX}/bin=" \
+ ${WRKSRC}/${i}.sed >${WRKSRC}/${i}
+.endfor
+ @${SED} \
+ -e "s=news/cnewsbin=${NEWSBIN:S=${PREFIX}/==}=" \
+ ${PKGDIR}/PLIST >${PLIST}
+
.include <bsd.port.mk>