aboutsummaryrefslogtreecommitdiff
path: root/news/nntp
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2006-08-29 04:14:27 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2006-08-29 04:14:27 +0000
commitfa2d81e6f9fd1bd4c98fc8310f6a26be0560ae40 (patch)
tree14d1e4943f37233e6dc28e0f11cb6e73215957bb /news/nntp
parent4eee414aa487245162a5ad36f11bbf2559b6069d (diff)
downloadports-fa2d81e6f9fd1bd4c98fc8310f6a26be0560ae40.tar.gz
ports-fa2d81e6f9fd1bd4c98fc8310f6a26be0560ae40.zip
- fix for child reaping
Submitted by: Scott Hazen Mueller
Notes
Notes: svn path=/head/; revision=171601
Diffstat (limited to 'news/nntp')
-rw-r--r--news/nntp/Makefile2
-rw-r--r--news/nntp/files/patch-server-netaux.c23
2 files changed, 19 insertions, 6 deletions
diff --git a/news/nntp/Makefile b/news/nntp/Makefile
index fb3fb67cf3be..dd0a7e119321 100644
--- a/news/nntp/Makefile
+++ b/news/nntp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nntp
PORTVERSION= 1.5.12.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= news
MASTER_SITES= ftp://ftp.dinoex.org/pub/c-news/
DISTNAME= ${PORTNAME}.${PORTVERSION}
diff --git a/news/nntp/files/patch-server-netaux.c b/news/nntp/files/patch-server-netaux.c
index f606f444ecd7..197b23c6ae87 100644
--- a/news/nntp/files/patch-server-netaux.c
+++ b/news/nntp/files/patch-server-netaux.c
@@ -1,11 +1,24 @@
---- server/netaux.c.orig Tue Jun 4 21:22:30 2002
-+++ server/netaux.c Tue Jun 4 21:23:10 2002
-@@ -261,7 +261,7 @@
+--- server/netaux.c.orig Tue Nov 1 07:08:56 1994
++++ server/netaux.c Sun Aug 27 21:52:42 2006
+@@ -20,6 +20,9 @@
+ #else
+ #include <sys/time.h>
+ #endif
++#ifdef BSD_44
++#include <sys/resource.h>
++#endif
+ /*
+ * read_again -- (maybe) read in the active file again,
+@@ -262,7 +265,11 @@
reaper()
{
--#ifndef USG
-+#if !defined(USG) && !defined(BSD_44)
+ #ifndef USG
++#ifdef BSD_44
++ int status;
++#else
union wait status;
++#endif
while (wait3(&status, WNOHANG, (struct rusage *)0) > 0)
+ ;