aboutsummaryrefslogtreecommitdiff
path: root/news/nntpcache
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-09-13 21:05:03 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-09-13 21:05:03 +0000
commit8d735b94dc189eb4b5f5212e0d6ce3543eb9284a (patch)
treeaa14a635e248a1bd90bf63170937678522f2296c /news/nntpcache
parentf3dcf0b80f25c9fdae5fb62aa5bbb2b4ba2fa4d9 (diff)
downloadports-8d735b94dc189eb4b5f5212e0d6ce3543eb9284a.tar.gz
ports-8d735b94dc189eb4b5f5212e0d6ce3543eb9284a.zip
- Fix xover head filtering
PR: ports/86045 Submitted by: SANETO Takanori <sanewo@ba2.so-net.ne.jp>
Notes
Notes: svn path=/head/; revision=142626
Diffstat (limited to 'news/nntpcache')
-rw-r--r--news/nntpcache/Makefile2
-rw-r--r--news/nntpcache/files/patch-src-acc.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/news/nntpcache/Makefile b/news/nntpcache/Makefile
index b51ca5da3e33..53060d21c9c3 100644
--- a/news/nntpcache/Makefile
+++ b/news/nntpcache/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nntpcache
PORTVERSION= 3.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= news
MASTER_SITES= ftp://ftp.cs.tu-berlin.de/pub/net/news/nntpcache/ \
ftp://ftp.sbs.de/pub/news/servers/nntpcache/ \
diff --git a/news/nntpcache/files/patch-src-acc.c b/news/nntpcache/files/patch-src-acc.c
new file mode 100644
index 000000000000..f5de8a38b1e2
--- /dev/null
+++ b/news/nntpcache/files/patch-src-acc.c
@@ -0,0 +1,11 @@
+--- src/acc.c.orig Sat Feb 19 12:16:21 2000
++++ src/acc.c Tue Sep 13 23:00:32 2005
+@@ -195,7 +195,7 @@
+ loge (("bad filter header/scope %s in file %s: %s", scope, fi, buf));
+ Exit(1);
+ }
+- *p='\0';
++ /* *p='\0'; */
+ f->scope = sc_header;
+ f->scope_header = Sstrdup(scope);
+ }