aboutsummaryrefslogtreecommitdiff
path: root/news/nntpcache
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2006-03-17 00:06:37 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2006-03-17 00:06:37 +0000
commitc1b52ea0f0491b1719485ed1a4a5a2cb66573de8 (patch)
tree0b45e5c9e1b5c1057e134690d08bee90bb972920 /news/nntpcache
parentd051daecb1e8cef85efea0cdfe255f821f9dbe23 (diff)
downloadports-c1b52ea0f0491b1719485ed1a4a5a2cb66573de8.tar.gz
ports-c1b52ea0f0491b1719485ed1a4a5a2cb66573de8.zip
- use %%RC_SUBR%% instead of hardcoded /etc/rc.subr [1]
- fix coredump when parsing user:pass@host in nntpcache.servers [2] - bump PORTREVISION PR: 94550 [1], 94549 [2] Submitted by: tps at vr-web.de [1][2]
Notes
Notes: svn path=/head/; revision=157468
Diffstat (limited to 'news/nntpcache')
-rw-r--r--news/nntpcache/Makefile2
-rw-r--r--news/nntpcache/files/nntpcached.in2
-rw-r--r--news/nntpcache/files/patch-src-nntpcache.c11
3 files changed, 13 insertions, 2 deletions
diff --git a/news/nntpcache/Makefile b/news/nntpcache/Makefile
index 8d50d143fc35..425a8f6e8190 100644
--- a/news/nntpcache/Makefile
+++ b/news/nntpcache/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nntpcache
PORTVERSION= 3.0.2
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= news
MASTER_SITES= http://www.nntpcache.com/pub/nntpcache/
diff --git a/news/nntpcache/files/nntpcached.in b/news/nntpcache/files/nntpcached.in
index 691fc250f3c6..f0c387e48aa0 100644
--- a/news/nntpcache/files/nntpcached.in
+++ b/news/nntpcache/files/nntpcached.in
@@ -11,7 +11,7 @@
# nntpcached_enable="YES"
#
-. /etc/rc.subr
+. %%RC_SUBR%%
name=nntpcached
rcvar=`set_rcvar`
diff --git a/news/nntpcache/files/patch-src-nntpcache.c b/news/nntpcache/files/patch-src-nntpcache.c
new file mode 100644
index 000000000000..ef3e490f551b
--- /dev/null
+++ b/news/nntpcache/files/patch-src-nntpcache.c
@@ -0,0 +1,11 @@
+--- src/nntpcache.c.orig Fri Mar 17 07:53:45 2006
++++ src/nntpcache.c Fri Mar 17 07:53:51 2006
+@@ -810,7 +810,7 @@
+ loge (("missing password in %s:%d: %s", file, n, buf));
+ continue;
+ }
+- if ((hostname = strrchr(password-2, '@')) != NULL) {
++ if ((hostname = strrchr(password, '@')) != NULL) {
+ *(hostname++) = '\0';
+ username = host;
+ list->user = Sstrdup (username);