aboutsummaryrefslogtreecommitdiff
path: root/news/p5-News-Article
diff options
context:
space:
mode:
authorTim Vanderhoek <hoek@FreeBSD.org>1998-08-16 19:22:30 +0000
committerTim Vanderhoek <hoek@FreeBSD.org>1998-08-16 19:22:30 +0000
commitf160cffbca9bd3ecf356f98066885a162dbbdc64 (patch)
treebf193ba94ecd85fb96ab3c942a48fb26ed1c3e2a /news/p5-News-Article
parenta8ad95f8bdf645453b380b58f39d29464cc66d60 (diff)
downloadports-f160cffbca9bd3ecf356f98066885a162dbbdc64.tar.gz
ports-f160cffbca9bd3ecf356f98066885a162dbbdc64.zip
Update for proper perl5 handling.
Submitted by: Don Croyle (ports/7597)
Notes
Notes: svn path=/head/; revision=12540
Diffstat (limited to 'news/p5-News-Article')
-rw-r--r--news/p5-News-Article/Makefile10
-rw-r--r--news/p5-News-Article/pkg-plist16
2 files changed, 11 insertions, 15 deletions
diff --git a/news/p5-News-Article/Makefile b/news/p5-News-Article/Makefile
index 635d20e22824..b087ba984513 100644
--- a/news/p5-News-Article/Makefile
+++ b/news/p5-News-Article/Makefile
@@ -3,7 +3,7 @@
# Date created: January 2, 1998
# Whom: Don Croyle <croyle@gelemna.ft-wayne.in.us>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1998/05/04 14:56:33 mph Exp $
#
DISTNAME= News-Article-1.14
@@ -14,15 +14,15 @@ MASTER_SITES= http://www.freebsd.org/~mph/distfiles/ \
MAINTAINER= croyle@gelemna.ft-wayne.in.us
-RUN_DEPENDS= ${PREFIX}/lib/perl5/site_perl/Net/DNS.pm:${PORTSDIR}/net/p5-Net-DNS \
- ${PREFIX}/lib/perl5/site_perl/Net/NNTP.pm:${PORTSDIR}/net/p5-Net \
- ${PREFIX}/lib/perl5/site_perl/PGP/Sign.pm:${PORTSDIR}/security/p5-PGP-Sign
+RUN_DEPENDS= ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/Net/DNS.pm:${PORTSDIR}/net/p5-Net-DNS \
+ ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/i386-freebsd/Net/NNTP.pm:${PORTSDIR}/net/p5-Net \
+ ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/PGP/Sign.pm:${PORTSDIR}/security/p5-PGP-Sign
USE_PERL5= yes
MAN3= News::Article.3 News::AutoReply.3 News::FormArticle.3 \
News::FormReply.3
-MANPREFIX= ${PREFIX}/lib/perl5
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
do-configure:
@ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PREFIX}/bin/perl Makefile.PL
diff --git a/news/p5-News-Article/pkg-plist b/news/p5-News-Article/pkg-plist
index 27b321b3521e..8866ba9330d0 100644
--- a/news/p5-News-Article/pkg-plist
+++ b/news/p5-News-Article/pkg-plist
@@ -1,10 +1,6 @@
-lib/perl5/man/man3/News::Article.3.gz
-lib/perl5/man/man3/News::AutoReply.3.gz
-lib/perl5/man/man3/News::FormArticle.3.gz
-lib/perl5/man/man3/News::FormReply.3.gz
-lib/perl5/site_perl/News/Article.pm
-lib/perl5/site_perl/News/AutoReply.pm
-lib/perl5/site_perl/News/FormArticle.pm
-lib/perl5/site_perl/News/FormReply.pm
-lib/perl5/site_perl/i386-freebsd/auto/News/Article/.packlist
-@dirrm lib/perl5/site_perl/i386-freebsd/auto/News/Article
+lib/perl5/site_perl/%%PERL_VER%%/News/Article.pm
+lib/perl5/site_perl/%%PERL_VER%%/News/AutoReply.pm
+lib/perl5/site_perl/%%PERL_VER%%/News/FormArticle.pm
+lib/perl5/site_perl/%%PERL_VER%%/News/FormReply.pm
+lib/perl5/site_perl/%%PERL_VER%%/i386-freebsd/auto/News/Article/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/i386-freebsd/auto/News/Article