aboutsummaryrefslogtreecommitdiff
path: root/news/pan
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-04-11 13:51:28 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-04-11 13:51:28 +0000
commit16ccff16fae59bc77c15ca065e6d4e1275b51808 (patch)
tree0e93cdc9a2585c97dd581848b7aeaf4d51570a51 /news/pan
parent392458c14b5f867476c17110f50406488a132262 (diff)
downloadports-16ccff16fae59bc77c15ca065e6d4e1275b51808.tar.gz
ports-16ccff16fae59bc77c15ca065e6d4e1275b51808.zip
Stagify
USES=gmake tar:bzip2 and sort USES Use new LIB_DEPENDS syntax. Add USE_GCC=any to fix the build on 10.0+. [1] PR: ports/182203 [1] Submitted by: Walter Hurry <walterhurry@gmail.com>
Notes
Notes: svn path=/head/; revision=350951
Diffstat (limited to 'news/pan')
-rw-r--r--news/pan/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/news/pan/Makefile b/news/pan/Makefile
index e9b00b454f83..d740f17abf43 100644
--- a/news/pan/Makefile
+++ b/news/pan/Makefile
@@ -14,13 +14,12 @@ COMMENT= Threaded GTK+ newsreader based on Agent for Windows
LICENSE= GPLv2
-LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre \
- gmime-2.6:${PORTSDIR}/mail/gmime26
+LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre \
+ libgmime-2.6.so:${PORTSDIR}/mail/gmime26
-USE_BZIP2= yes
-USE_GMAKE= yes
-USES= pathfix gettext iconv pkgconfig
+USES= gmake gettext iconv pathfix pkgconfig tar:bzip2
USE_GNOME= intlhack
+USE_GCC= any
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lgnuregex ${ICONV_LIB}
@@ -30,7 +29,6 @@ OPTIONS_DEFAULT=GTKSPELL
GTKSPELL_DESC= Spell checking support (gtk+2 only)
GTK3_DESC= Use gtk+3 based UI instead of gtk+2
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGTK3}
@@ -44,7 +42,7 @@ CONFIGURE_ARGS+=--without-gtk3
.if !${PORT_OPTIONS:MGTKSPELL} || ${PORT_OPTIONS:MGTK3}
CONFIGURE_ARGS+= --without-gtkspell
.else
-LIB_DEPENDS+= gtkspell:${PORTSDIR}/textproc/gtkspell
+LIB_DEPENDS+= libgtkspell.so:${PORTSDIR}/textproc/gtkspell
CONFIGURE_ARGS+= --with-gtkspell
.endif