aboutsummaryrefslogtreecommitdiff
path: root/news/pan
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2016-03-25 09:49:17 +0000
committerKoop Mast <kwm@FreeBSD.org>2016-03-25 09:49:17 +0000
commit3c34a3b6dd0323e1babfd80bfa83ddbfd318b0d0 (patch)
tree194db6c4ca8081fec0f413ed992cc95a17f3d8c0 /news/pan
parente28ca54faece2a6b641c6842459f1217fc6b73e2 (diff)
downloadports-3c34a3b6dd0323e1babfd80bfa83ddbfd318b0d0.tar.gz
ports-3c34a3b6dd0323e1babfd80bfa83ddbfd318b0d0.zip
* Add gnutls options for SSL news servers (default on)
* Make gettext optional. * Turn toolkit selection into a radio option. PR: 208165 (with minor tweaks) Submitted by: cpet <freebsd@shotmail.ru>
Notes
Notes: svn path=/head/; revision=411829
Diffstat (limited to 'news/pan')
-rw-r--r--news/pan/Makefile46
1 files changed, 24 insertions, 22 deletions
diff --git a/news/pan/Makefile b/news/pan/Makefile
index 15fa3eeb849a..c66c0d172f3e 100644
--- a/news/pan/Makefile
+++ b/news/pan/Makefile
@@ -4,7 +4,7 @@
PORTNAME= pan
PORTVERSION= 0.139
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= news gnome
MASTER_SITES= http://pan.rebelbase.com/download/releases/${PORTVERSION}/source/
DIST_SUBDIR= gnome2
@@ -17,7 +17,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre \
libgmime-2.6.so:${PORTSDIR}/mail/gmime26
-USES= gmake gettext iconv pathfix pkgconfig tar:bzip2
+USES= gmake iconv pathfix pkgconfig tar:bzip2
USE_GNOME= intlhack
USE_GCC= any
GNU_CONFIGURE= yes
@@ -25,27 +25,29 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -static-libgcc -static-libstdc++ -L${LOCALBASE}/lib \
-lgnuregex ${ICONV_LIB}
-OPTIONS_DEFINE= GTKSPELL GTK3
-OPTIONS_DEFAULT=GTKSPELL
+OPTIONS_DEFINE= GTKSPELL GNUTLS NLS
+OPTIONS_RADIO= GTK
+OPTIONS_RADIO_GTK= GTK2 GTK3
+OPTIONS_SUB= yes
+OPTIONS_DEFAULT=GTKSPELL GNUTLS GTK2
GTKSPELL_DESC= Spell checking support (gtk+2 only)
-GTK3_DESC= Use gtk+3 based UI instead of gtk+2
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MGTK3}
-USE_GNOME+= gtk30
-CONFIGURE_ARGS+=--with-gtk3
-.else
-USE_GNOME+= gtk20
-CONFIGURE_ARGS+=--without-gtk3
-.endif
-
-.if !${PORT_OPTIONS:MGTKSPELL} || ${PORT_OPTIONS:MGTK3}
-CONFIGURE_ARGS+= --without-gtkspell
-.else
-LIB_DEPENDS+= libgtkspell.so:${PORTSDIR}/textproc/gtkspell
-CONFIGURE_ARGS+= --with-gtkspell
-.endif
+
+GNUTLS_LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls
+GNUTLS_USES= pkgconfig
+GNUTLS_CONFIGURE_WITH= gnutls
+
+GTK3_CONFIGURE_WITH= gtk3
+GTK3_USE= gnome=gtk30
+
+GTK2_USE= gnome=gtk20
+
+GTKSPELL_LIB_DEPENDS= libgtkspell.so:${PORTSDIR}/textproc/gtkspell
+GTKSPELL_CONFIGURE_WITH= gtkspell
+
+GTK3_PREVENTS= GTKSPELL
+
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in"| ${XARGS} ${REINPLACE_CMD} -e \