aboutsummaryrefslogtreecommitdiff
path: root/news/pan
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-12-12 23:37:57 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-12-12 23:37:57 +0000
commit759ecf1f626629e552db88c8b930972aa2fef079 (patch)
tree0d2aa5e6ce9997008d0a83fe0551135734d1651c /news/pan
parent9cae799dc460e88d1452728491e0dab77bdb7f70 (diff)
downloadports-759ecf1f626629e552db88c8b930972aa2fef079.tar.gz
ports-759ecf1f626629e552db88c8b930972aa2fef079.zip
Staticly link to libgcc and libstdc++. This fixes a segmentation fault
when trying to run pan on a libc++ based system. PR: 199303 Submitted by: Andrew <andrew_terekhov@yahoo.com>
Notes
Notes: svn path=/head/; revision=403639
Diffstat (limited to 'news/pan')
-rw-r--r--news/pan/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/news/pan/Makefile b/news/pan/Makefile
index d740f17abf43..15fa3eeb849a 100644
--- a/news/pan/Makefile
+++ b/news/pan/Makefile
@@ -4,7 +4,7 @@
PORTNAME= pan
PORTVERSION= 0.139
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= news gnome
MASTER_SITES= http://pan.rebelbase.com/download/releases/${PORTVERSION}/source/
DIST_SUBDIR= gnome2
@@ -22,7 +22,8 @@ USE_GNOME= intlhack
USE_GCC= any
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lgnuregex ${ICONV_LIB}
+LDFLAGS+= -static-libgcc -static-libstdc++ -L${LOCALBASE}/lib \
+ -lgnuregex ${ICONV_LIB}
OPTIONS_DEFINE= GTKSPELL GTK3
OPTIONS_DEFAULT=GTKSPELL