aboutsummaryrefslogtreecommitdiff
path: root/news/pan
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2007-04-23 21:25:44 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2007-04-23 21:25:44 +0000
commit7d645b9416df66683acdde69e778f2819869221f (patch)
treed9c1d1eb4f7d79a4650bf753f41e60c59a64c006 /news/pan
parent4972deae12beb73bbc23d647d279111ddf890e89 (diff)
downloadports-7d645b9416df66683acdde69e778f2819869221f.tar.gz
ports-7d645b9416df66683acdde69e778f2819869221f.zip
Change this patch to a better fix, bump the PORTREVISION.
GNOME Bugzilla: http://bugzilla.gnome.org/show_bug.cgi?id=432387 Submitted by: Charles Kerr (developer) Tested by: pav
Notes
Notes: svn path=/head/; revision=190759
Diffstat (limited to 'news/pan')
-rw-r--r--news/pan/Makefile1
-rw-r--r--news/pan/files/patch-pan_data_article.cc9
2 files changed, 6 insertions, 4 deletions
diff --git a/news/pan/Makefile b/news/pan/Makefile
index 5edf474923d8..984b23d5afe3 100644
--- a/news/pan/Makefile
+++ b/news/pan/Makefile
@@ -8,6 +8,7 @@
PORTNAME= pan
PORTVERSION= 0.128
+PORTREVISION= 1
CATEGORIES= news gnome
MASTER_SITES= http://pan.rebelbase.com/download/releases/${PORTVERSION}/source/
DIST_SUBDIR= gnome2
diff --git a/news/pan/files/patch-pan_data_article.cc b/news/pan/files/patch-pan_data_article.cc
index c461c7d93f26..e050cb84cbbb 100644
--- a/news/pan/files/patch-pan_data_article.cc
+++ b/news/pan/files/patch-pan_data_article.cc
@@ -1,11 +1,12 @@
---- pan/data/article.cc.orig Sun Apr 22 15:17:04 2007
-+++ pan/data/article.cc Sun Apr 22 15:17:44 2007
-@@ -153,7 +153,7 @@
+--- pan/data/article.cc.orig Mon Apr 23 16:21:51 2007
++++ pan/data/article.cc Mon Apr 23 16:23:29 2007
+@@ -153,7 +153,8 @@
kc = &key.back();
mc = &mid.back();
- ke = key.str + 1 + std::max (int(b), (int)minlen - UCHAR_MAX);
-+ ke = key.str + 1 + std::max ((char)b, (char)(minlen - UCHAR_MAX));
++ ke = std::max (key.str + b + 1,
++ key.str + key.len - UCHAR_MAX);
while (kc>ke)
if (*kc-- != *mc--) { ++kc; break; }
const size_t e (&key.back() - kc);