aboutsummaryrefslogtreecommitdiff
path: root/news/pan
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2018-11-10 03:38:37 +0000
committerSteve Wills <swills@FreeBSD.org>2018-11-10 03:38:37 +0000
commit89af6749958d2072a90ad8c298ae6c20fb19e102 (patch)
treebe30f375d1a3d3d2cb1ebdaa00b16bfa41f43e63 /news/pan
parentfcc1aad0cb15f65ae775eaf33d206b32f5769442 (diff)
downloadports-89af6749958d2072a90ad8c298ae6c20fb19e102.tar.gz
ports-89af6749958d2072a90ad8c298ae6c20fb19e102.zip
news/pan: Update to 0.145
PR: 230112 Submitted by: Nathan <ndowens@yahoo.com> (based on)
Notes
Notes: svn path=/head/; revision=484568
Diffstat (limited to 'news/pan')
-rw-r--r--news/pan/Makefile38
-rw-r--r--news/pan/distinfo6
-rw-r--r--news/pan/files/patch-c++11166
-rw-r--r--news/pan/pkg-plist7
4 files changed, 29 insertions, 188 deletions
diff --git a/news/pan/Makefile b/news/pan/Makefile
index 1b38e8ecf9a2..b00afda748e4 100644
--- a/news/pan/Makefile
+++ b/news/pan/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= pan
-PORTVERSION= 0.141
+PORTVERSION= 0.145
CATEGORIES= news gnome
MASTER_SITES= http://pan.rebelbase.com/download/releases/${PORTVERSION}/source/
DIST_SUBDIR= gnome2
@@ -11,44 +11,46 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= Threaded GTK+ newsreader based on Agent for Windows
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+BUILD_DEPENDS= itstool:textproc/itstool
LIB_DEPENDS= libpcre.so:devel/pcre \
libenchant.so:textproc/enchant \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libgmime-2.6.so:mail/gmime26
-USES= gmake iconv localbase pathfix pkgconfig tar:bzip2
+USES= desktop-file-utils gettext-tools:build gmake gnome iconv \
+ localbase pathfix pkgconfig tar:bzip2
USE_GNOME= cairo gdkpixbuf2 intlhack
GNU_CONFIGURE= yes
LDFLAGS+= -lgnuregex ${ICONV_LIB}
-
-OPTIONS_DEFINE= GTKSPELL GNUTLS NLS
-OPTIONS_RADIO= GTK
+INSTALLS_ICONS= yes
+OPTIONS_DEFINE= GTKSPELL GNUTLS NLS
+OPTIONS_DEFAULT= GTKSPELL GNUTLS GTK2
+OPTIONS_RADIO= GTK
OPTIONS_RADIO_GTK= GTK2 GTK3
-OPTIONS_SUB= yes
-OPTIONS_DEFAULT=GTKSPELL GNUTLS GTK2
-GTKSPELL_DESC= Spell checking support (gtk+2 only)
+OPTIONS_SUB= yes
+GTKSPELL_DESC= Spell checking support (gtk+2 only)
GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
-GNUTLS_USES= pkgconfig
GNUTLS_CONFIGURE_WITH= gnutls
GTK3_CONFIGURE_WITH= gtk3
-GTK3_USE= gnome=gtk30
-
-GTK2_USE= gnome=gtk20
+GTK3_USE= gnome=gtk30
+GTK2_USE= gnome=gtk20
GTKSPELL_LIB_DEPENDS= libgtkspell.so:textproc/gtkspell
-GTKSPELL_CONFIGURE_WITH= gtkspell
-
-GTK3_PREVENTS= GTKSPELL
+GTKSPELL_CONFIGURE_WITH=gtkspell
+GTK3_PREVENTS= GTKSPELL
-NLS_USES= gettext
+NLS_USES= gettext-runtime
NLS_CONFIGURE_ENABLE= nls
+NLS_CONFIGURE_DISABLE= nls
post-patch:
- @${FIND} ${WRKSRC} -name "Makefile.in"| ${XARGS} ${REINPLACE_CMD} -e \
- 's|noinst_PROGRAMS = |noinst_PROGRAMS = #|g'
+ ${REINPLACE_CMD} -e 's|noinst_PROGRAMS = |noinst_PROGRAMS = #|g' \
+ ${WRKSRC}/Makefile.in
+ ${REINPLACE_CMD} -e '98s|const std|std|' ${WRKSRC}/pan/general/string-view.h
.include <bsd.port.mk>
diff --git a/news/pan/distinfo b/news/pan/distinfo
index 0b8be33a2318..815d9b184a64 100644
--- a/news/pan/distinfo
+++ b/news/pan/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1483999180
-SHA256 (gnome2/pan-0.141.tar.bz2) = ffa63cd078afa18496be86a76db9370eb0ccdab5ae1f2f74ef5adc7753d11aa3
-SIZE (gnome2/pan-0.141.tar.bz2) = 1589991
+TIMESTAMP = 1537582598
+SHA256 (gnome2/pan-0.145.tar.bz2) = 68da514a8088513502b418859a7df7638866f75d03a429197cf9c23176559cac
+SIZE (gnome2/pan-0.145.tar.bz2) = 2307162
diff --git a/news/pan/files/patch-c++11 b/news/pan/files/patch-c++11
deleted file mode 100644
index 074c4ea55e89..000000000000
--- a/news/pan/files/patch-c++11
+++ /dev/null
@@ -1,166 +0,0 @@
-text-match.cc:476:8: error: no viable conversion from 'pan::StringView' to 'std::__1::basic_string<char>'
- s = tmp;
- ^~~
-/usr/include/c++/v1/string:767:5: note: candidate constructor not viable: no known conversion from 'pan::StringView' to 'const std::__1::basic_string<char> &' for 1st argument
- basic_string(const basic_string& __str);
- ^
-/usr/include/c++/v1/string:772:5: note: candidate constructor not viable: no known conversion from 'pan::StringView' to 'std::__1::basic_string<char> &&' for 1st argument
- basic_string(basic_string&& __str)
- ^
-/usr/include/c++/v1/string:782:31: note: candidate constructor not viable: no known conversion from 'pan::StringView' to 'const char *' for 1st argument
- _LIBCPP_INLINE_VISIBILITY basic_string(const _CharT* __s);
- ^
-/usr/include/c++/v1/string:815:5: note: candidate constructor not viable: no known conversion from 'pan::StringView' to 'initializer_list<char>' for 1st argument
- basic_string(initializer_list<_CharT> __il);
- ^
-../../pan/general/string-view.h:98:10: note: candidate function
- operator const std::string () const { return to_string(); }
- ^
-/usr/include/c++/v1/string:834:44: note: passing argument to parameter '__str' here
- basic_string& operator=(basic_string&& __str)
- ^
-article-filter.cc:165:46: error: invalid suffix on literal; C++11 requires a space between literal
- and identifier [-Wreserved-user-defined-literal]
- g_snprintf (buf, sizeof(buf), "%"G_GUINT64_FORMAT, xit->number);
- ^
-nntp.cc:366:49: error: invalid suffix on literal; C++11 requires a space between literal and
- identifier [-Wreserved-user-defined-literal]
- _commands.push_back (build_command ("XOVER %"G_GUINT64_FORMAT"-%"G_GUINT64_FORMAT"\r\n", l...
- ^
-nntp.cc:366:69: error: invalid suffix on literal; C++11 requires a space between literal and
- identifier [-Wreserved-user-defined-literal]
- _commands.push_back (build_command ("XOVER %"G_GUINT64_FORMAT"-%"G_GUINT64_FORMAT"\r\n", l...
- ^
-nntp.cc:379:49: error: invalid suffix on literal; C++11 requires a space between literal and
- identifier [-Wreserved-user-defined-literal]
- _commands.push_back (build_command ("XZVER %"G_GUINT64_FORMAT"-%"G_GUINT64_FORMAT"\r\n", l...
- ^
-nntp.cc:379:69: error: invalid suffix on literal; C++11 requires a space between literal and
- identifier [-Wreserved-user-defined-literal]
- _commands.push_back (build_command ("XZVER %"G_GUINT64_FORMAT"-%"G_GUINT64_FORMAT"\r\n", l...
- ^
-nntp.cc:420:51: error: invalid suffix on literal; C++11 requires a space between literal and
- identifier [-Wreserved-user-defined-literal]
- _commands.push_back (build_command ("ARTICLE %"G_GUINT64_FORMAT"\r\n", article_number));
- ^
-nntp.cc:462:48: error: invalid suffix on literal; C++11 requires a space between literal and
- identifier [-Wreserved-user-defined-literal]
- _commands.push_back (build_command ("HEAD %"G_GUINT64_FORMAT"\r\n", article_number));
- ^
-nntp.cc:490:48: error: invalid suffix on literal; C++11 requires a space between literal and
- identifier [-Wreserved-user-defined-literal]
- _commands.push_back (build_command ("BODY %"G_GUINT64_FORMAT"\r\n", article_number));
- ^
-numbers.cc:270:50: error: invalid suffix on literal; C++11 requires a space between literal and
- identifier [-Wreserved-user-defined-literal]
- bytes = g_snprintf (buf, sizeof(buf), "%"G_GUINT64_FORMAT",", r.low);
- ^
-
-numbers.cc:272:51: error: invalid suffix on literal; C++11 requires a space between literal and
- identifier [-Wreserved-user-defined-literal]
- bytes = g_snprintf (buf, sizeof(buf), "%"G_GUINT64_FORMAT"-%"G_GUINT64_FORMAT",", r....
- ^
-
-numbers.cc:272:71: error: invalid suffix on literal; C++11 requires a space between literal and
- identifier [-Wreserved-user-defined-literal]
- bytes = g_snprintf (buf, sizeof(buf), "%"G_GUINT64_FORMAT"-%"G_GUINT64_FORMAT",", r....
- ^
-task-xover.cc:394:41: error: invalid suffix on literal; C++11 requires a space between literal and
- identifier [-Wreserved-user-defined-literal]
- xref = buf = g_strdup_printf("%s %s:%"G_GUINT64_FORMAT,
- ^
-
---- pan/data-impl/article-filter.cc.orig 2016-03-12 23:32:41 UTC
-+++ pan/data-impl/article-filter.cc
-@@ -162,7 +162,7 @@ ArticleFilter :: test_article (const Data & dat
- s += xit->group;
- s += ':';
- char buf[32];
-- g_snprintf (buf, sizeof(buf), "%"G_GUINT64_FORMAT, xit->number);
-+ g_snprintf (buf, sizeof(buf), "%" G_GUINT64_FORMAT, xit->number);
- s += buf;
- s += ' ';
- }
---- pan/general/string-view.h.orig 2011-06-02 10:17:28 UTC
-+++ pan/general/string-view.h
-@@ -95,7 +95,7 @@ namespace pan
- std::string to_string () const {return empty()
- ? std::string()
- : std::string(str,str+len); }
-- operator const std::string () const { return to_string(); }
-+ operator std::string () const { return to_string(); }
-
- StringView substr (const char * start, const char * end) const;
- void substr (const char * start, const char * end, StringView& setme) const;
---- pan/tasks/nntp.cc.orig 2016-11-23 21:06:54 UTC
-+++ pan/tasks/nntp.cc
-@@ -363,7 +363,7 @@ NNTP :: xover (const Quark & group,
- _listener = l;
-
- enter_group(group);
-- _commands.push_back (build_command ("XOVER %"G_GUINT64_FORMAT"-%"G_GUINT64_FORMAT"\r\n", low, high));
-+ _commands.push_back (build_command ("XOVER %" G_GUINT64_FORMAT "-%" G_GUINT64_FORMAT "\r\n", low, high));
- write_next_command ();
- }
-
-@@ -376,7 +376,7 @@ NNTP :: xzver (const Quark & group,
- _listener = l;
-
- enter_group(group);
-- _commands.push_back (build_command ("XZVER %"G_GUINT64_FORMAT"-%"G_GUINT64_FORMAT"\r\n", low, high));
-+ _commands.push_back (build_command ("XZVER %" G_GUINT64_FORMAT "-%" G_GUINT64_FORMAT "\r\n", low, high));
- write_next_command ();
- }
-
-@@ -417,7 +417,7 @@ NNTP :: article (const Quark & group,
-
- enter_group(group);
-
-- _commands.push_back (build_command ("ARTICLE %"G_GUINT64_FORMAT"\r\n", article_number));
-+ _commands.push_back (build_command ("ARTICLE %" G_GUINT64_FORMAT "\r\n", article_number));
-
- write_next_command ();
- }
-@@ -459,7 +459,7 @@ NNTP :: get_headers (const Quark & group,
-
- enter_group(group);
-
-- _commands.push_back (build_command ("HEAD %"G_GUINT64_FORMAT"\r\n", article_number));
-+ _commands.push_back (build_command ("HEAD %" G_GUINT64_FORMAT "\r\n", article_number));
-
- write_next_command ();
- }
-@@ -487,7 +487,7 @@ NNTP :: get_body (const Quark & group,
-
- enter_group(group);
-
-- _commands.push_back (build_command ("BODY %"G_GUINT64_FORMAT"\r\n", article_number));
-+ _commands.push_back (build_command ("BODY %" G_GUINT64_FORMAT "\r\n", article_number));
-
- write_next_command ();
- }
---- pan/tasks/task-xover.cc.orig 2016-03-07 21:09:53 UTC
-+++ pan/tasks/task-xover.cc
-@@ -391,7 +391,7 @@ TaskXOver::on_nntp_line_process(NNTP * nntp, const Str
- // if news server doesn't provide an xref, fake one
- char * buf(0);
- if (xref.empty())
-- xref = buf = g_strdup_printf("%s %s:%"G_GUINT64_FORMAT,
-+ xref = buf = g_strdup_printf("%s %s:%" G_GUINT64_FORMAT,
- nntp->_server.c_str(), nntp->_group.c_str(), number);
-
- uint64_t& h(_high[nntp->_server]);
---- pan/usenet-utils/numbers.cc.orig 2011-06-02 10:17:28 UTC
-+++ pan/usenet-utils/numbers.cc
-@@ -267,9 +267,9 @@ Numbers :: to_string (std::string & str) const
- Range r (*it);
-
- if (r.low == r.high)
-- bytes = g_snprintf (buf, sizeof(buf), "%"G_GUINT64_FORMAT",", r.low);
-+ bytes = g_snprintf (buf, sizeof(buf), "%" G_GUINT64_FORMAT ",", r.low);
- else
-- bytes = g_snprintf (buf, sizeof(buf), "%"G_GUINT64_FORMAT"-%"G_GUINT64_FORMAT",", r.low, r.high);
-+ bytes = g_snprintf (buf, sizeof(buf), "%" G_GUINT64_FORMAT "-%" G_GUINT64_FORMAT ",", r.low, r.high);
- temp.append(buf, bytes);
- }
-
diff --git a/news/pan/pkg-plist b/news/pan/pkg-plist
index 7e58af8b9f22..e6a6060c2365 100644
--- a/news/pan/pkg-plist
+++ b/news/pan/pkg-plist
@@ -1,6 +1,12 @@
bin/pan
+man/man1/pan.1.gz
share/applications/pan.desktop
share/appdata/pan.appdata.xml
+share/icons/hicolor/16x16/apps/pan.png
+share/icons/hicolor/24x24/apps/pan.png
+share/icons/hicolor/256x256/apps/pan.png
+share/icons/hicolor/32x32/apps/pan.png
+share/icons/hicolor/48x48/apps/pan.png
%%NLS%%share/locale/am/LC_MESSAGES/pan.mo
%%NLS%%share/locale/ar/LC_MESSAGES/pan.mo
%%NLS%%share/locale/az/LC_MESSAGES/pan.mo
@@ -49,4 +55,3 @@ share/appdata/pan.appdata.xml
%%NLS%%share/locale/vi/LC_MESSAGES/pan.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/pan.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/pan.mo
-share/pixmaps/pan.png