aboutsummaryrefslogtreecommitdiff
path: root/news/s-news
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-03-29 17:28:56 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-03-29 17:28:56 +0000
commit2a58169b19854c36ac6d019a7c3954879ded21d5 (patch)
tree1b1cbaaa8a1ad8875cf82eefa0bfb6687b917752 /news/s-news
parente08194692d8105d8bde7eed78560a26d65c7084b (diff)
downloadports-2a58169b19854c36ac6d019a7c3954879ded21d5.tar.gz
ports-2a58169b19854c36ac6d019a7c3954879ded21d5.zip
Add stage support to news, and improve correctness.
I am not touching the husky ports with a 10 foot pole. atp: stage, improve pkg-message crashmail: stage diablo: too wacky to stage, but convert WITH_* to OPTIONS, unmute commands that shouldn't be muted, use :MDOCS fidogate-ds: stage, OPTIONS, treat examples as EXAMPLES, not DOCS, handle /var/* in the plist properly golded+: stage, OPTIONS, protect examples behind %%PORTEXAMPLES%% nntpbtr: this was an unbelievably PITA stage, add missing prototypes, add missing return types, rename patch files to what they actually patch nntpcache: stage support, required lots of Makefile.in patching, call submakes correctly, handle config files properly nzbperl: stage, use OPTIONS, remove obsolete pkg-message papercut: stage, handle config file properly py-pynzb: stage, use OPTIONS helper to avoid bsd.port.options.mk inclusion s-news: stage slrnconf: stage slrnface: stage, install required files to datadir, not examplesdir, generate proper pkg-message sn: stage
Notes
Notes: svn path=/head/; revision=349572
Diffstat (limited to 'news/s-news')
-rw-r--r--news/s-news/Makefile17
-rw-r--r--news/s-news/files/patch-Makefile.in14
-rw-r--r--news/s-news/pkg-plist10
3 files changed, 25 insertions, 16 deletions
diff --git a/news/s-news/Makefile b/news/s-news/Makefile
index 0b0ad5e4d723..fa40436e89fe 100644
--- a/news/s-news/Makefile
+++ b/news/s-news/Makefile
@@ -14,14 +14,14 @@ LIB_DEPENDS= gdbm:${PORTSDIR}/databases/gdbm
CONFLICTS= leafnode-[1-9]* nntp-[0-9]*
-CONFIGURE_ARGS= --prefix=${PREFIX} \
+CONFIGURE_ARGS+= \
--with-confdir=${PREFIX}/etc/s-news \
--with-spooldir=/var/spool/s-news
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+LDFLAGS+= -L${LOCALBASE}/lib
CPPFLAGS+= -I${LOCALBASE}/include
-USE_GMAKE= yes
-HAS_CONFIGURE= yes
+USES= gmake
+GNU_CONFIGURE= yes
MAN1= inews.1
MAN8= expire.8 listactive.8 makehistory.8 newgroup.8 nntpd.8 overview.8 \
@@ -31,13 +31,8 @@ PORTDOCS= README README.conf README.suck TODO
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/news/s-news/files/patch-Makefile.in b/news/s-news/files/patch-Makefile.in
index de222774d1e1..0e06d5ac2ec6 100644
--- a/news/s-news/files/patch-Makefile.in
+++ b/news/s-news/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in.orig Sat May 18 21:23:03 2002
-+++ Makefile.in Sat Jul 17 21:03:08 2004
+--- Makefile.in.orig 2002-05-18 15:23:03.000000000 -0400
++++ Makefile.in 2014-03-29 13:01:10.000000000 -0400
@@ -113,7 +113,7 @@
$(INSTALL_PROGRAM) $$p $(DESTDIR)$(sbindir)/$$p;\
done
@@ -9,11 +9,15 @@
done
$(INSTALL_DIRECTORY) $(DESTDIR)$(mandir)/man1
for p in $(MAN1PAGES); do\
-@@ -125,10 +125,9 @@
+@@ -123,12 +123,11 @@
+ for p in $(MAN8PAGES); do\
+ $(INSTALL_DATA) $$p $(DESTDIR)$(mandir)/man8/$$p;\
done
- $(INSTALL_VARDIR) $(spooldir)
- $(INSTALL_VARDIR) $(confdir)
+- $(INSTALL_VARDIR) $(spooldir)
+- $(INSTALL_VARDIR) $(confdir)
- $(INSTALL_VARDIR) $(confdir)/suck
++ $(INSTALL_VARDIR) $(DESTDIR)$(spooldir)
++ $(INSTALL_VARDIR) $(DESTDIR)$(confdir)
for d in $(DATA); do\
if test ! -e $(DESTDIR)$(confdir)/$$d; then\
- $(INSTALL_VARDATA) data/$$d $(DESTDIR)$(confdir)/$$d;\
diff --git a/news/s-news/pkg-plist b/news/s-news/pkg-plist
index f25b3a2a7633..df6b9e1323d3 100644
--- a/news/s-news/pkg-plist
+++ b/news/s-news/pkg-plist
@@ -6,6 +6,16 @@ etc/s-news/newsfeeds.sample
etc/s-news/newsgroups.sample
etc/s-news/overview.fmt.sample
etc/s-news/put.news
+man/man1/inews.1.gz
+man/man8/expire.8.gz
+man/man8/listactive.8.gz
+man/man8/makehistory.8.gz
+man/man8/newgroup.8.gz
+man/man8/nntpd.8.gz
+man/man8/overview.8.gz
+man/man8/qnews.8.gz
+man/man8/rmgroup.8.gz
+man/man8/rnews.8.gz
sbin/expire
sbin/fetchnews
sbin/listactive