aboutsummaryrefslogtreecommitdiff
path: root/news/sabnzbdplus/Makefile
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2020-08-16 20:58:01 +0000
committerFlorian Smeets <flo@FreeBSD.org>2020-08-16 20:58:01 +0000
commit8423f117e5bfb2c6cfc2f41ac2ecdefbd92a377f (patch)
treeee359c454410452be6f383ad9d5aaca42b90c74d /news/sabnzbdplus/Makefile
parent1e56346a18a20e9b68ddc1ceaf37c9344ab779da (diff)
downloadports-8423f117e5bfb2c6cfc2f41ac2ecdefbd92a377f.tar.gz
ports-8423f117e5bfb2c6cfc2f41ac2ecdefbd92a377f.zip
Notes
Diffstat (limited to 'news/sabnzbdplus/Makefile')
-rw-r--r--news/sabnzbdplus/Makefile32
1 files changed, 19 insertions, 13 deletions
diff --git a/news/sabnzbdplus/Makefile b/news/sabnzbdplus/Makefile
index 2dc8a035e632..55a65cdf7483 100644
--- a/news/sabnzbdplus/Makefile
+++ b/news/sabnzbdplus/Makefile
@@ -1,23 +1,23 @@
# $FreeBSD$
PORTNAME= sabnzbdplus
-PORTVERSION= 2.3.9
+PORTVERSION= 3.0.0
CATEGORIES= news
-MAINTAINER= joshruehlig@gmail.com
+MAINTAINER= james@french.id.au
COMMENT= Web-interface based binary newsgrabber in python, with nzb support
LICENSE= BSD2CLAUSE BSD3CLAUSE GPLv2+ ISCL MIT PSFL
LICENSE_COMB= multi
-DEPRECATED= Uses deprecated version of python
-EXPIRATION_DATE= 2020-09-15
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cheetah3>=0:devel/py-cheetah3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cherrypy>=8.9.1:www/py-cherrypy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}chardet>=0:textproc/py-chardet@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}configobj>=0:devel/py-configobj@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}portend>=0:net/py-portend@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>=0:databases/py-sqlite3@${PY_FLAVOR}
-RUN_DEPENDS= cheetah:devel/py-cheetah@${PY_FLAVOR} \
- ${PYTHON_SITELIBDIR}/pythonutils/configobj.py:devel/py-utils@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
-
-USES= python:2.7 shebangfix
+USES= python:3.5+ shebangfix gettext
USE_GITHUB= yes
GH_ACCOUNT= sabnzbd
@@ -39,19 +39,25 @@ PORTDOCS= ABOUT.txt \
USERS= _sabnzbd
GROUPS= _sabnzbd
-OPTIONS_DEFINE= PAR2CMDLINE UNRAR 7ZIP FEEDPARSER YENC SSL DOCS
+OPTIONS_DEFINE= PAR2CMDLINE UNRAR 7ZIP FEEDPARSER YENC SSL DOCS NOTIFY2 DBUS PYGOBJECT
OPTIONS_DEFAULT= PAR2CMDLINE UNRAR 7ZIP FEEDPARSER YENC SSL
PAR2CMDLINE_DESC= Required for postprocessing of par files
7ZIP_DESC= Needed for unpacking 7-Zip posts
-FEEDPARSER_DESC= rss-feed support
+FEEDPARSER_DESC= RSS feed support
YENC_DESC= yenc support
+NOTIFY2_DESC= Notify2 support
+DBUS_DESC= DBUS support for system power management
+PYGOBJECT_DESC= PyGObject support for system tray icon (requires cairo)
PAR2CMDLINE_RUN_DEPENDS= par2repair:archivers/par2cmdline-tbb
FEEDPARSER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}feedparser>=0:textproc/py-feedparser@${PY_FLAVOR}
-YENC_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sabyenc>=3.3.1:news/py-sabyenc@${PY_FLAVOR}
+YENC_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sabyenc3>=0:news/py-sabyenc3@${PY_FLAVOR}
SSL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=0:security/py-cryptography@${PY_FLAVOR}
UNRAR_RUN_DEPENDS= unrar:archivers/unrar
7ZIP_RUN_DEPENDS= 7za:archivers/p7zip
+NOTIFY2_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}notify2>=0:devel/py-notify2@${PY_FLAVOR}
+DBUS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>=0:devel/py-dbus@${PY_FLAVOR}
+PYGOBJECT_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gobject3>=3.10.2:devel/py-gobject3@${PY_FLAVOR}
post-patch:
@${REINPLACE_CMD} -e "s:%%DATADIR%%:'${DATADIR}':g" \
@@ -66,7 +72,7 @@ do-install:
@${MKDIR} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/sabnzbd
cd ${WRKSRC}/sabnzbd && ${COPYTREE_SHARE} \* ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/sabnzbd
@${MKDIR} ${STAGEDIR}${DATADIR}
-.for i in cherrypy gntp interfaces locale po tools util
+.for i in email icons interfaces locale po tools
@${MKDIR} ${STAGEDIR}${DATADIR}/${i}
cd ${WRKSRC}/${i} && ${COPYTREE_SHARE} \* ${STAGEDIR}${DATADIR}/${i}
.endfor