aboutsummaryrefslogtreecommitdiff
path: root/news/slrnface
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2002-08-22 20:03:15 +0000
committerOliver Braun <obraun@FreeBSD.org>2002-08-22 20:03:15 +0000
commit1ce3ea230782eaaa2edcbf75b5f5c6e83a330547 (patch)
tree596a7fa9ef9c8c468bd52e37e5fc3494c5e6e90e /news/slrnface
parent3fccc4d9a5d6f45ef88537bd20d39666977499c5 (diff)
downloadports-1ce3ea230782eaaa2edcbf75b5f5c6e83a330547.tar.gz
ports-1ce3ea230782eaaa2edcbf75b5f5c6e83a330547.zip
Add slrnface 1.2, shows X-Faces from slrn in X11 terminal emulator.
PR: ports/36967 Approved by: dwcjr (mentor)
Notes
Notes: svn path=/head/; revision=64840
Diffstat (limited to 'news/slrnface')
-rw-r--r--news/slrnface/Makefile31
-rw-r--r--news/slrnface/distinfo1
-rw-r--r--news/slrnface/files/patch-Makefile20
-rw-r--r--news/slrnface/files/patch-slrnface.sl11
-rw-r--r--news/slrnface/pkg-comment1
-rw-r--r--news/slrnface/pkg-descr6
-rw-r--r--news/slrnface/pkg-message10
-rw-r--r--news/slrnface/pkg-plist3
8 files changed, 83 insertions, 0 deletions
diff --git a/news/slrnface/Makefile b/news/slrnface/Makefile
new file mode 100644
index 000000000000..224fd61f8da4
--- /dev/null
+++ b/news/slrnface/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: slrnface
+# Date created: 10 April 2002
+# Whom: Oliver Braun <obraun@informatik.unibw-muenchen.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= slrnface
+PORTVERSION= 1.2
+CATEGORIES= news
+MASTER_SITES= http://fly.cc.fer.hr/~dave/slrnface/
+
+MAINTAINER= obraun@FreeBSD.org
+
+LIB_DEPENDS= compface:${PORTSDIR}/mail/faces
+
+ALL_TARGET= slrnface
+
+USE_XLIB= yes
+USE_GMAKE= yes
+
+post-patch:
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/slrnface ${PREFIX}/bin
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/slrnface.sl ${EXAMPLESDIR}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/news/slrnface/distinfo b/news/slrnface/distinfo
new file mode 100644
index 000000000000..4d3f40651619
--- /dev/null
+++ b/news/slrnface/distinfo
@@ -0,0 +1 @@
+MD5 (slrnface-1.2.tar.gz) = 71c39b70c89c715970c29378b71ecf9e
diff --git a/news/slrnface/files/patch-Makefile b/news/slrnface/files/patch-Makefile
new file mode 100644
index 000000000000..047bb3be7ae1
--- /dev/null
+++ b/news/slrnface/files/patch-Makefile
@@ -0,0 +1,20 @@
+--- Makefile.orig Mon Dec 25 02:38:17 2000
++++ Makefile Thu Aug 22 21:28:44 2002
+@@ -1,13 +1,12 @@
+-CC = cc
+-X_INCL = # location of X include files, if needed
++X_INCL = -I${X11BASE}/include # location of X include files, if needed
+ X_LIBS = -lXt -lX11 # X libs
+-XF_LIB = -L/usr/local/lib -lcompface # compface library
+-C_FLAGS = -O -D_REENTRANT
++XF_LIB = -L${X11BASE}/lib -L${LOCALBASE}/lib -lcompface # compface library
++C_FLAGS+= -O -D_REENTRANT
+
+ OS_DEFS = #-DLINUX_SUX
+
+ CFLAGS = $(C_FLAGS) $(OS_DEFS) $(X_INCL)
+-LDFLAGS = $(XF_LIB) $(X_LIBS) -lpthread
++LDFLAGS = $(XF_LIB) $(X_LIBS) "-pthread"
+
+ slrnface: slrnface.c
+ $(CC) $(CFLAGS) -o slrnface slrnface.c $(LDFLAGS)
diff --git a/news/slrnface/files/patch-slrnface.sl b/news/slrnface/files/patch-slrnface.sl
new file mode 100644
index 000000000000..b43f5b93fd35
--- /dev/null
+++ b/news/slrnface/files/patch-slrnface.sl
@@ -0,0 +1,11 @@
+--- slrnface.sl.orig Wed Apr 10 18:34:08 2002
++++ slrnface.sl Wed Apr 10 18:34:22 2002
+@@ -16,7 +16,7 @@
+ % Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+
+-variable xfacefp;
++variable xfacefp = NULL;
+
+ define startup_hook()
+ {
diff --git a/news/slrnface/pkg-comment b/news/slrnface/pkg-comment
new file mode 100644
index 000000000000..18099980fa18
--- /dev/null
+++ b/news/slrnface/pkg-comment
@@ -0,0 +1 @@
+Shows X-Faces from slrn in X11 terminal emulator
diff --git a/news/slrnface/pkg-descr b/news/slrnface/pkg-descr
new file mode 100644
index 000000000000..0b809ad86642
--- /dev/null
+++ b/news/slrnface/pkg-descr
@@ -0,0 +1,6 @@
+slrnface shows X-Faces from slrn in an X11 terminal emulator
+
+WWW: http://fly.cc.fer.hr/~dave/slrnface/
+
+- Oliver Braun
+obraun@informatik.unibw-muenchen.de
diff --git a/news/slrnface/pkg-message b/news/slrnface/pkg-message
new file mode 100644
index 000000000000..601fdef47ec5
--- /dev/null
+++ b/news/slrnface/pkg-message
@@ -0,0 +1,10 @@
+*********************************************************
+Add
+
+ interpret ${PREFIX}/share/examples/slrnface/slrnface.sl
+
+to your .slrnrc
+
+NOTE: slrnface.sl defines hooks.
+ Merge these hooks with yours if they already exist.
+*********************************************************
diff --git a/news/slrnface/pkg-plist b/news/slrnface/pkg-plist
new file mode 100644
index 000000000000..6dcf52a1b6cb
--- /dev/null
+++ b/news/slrnface/pkg-plist
@@ -0,0 +1,3 @@
+bin/slrnface
+share/examples/slrnface/slrnface.sl
+@dirrm share/examples/slrnface