aboutsummaryrefslogtreecommitdiff
path: root/news/slrnface
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-03-29 17:28:56 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-03-29 17:28:56 +0000
commit2a58169b19854c36ac6d019a7c3954879ded21d5 (patch)
tree1b1cbaaa8a1ad8875cf82eefa0bfb6687b917752 /news/slrnface
parente08194692d8105d8bde7eed78560a26d65c7084b (diff)
downloadports-2a58169b19854c36ac6d019a7c3954879ded21d5.tar.gz
ports-2a58169b19854c36ac6d019a7c3954879ded21d5.zip
Add stage support to news, and improve correctness.
I am not touching the husky ports with a 10 foot pole. atp: stage, improve pkg-message crashmail: stage diablo: too wacky to stage, but convert WITH_* to OPTIONS, unmute commands that shouldn't be muted, use :MDOCS fidogate-ds: stage, OPTIONS, treat examples as EXAMPLES, not DOCS, handle /var/* in the plist properly golded+: stage, OPTIONS, protect examples behind %%PORTEXAMPLES%% nntpbtr: this was an unbelievably PITA stage, add missing prototypes, add missing return types, rename patch files to what they actually patch nntpcache: stage support, required lots of Makefile.in patching, call submakes correctly, handle config files properly nzbperl: stage, use OPTIONS, remove obsolete pkg-message papercut: stage, handle config file properly py-pynzb: stage, use OPTIONS helper to avoid bsd.port.options.mk inclusion s-news: stage slrnconf: stage slrnface: stage, install required files to datadir, not examplesdir, generate proper pkg-message sn: stage
Notes
Notes: svn path=/head/; revision=349572
Diffstat (limited to 'news/slrnface')
-rw-r--r--news/slrnface/Makefile19
-rw-r--r--news/slrnface/files/pkg-message.in (renamed from news/slrnface/pkg-message)2
2 files changed, 10 insertions, 11 deletions
diff --git a/news/slrnface/Makefile b/news/slrnface/Makefile
index 621c64e9523d..0bccb147bd5d 100644
--- a/news/slrnface/Makefile
+++ b/news/slrnface/Makefile
@@ -3,7 +3,7 @@
PORTNAME= slrnface
PORTVERSION= 2.1.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= news
MASTER_SITES= ${MASTER_SITE_DEBIAN}
MASTER_SITE_SUBDIR= pool/main/s/${PORTNAME}
@@ -21,16 +21,15 @@ MAKE_ARGS= CC="${CC}" C_FLAGS="${CFLAGS}" \
XF_LIB="-L${LOCALBASE}/lib -lcompface"
USE_XORG= xt
-MAN1= slrnface.1
-PLIST_FILES= bin/slrnface share/examples/slrnface/slrnface.sl
-PLIST_DIRS= share/examples/slrnface
+PLIST_FILES= bin/slrnface man/man1/slrnface.1.gz %%DATADIR%%/slrnface.sl
+PLIST_DIRS= %%DATADIR%%
+
+SUB_FILES= pkg-message
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/slrnface ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/slrnface.1 ${MAN1PREFIX}/man/man1/slrnface.1
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/slrnface.sl ${EXAMPLESDIR}
- @${CAT} ${PKGMESSAGE}
+ ${INSTALL_PROGRAM} ${WRKSRC}/slrnface ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/slrnface.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/slrnface.sl ${STAGEDIR}${DATADIR}
.include <bsd.port.mk>
diff --git a/news/slrnface/pkg-message b/news/slrnface/files/pkg-message.in
index 601fdef47ec5..5c224d06a010 100644
--- a/news/slrnface/pkg-message
+++ b/news/slrnface/files/pkg-message.in
@@ -1,7 +1,7 @@
*********************************************************
Add
- interpret ${PREFIX}/share/examples/slrnface/slrnface.sl
+ interpret %%DATADIR%%/slrnface.sl
to your .slrnrc