aboutsummaryrefslogtreecommitdiff
path: root/news/slrnface
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-05-19 09:15:39 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-05-19 09:15:39 +0000
commit90abca96c12806753ea703b2478118fd4c4c1631 (patch)
treee86ecaf0acac8bdd34d3d37693f60b478eadc7cb /news/slrnface
parent6d0e8077c2c63882605dc18bffc19e659911a17d (diff)
downloadports-90abca96c12806753ea703b2478118fd4c4c1631.tar.gz
ports-90abca96c12806753ea703b2478118fd4c4c1631.zip
Use MAKE_ARGS
Notes
Notes: svn path=/head/; revision=135592
Diffstat (limited to 'news/slrnface')
-rw-r--r--news/slrnface/Makefile3
-rw-r--r--news/slrnface/files/patch-Makefile29
2 files changed, 3 insertions, 29 deletions
diff --git a/news/slrnface/Makefile b/news/slrnface/Makefile
index 717c434ae7f0..180c5ce988aa 100644
--- a/news/slrnface/Makefile
+++ b/news/slrnface/Makefile
@@ -20,6 +20,9 @@ LIB_DEPENDS= compface:${PORTSDIR}/mail/faces
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
ALL_TARGET= slrnface
+MAKE_ARGS= CC="${CC}" C_FLAGS="${CFLAGS}" \
+ X_INCL=-I${X11BASE}/include \
+ XF_LIB="-L${X11BASE}/lib -L${LOCALBASE}/lib -lcompface"
USE_XLIB= yes
diff --git a/news/slrnface/files/patch-Makefile b/news/slrnface/files/patch-Makefile
deleted file mode 100644
index 4e5ce80ac229..000000000000
--- a/news/slrnface/files/patch-Makefile
+++ /dev/null
@@ -1,29 +0,0 @@
---- Makefile.orig Sat Aug 24 23:56:21 2002
-+++ Makefile Fri Sep 6 14:46:38 2002
-@@ -1,21 +1,19 @@
--CC = cc
--
--X_INCL = # location of X include files, if needed
-+X_INCL = -I${X11BASE}/include # location of X include files, if needed
-
- # A lot of popular terminals are brain damaged, so we cannot use X
- # resources for configuration. In those cases Xt routines won't even be
- # called, so you might want to use lazy loading for Xt if your OS supports it.
-
- X_LIBS = -lXt -lX11 # X libs
--XF_LIB = -L/usr/local/lib -lcompface # compface library
--C_FLAGS = -O
-+XF_LIB = -L${X11BASE}/lib -L${LOCALBASE}/lib -lcompface # compface library
-+C_FLAGS = #-O
-
- prefix = /usr/local
-
- # No need to configure anything below.
-
--CFLAGS = $(C_FLAGS) $(X_INCL)
--LDFLAGS = $(XF_LIB) $(X_LIBS)
-+CFLAGS += $(C_FLAGS) $(X_INCL)
-+LDFLAGS += $(XF_LIB) $(X_LIBS)
-
- slrnface: slrnface.c
- $(CC) $(CFLAGS) -o slrnface slrnface.c $(LDFLAGS)