aboutsummaryrefslogtreecommitdiff
path: root/news/tin
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2013-12-27 20:20:30 +0000
committerJohan van Selst <johans@FreeBSD.org>2013-12-27 20:20:30 +0000
commit33d7a827c1f323365126dddbc74236513efd9e35 (patch)
treecf39903ab3826c190d9efe13d282958f80e1925d /news/tin
parent593c57190acbb15b9555e175db993ea7c8598f7f (diff)
downloadports-33d7a827c1f323365126dddbc74236513efd9e35.tar.gz
ports-33d7a827c1f323365126dddbc74236513efd9e35.zip
- Update tin to 2.2.0
- Enable STAGE support
Notes
Notes: svn path=/head/; revision=337797
Diffstat (limited to 'news/tin')
-rw-r--r--news/tin/Makefile25
-rw-r--r--news/tin/distinfo4
-rw-r--r--news/tin/pkg-plist10
3 files changed, 23 insertions, 16 deletions
diff --git a/news/tin/Makefile b/news/tin/Makefile
index a24e22cc13c5..f44d54cd4812 100644
--- a/news/tin/Makefile
+++ b/news/tin/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= tin
-PORTVERSION= 2.0.1
-PORTREVISION?= 3
+PORTVERSION= 2.2.0
CATEGORIES+= news ipv6
MASTER_SITES= ftp://ftp.tin.org/pub/news/clients/tin/v${PORTVERSION:R}/ \
ftp://ftp.sunet.se/pub/news/readers/tin/v${PORTVERSION:R}/ \
@@ -21,14 +20,15 @@ MASTER_SITES= ftp://ftp.tin.org/pub/news/clients/tin/v${PORTVERSION:R}/ \
MAINTAINER?= johans@FreeBSD.org
COMMENT= Easy-to-use threaded newsreader with NOV/NNTP support
-LIB_DEPENDS= uu:${PORTSDIR}/converters/uulib \
- pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= libuu.so:${PORTSDIR}/converters/uulib \
+ libpcre.so:${PORTSDIR}/devel/pcre
RUN_DEPENDS= ${LOCALBASE}/etc/mime.types:${PORTSDIR}/misc/mime-support
USE_BZIP2= yes
-USE_GMAKE= yes
-USES= iconv
+USES= gmake iconv shebangfix
GNU_CONFIGURE= yes
+SHEBANG_FILES= tools/opt-case.pl tools/tinews.pl tools/url_handler.pl \
+ tools/w2r.pl
TIN_EDITOR?= /usr/bin/ee
TIN_SCREEN?= ncursesw
@@ -37,7 +37,6 @@ OPTIONS_DEFAULT=GNUPG ISPELL METAMAIL
CANLOCK_DESC= Enable Cancel-Lock key support via libcanlock
NNTP_ONLY= Only read news via NNTP (no spool dir support)
-NO_STAGE= yes
.include <bsd.port.options.mk>
# --with-mime-default-charset=US-ASCII needed to build tin in the non-ascii
@@ -58,9 +57,6 @@ CFLAGS+= -DNNTP_SERVER_FILE=\\\"${PREFIX}/etc/nntpserver\\\"
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
ALL_TARGET= build
-MAN1= tin.1 w2r.pl.1 opt-case.pl.1 tinews.pl.1 tinurl_handler.pl.1
-MAN5= tin.5 tin_mbox.5 tin_mmdf.5
-MLINKS= tin.1 rtin.1
.if ${PORT_OPTIONS:MNNTP_ONLY}
CONFIGURE_ARGS+= --enable-nntp-only
@@ -121,9 +117,10 @@ post-build:
.endif
post-install:
- cd ${WRKSRC}/doc; ${INSTALL_DATA} tin.defaults ${PREFIX}/etc/tin.defaults.dist
- if [ ! -f ${PREFIX}/etc/tin.defaults ] ; then \
- ${CP} ${PREFIX}/etc/tin.defaults.dist ${PREFIX}/etc/tin.defaults; \
- fi
+ cd ${STAGEDIR}${PREFIX}/etc;\
+ ${INSTALL_DATA} ${WRKSRC}/doc/tin.defaults tin.defaults.dist;\
+ if [ ! -f tin.defaults ] ; then \
+ ${CP} tin.defaults.dist tin.defaults; \
+ fi
.include <bsd.port.mk>
diff --git a/news/tin/distinfo b/news/tin/distinfo
index 9be8c7b2c232..8a9dfc9d830e 100644
--- a/news/tin/distinfo
+++ b/news/tin/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tin-2.0.1.tar.bz2) = eb4c1e46defb66f02eb64daa0929414c6363d9d4d74ec2458cfc6e781de89b1f
-SIZE (tin-2.0.1.tar.bz2) = 1758848
+SHA256 (tin-2.2.0.tar.bz2) = ba25cc3345675810c85cc0bddcce5474370ce91dce91d8433176f0de858b5b44
+SIZE (tin-2.2.0.tar.bz2) = 1836169
diff --git a/news/tin/pkg-plist b/news/tin/pkg-plist
index b4315805cec9..32259226f904 100644
--- a/news/tin/pkg-plist
+++ b/news/tin/pkg-plist
@@ -9,6 +9,15 @@ bin/w2r.pl
@unexec if cmp -s %D/etc/tin.defaults %D/etc/tin.defaults.dist; then rm -f %D/etc/tin.defaults; fi
etc/tin.defaults.dist
@exec [ -f %B/tin.defaults ] || cp %B/%f %B/tin.defaults
+man/man1/opt-case.pl.1.gz
+man/man1/rtin.1.gz
+man/man1/tin.1.gz
+man/man1/tinews.pl.1.gz
+man/man1/tinurl_handler.pl.1.gz
+man/man1/w2r.pl.1.gz
+man/man5/tin.5.gz
+man/man5/tin_mbox.5.gz
+man/man5/tin_mmdf.5.gz
%%NLS%%share/locale/da/LC_MESSAGES/tin.mo
%%NLS%%share/locale/de/LC_MESSAGES/tin.mo
%%NLS%%share/locale/en_GB/LC_MESSAGES/tin.mo
@@ -17,3 +26,4 @@ etc/tin.defaults.dist
%%NLS%%share/locale/ru/LC_MESSAGES/tin.mo
%%NLS%%share/locale/sv/LC_MESSAGES/tin.mo
%%NLS%%share/locale/tr/LC_MESSAGES/tin.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/tin.mo