aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2007-10-07 05:45:04 +0000
committerMark Linimon <linimon@FreeBSD.org>2007-10-07 05:45:04 +0000
commit581e69adb267a46bd059f3252f57fdda449034ef (patch)
tree6116b00d58bb2d3a91aafabcb58642a8c7ebeb58 /news
parent0993ac7ee05fb36834452d01188a887420b86d56 (diff)
Set USE_PERL5/WANT_PERL as appropriate, for ports that either depend on
perl unconditonally, or conditionally. To be able to conditionalize the inclusion of bsd.perl.mk, they now need to be defined before the inclusion of bsd.port.pre.mk. Hat: portmgr
Notes
Notes: svn path=/head/; revision=201032
Diffstat (limited to 'news')
-rw-r--r--news/inn/Makefile1
-rw-r--r--news/newsstar/Makefile22
-rw-r--r--news/ubh/Makefile1
3 files changed, 13 insertions, 11 deletions
diff --git a/news/inn/Makefile b/news/inn/Makefile
index 948ebb2a6f57..eade0431ebd2 100644
--- a/news/inn/Makefile
+++ b/news/inn/Makefile
@@ -22,6 +22,7 @@ LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
USE_GMAKE= yes
USE_OPENSSL= yes
+WANT_PERL= yes
CONFLICTS?= inn-stable-[0-9]* inn-current-[0-9]*
diff --git a/news/newsstar/Makefile b/news/newsstar/Makefile
index 7b5819b9a25c..71c65a2499ad 100644
--- a/news/newsstar/Makefile
+++ b/news/newsstar/Makefile
@@ -16,6 +16,17 @@ COMMENT= Transfer news between a local NNTP server (INN, sn, s-news)
LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm
+USE_PERL5= yes
+HAS_CONFIGURE= yes
+
+CONFIGURE_ARGS+=--prefix=${PREFIX} --mandir=${PREFIX}/man \
+ --with-conf-dir=${PREFIX}/etc/newsstar \
+ --with-rc-dir=/var/spool/newsstar/lib \
+ --with-incoming-dir=/var/spool/newsstar/incoming
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
.if defined(WITHOUT_SSL)
CONFIGURE_ARGS+=--disable-ssl
.else
@@ -39,17 +50,6 @@ CONFIGURE_ARGS+=--with-sn-spool-dir=/var/spool/news \
CONFIGURE_ARGS+=--with-inn-path=${LOCALBASE}/news/bin
.endif
-CONFIGURE_ARGS+=--prefix=${PREFIX} --mandir=${PREFIX}/man \
- --with-conf-dir=${PREFIX}/etc/newsstar \
- --with-rc-dir=/var/spool/newsstar/lib \
- --with-incoming-dir=/var/spool/newsstar/incoming
-
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
-
-USE_PERL5= yes
-HAS_CONFIGURE= yes
-
MAN1= newsstar.1
DOCS= AUTHORS INSTALL NEWS README TODO docs/QuickStart docs/manual.txt \
docs/index.html docs/ar01s02.html docs/ar01s03.html docs/ar01s04.html \
diff --git a/news/ubh/Makefile b/news/ubh/Makefile
index 6c437f5a2713..ddd09a02487d 100644
--- a/news/ubh/Makefile
+++ b/news/ubh/Makefile
@@ -23,6 +23,7 @@ RUN_DEPENDS= \
${SITE_PERL}/${PERL_ARCH}/String/CRC32.pm:${PORTSDIR}/devel/p5-String-CRC32
NO_BUILD= YES
+USE_PERL5= YES
pre-patch:
@${MV} ${WRKSRC}/ubh ${WRKSRC}/ubh.old