aboutsummaryrefslogtreecommitdiff
path: root/palm/coldsync
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2002-12-27 21:11:59 +0000
committerMikhail Teterin <mi@FreeBSD.org>2002-12-27 21:11:59 +0000
commit15c5750d2df45deba13eb9c35fe913c885e79e5a (patch)
tree4e2ff150efb0a210c25a88e806444b30b3529376 /palm/coldsync
parent387237e65e77d406be9573db263dc5e7123145f5 (diff)
downloadports-15c5750d2df45deba13eb9c35fe913c885e79e5a.tar.gz
ports-15c5750d2df45deba13eb9c35fe913c885e79e5a.zip
Upgrade to the latest stable version -- 2.2.5, which supports Palms in
addition to Handspring, so there is no need for patch-palm any more. Remove the Perl parts of this port. They will be turned into the new p5-coldsync. Now, that the port no longer uses Perl, switch back to REINPLACE and rephrase the regexps, so they work (\S was a perlism). Make patch-in6 a little nicer by making coldsync.c define _POSIX_SOURCE as 200112 -- the only way to cause netinet/in.h to include netinet6/in6.h, apparently. Reviewed by: knu (portmgr) Approved by: maintainer, portmgr
Notes
Notes: svn path=/head/; revision=71930
Diffstat (limited to 'palm/coldsync')
-rw-r--r--palm/coldsync/Makefile43
-rw-r--r--palm/coldsync/distinfo2
-rw-r--r--palm/coldsync/files/patch-in636
-rw-r--r--palm/coldsync/files/patch-noperl29
-rw-r--r--palm/coldsync/files/patch-palm27
-rw-r--r--palm/coldsync/pkg-plist25
6 files changed, 90 insertions, 72 deletions
diff --git a/palm/coldsync/Makefile b/palm/coldsync/Makefile
index 0af6dde0ab30..07b73f4d1737 100644
--- a/palm/coldsync/Makefile
+++ b/palm/coldsync/Makefile
@@ -6,46 +6,59 @@
#
PORTNAME= coldsync
-PORTVERSION= 2.1.3
-PORTREVISION= 3
+PORTVERSION= 2.2.5
CATEGORIES= palm comms
MASTER_SITES= http://www.coldsync.org/download/
MAINTAINER= arensb+freebsd-ports@ooblick.com
LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
-RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Palm/PDB.pm:${PORTSDIR}/palm/p5-Palm
-USE_PERL= yes
+USE_REINPLACE= yes
+REINPLACE_ARGS= -i "" -E
GNU_CONFIGURE= yes
-# The ColdSync.3 man page describes a Perl package. That's why it goes
-# in the Perl manpage directory.
-MAN1= send-mail.1 \
- todo-text.1
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-MAN3= ColdSync.3 \
- ColdSync::SPC.3
+MAN3= libpconn.3 DlpAddSyncLogEntry.3 DlpCallApplication.3 \
+ DlpCleanUpDataBase.3 DlpDeleteRecord.3 DlpEndOfSync.3 \
+ DlpGetSysDateTime.3 DlpMoveCategory.3 DlpOpenConduit.3 \
+ DlpOpenDB.3 DlpRPC.3 DlpReadAppBlock.3 \
+ DlpReadAppPreference.3 DlpReadDBList.3 DlpReadFeature.3 \
+ DlpReadNetSyncInfo.3 DlpReadOpenDBInfo.3 \
+ DlpReadRecordByID.3 DlpReadRecordIDList.3 \
+ DlpReadResourceByIndex.3 DlpReadStorageInfo.3 \
+ DlpReadSysInfo.3 DlpReadUserInfo.3 DlpResetRecordIndex.3 \
+ DlpResetSyncFlags.3 DlpResetSystem.3 DlpWriteRecord.3 \
+ DlpWriteResource.3 PConnClose.3 PConn_bind.3 \
+ RDLP_Backlight.3 RDLP_BatteryDialog.3 \
+ RDLP_GetOSVersionString.3 RDLP_MemHandleNew.3 \
+ RDLP_PluggedIn.3 RDLP_ROMToken.3 new_PConnection.3 \
+ time_dlp2palmtime.3 libpdb.3 new_Record.3 \
+ new_pdb.3 pdb_AppendRecord.3 pdb_CopyRecord.3 \
+ pdb_DeleteRecordByID.3 pdb_FindRecordByID.3 \
+ pdb_LoadHeader.3 pdb_Read.3
MAN8= coldsync.8
MANCOMPRESSED= no
.include <bsd.port.pre.mk>
CFLAGS+= -D__BSD_VISIBLE=1
-CONFIGURE_ARGS+= --with-i18n --disable-pedantic
+CONFIGURE_ARGS+= --with-i18n --disable-pedantic --without-perl
# I don't know how to test for a version of {Net,Open}BSD that supports USB.
.if ${OPSYS} == "FreeBSD" && ${OSVERSION} >= 400000
CONFIGURE_ARGS+= --with-usb
.if ${OSVERSION} >= 450000
post-patch:
- ${PERL} -pi -e 's,udi\.(\S+),udi.udi_\1,g;' \
- -e 's,ur\.(\S+),ur.ucr_\1,g;' \
+ ${REINPLACE_CMD} -e 's,udi\.([A-Za-z0-9]+),udi.udi_\1,g;' \
+ -e 's,ur\.([A-Za-z0-9]+),ur.ucr_\1,g;' \
${WRKSRC}/configure ${WRKSRC}/libpconn/PConnection_usb.c
.endif
.endif
post-install:
- @install-info ${PREFIX}/info/conduits.info ${PREFIX}/info/dir
+ install-info ${PREFIX}/info/conduits.info ${PREFIX}/info/dir
+ ${MKDIR} ${PREFIX}/include/pconn
+ ${INSTALL_DATA} ${WRKSRC}/include/*.h ${PREFIX}/include/
+ ${INSTALL_DATA} ${WRKSRC}/include/pconn/*.h ${PREFIX}/include/pconn/
.include <bsd.port.post.mk>
diff --git a/palm/coldsync/distinfo b/palm/coldsync/distinfo
index 7f130990a75b..a78eac7eaf8b 100644
--- a/palm/coldsync/distinfo
+++ b/palm/coldsync/distinfo
@@ -1 +1 @@
-MD5 (coldsync-2.1.3.tar.gz) = c811081a2020acd8b6cb2a9d3d7414ec
+MD5 (coldsync-2.2.5.tar.gz) = cba1d751a51d50a1983a7e0245820099
diff --git a/palm/coldsync/files/patch-in6 b/palm/coldsync/files/patch-in6
index 1c236a50dd00..861eb4d585af 100644
--- a/palm/coldsync/files/patch-in6
+++ b/palm/coldsync/files/patch-in6
@@ -1,23 +1,17 @@
---- libpconn/PConnection_net.c Sun Apr 15 06:33:56 2001
-+++ libpconn/PConnection_net.c Wed Dec 25 20:09:52 2002
-@@ -10,5 +10,7 @@
- #include <string.h> /* For bzero() */
- #include <arpa/nameser.h> /* Solaris's <resolv.h> requires this */
-+#ifndef __FreeBSD__ /* resolv.h without in6.h blows up on FreeBSD */
- #include <resolv.h> /* For inet_ntop() under Solaris */
-+#endif
-
- #if HAVE_LIBINTL_H
---- src/coldsync.c Tue May 15 15:23:40 2001
-+++ src/coldsync.c Wed Dec 25 20:12:40 2002
-@@ -25,5 +25,9 @@
-
- #include <arpa/nameser.h> /* Solaris's <resolv.h> requires this */
+--- libpconn/PConnection_net.c Mon Nov 19 18:08:06 2001
++++ libpconn/PConnection_net.c Thu Dec 26 08:02:24 2002
+@@ -11,5 +11,5 @@
+ #include <netdb.h> /* For getservbyname() */
+ #include <string.h> /* For memset() */
+-#if HAVE_INET_NTOP
++#if HAVE_INET_NTOP && !defined(__FreeBSD__)
+ # include <arpa/nameser.h> /* Solaris's <resolv.h> requires this */
+ # include <resolv.h> /* For inet_ntop() under Solaris */
+--- src/coldsync.c Wed Nov 28 16:48:44 2001
++++ src/coldsync.c Thu Dec 26 08:26:47 2002
+@@ -8,2 +8,5 @@
+ */
+#ifdef __FreeBSD__
-+#define __KAME_NETINET_IN_H_INCLUDED_
-+#include <netinet6/in6.h>
-+#undef __KAME_NETINET_IN_H_INCLUDED_ /* XXX: you are welcome to fix this */
--#include <resolv.h> /* For inet_ntop() under Solaris */
++# define _POSIX_C_SOURCE 200112
+#endif
- #include <unistd.h> /* For sleep(), getopt() */
- #include <ctype.h> /* For isalpha() and friends */
+ #include "config.h"
diff --git a/palm/coldsync/files/patch-noperl b/palm/coldsync/files/patch-noperl
new file mode 100644
index 000000000000..b26d7a3666e1
--- /dev/null
+++ b/palm/coldsync/files/patch-noperl
@@ -0,0 +1,29 @@
+--- Makefile Mon Jun 4 06:18:28 2001
++++ Makefile Fri Dec 27 09:31:00 2002
+@@ -16,3 +16,3 @@
+ # Note that $(PERLDIR) is expanded in Make.rules.
+-SUBDIRS = include libpconn libpdb src $(PERLDIR) conduits doc i18n
++SUBDIRS = include libpconn libpdb src $(PERLDIRS) doc i18n
+
+--- Make.rules.in Mon Nov 19 12:05:33 2001
++++ Make.rules.in Fri Dec 27 09:30:15 2002
+@@ -40,3 +40,3 @@
+ # Subdirectory containing the Perl modules. Used by "configure --without-perl"
+-PERLDIR = @PERLDIR@
++PERLDIRS = @PERLDIRS@
+
+--- configure Fri Dec 7 10:24:39 2001
++++ configure Fri Dec 27 09:29:28 2002
+@@ -3939,5 +3939,5 @@
+ # Name of Perl subdirectory
+- PERLDIR=perl
++ PERLDIRS="perl conduits"
+ else
+- PERLDIR=""
++ PERLDIRS=""
+ fi
+@@ -4303,3 +4303,3 @@
+ s%@LIBYACC@%$LIBYACC%g
+-s%@PERLDIR@%$PERLDIR%g
++s%@PERLDIRS@%$PERLDIRS%g
+ s%@CONDUITDIR@%$CONDUITDIR%g
diff --git a/palm/coldsync/files/patch-palm b/palm/coldsync/files/patch-palm
deleted file mode 100644
index 1e63f83b2bcc..000000000000
--- a/palm/coldsync/files/patch-palm
+++ /dev/null
@@ -1,27 +0,0 @@
-Index: libpconn/PConnection_usb.c
-===================================================================
-RCS file: /var/lib/cvs/coldsync/libpconn/PConnection_usb.c,v
-retrieving revision 1.26
-retrieving revision 1.27
-diff -u -r1.26 -r1.27
---- libpconn/PConnection_usb.c 30 Jul 2001 07:23:56 -0000 1.26
-+++ libpconn/PConnection_usb.c 20 Aug 2001 09:13:00 -0000 1.27
-@@ -94,6 +94,7 @@
- #define hs_usbfun_MAX 4
-
- #define HANDSPRING_VENDOR_ID 0x082d
-+#define PALM_VENDOR_ID 0x0830
-
- static char *hs_usb_functions[] = {
- "Generic",
-@@ -505,7 +506,9 @@
-
- }
-
-- if (udi.vendorNo != HANDSPRING_VENDOR_ID) {
-+ if ((udi.vendorNo != HANDSPRING_VENDOR_ID) &&
-+ (udi.vendorNo != PALM_VENDOR_ID))
-+ {
- fprintf(stderr,
- _("%s: Warning: Unexpected USB vendor ID %#x.\n"),
- "pconn_usb_open", udi.vendorNo);
diff --git a/palm/coldsync/pkg-plist b/palm/coldsync/pkg-plist
index f203b4be1e46..ff9e4e88845b 100644
--- a/palm/coldsync/pkg-plist
+++ b/palm/coldsync/pkg-plist
@@ -1,18 +1,27 @@
bin/coldsync
-lib/perl5/site_perl/%%PERL_VER%%/ColdSync.pm
-lib/perl5/site_perl/%%PERL_VER%%/ColdSync/SPC.pm
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/ColdSync
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/ColdSync/.packlist
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/ColdSync
-libexec/coldsync/send-mail
-libexec/coldsync/todo-text
-@dirrm libexec/coldsync
etc/sample.coldsync.rc
@unexec install-info --delete %D/info/conduits.info %D/info/dir
info/conduits.info
info/conduits.info-1
info/conduits.info-2
@exec install-info %D/info/conduits.info %D/info/dir
+share/locale/cs/LC_MESSAGES/coldsync.mo
share/locale/de/LC_MESSAGES/coldsync.mo
share/locale/fr/LC_MESSAGES/coldsync.mo
share/locale/it/LC_MESSAGES/coldsync.mo
+include/palm.h
+include/pdb.h
+include/pconn/util.h
+include/pconn/slp.h
+include/pconn/pconn.h
+include/pconn/palm_types.h
+include/pconn/palm_errno.h
+include/pconn/padp.h
+include/pconn/dlp_rpc.h
+include/pconn/dlp_cmd.h
+include/pconn/dlp.h
+include/pconn/cmp.h
+include/pconn/netsync.h
+include/pconn/PConnection.h
+include/pconn/spc_client.h
+@dirrm include/pconn