aboutsummaryrefslogtreecommitdiff
path: root/polish/fortunepl
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-06-26 20:26:48 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-06-26 20:26:48 +0000
commite4c7ebc3c42868f16899c3e00d2c7647974c6c70 (patch)
treec1079ad86c93adb507866ddb0668d6be4a5f688d /polish/fortunepl
parent3661a0aaf709872ef6a3b6a98df08bb7360ec539 (diff)
downloadports-e4c7ebc3c42868f16899c3e00d2c7647974c6c70.tar.gz
ports-e4c7ebc3c42868f16899c3e00d2c7647974c6c70.zip
- Add staging support
- Unmute install commands
Notes
Notes: svn path=/head/; revision=359418
Diffstat (limited to 'polish/fortunepl')
-rw-r--r--polish/fortunepl/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/polish/fortunepl/Makefile b/polish/fortunepl/Makefile
index 68fc0da69e68..73f56dec8170 100644
--- a/polish/fortunepl/Makefile
+++ b/polish/fortunepl/Makefile
@@ -12,7 +12,7 @@ PATCHFILES= fortunes-pl_${PORTVERSION}.freebsd.pl \
fortunes-pl_${PORTVERSION}.filozofia
MAINTAINER= ports@FreeBSD.org
-COMMENT= A lot of funny Polish fortune files
+COMMENT= Lot of funny Polish fortune files
STRCMD= /usr/games/strfile
WRKSRC= ${WRKDIR}/fortunes-pl-${PORTVERSION}.orig
@@ -28,7 +28,6 @@ FORTUNES= 7thguard advocacy apcoh argante bajki bok cnp cows \
teleturnieje testnaosobowosc wierszyki wieza-pilot zen \
znaki_zodiaku
-NO_STAGE= yes
pre-everything::
.if !exists(${STRCMD})
IGNORE= need strfile command. Please install games distribution of base system
@@ -44,13 +43,12 @@ do-build:
.endfor
do-install:
- @${MKDIR} ${PREFIX}/share/games
- @${MKDIR} ${PREFIX}/share/games/fortune
- @${MKDIR} ${PREFIX}/share/games/fortune/pl
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/games/fortune/pl
.for FILE in ${FORTUNES}
- @${ECHO_CMD} "Installing ${FILE} into ${PREFIX}/share/games/fortune/pl/"
- @${INSTALL_DATA} ${WRKSRC}/${FILE} ${PREFIX}/share/games/fortune/pl
- @${INSTALL_DATA} ${WRKSRC}/${FILE}.dat ${PREFIX}/share/games/fortune/pl
+ ${INSTALL_DATA} ${WRKSRC}/${FILE} \
+ ${STAGEDIR}${PREFIX}/share/games/fortune/pl
+ ${INSTALL_DATA} ${WRKSRC}/${FILE}.dat \
+ ${STAGEDIR}${PREFIX}/share/games/fortune/pl
.endfor
post-install: