aboutsummaryrefslogtreecommitdiff
path: root/polish/kadu/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2009-03-15 20:13:00 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2009-03-15 20:13:00 +0000
commita37b051f639c7ad6113045af3cd1b01dbb2dc74a (patch)
tree9926633abd1bde0e5499f3cec8a5aa099b02874e /polish/kadu/Makefile
parentb41ed32bc92b5807f9ca7ff3c98095d1a51dca28 (diff)
downloadports-a37b051f639c7ad6113045af3cd1b01dbb2dc74a.tar.gz
ports-a37b051f639c7ad6113045af3cd1b01dbb2dc74a.zip
Notes
Diffstat (limited to 'polish/kadu/Makefile')
-rw-r--r--polish/kadu/Makefile67
1 files changed, 27 insertions, 40 deletions
diff --git a/polish/kadu/Makefile b/polish/kadu/Makefile
index 9030b0ddbaa7..b7a0f7ab7b1c 100644
--- a/polish/kadu/Makefile
+++ b/polish/kadu/Makefile
@@ -6,14 +6,14 @@
#
PORTNAME= kadu
-PORTVERSION= 0.6.0.2
+PORTVERSION= 0.6.5.1
PORTEPOCH= 1
CATEGORIES= polish net-im
MASTER_SITES= http://www.kadu.net/download/stable/:kadu \
http://www.kadu.net/download/additions/:additions \
http://www.kadu.net/download/modules_extra/spellchecker/:aspell \
http://www.kadu.net/download/modules_mirror/:modules \
- http://kadu.net/~arvenil/tabs/download/${PORTVERSION}/:modtab
+ http://kadu.net/~arvenil/tabs/download/${PORTVERSION:C/(([0-9]+\.){2}[0-9]+)(.*)/\1/}/:modtab
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:kadu
DIST_SUBDIR= kadu
EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
@@ -21,42 +21,49 @@ EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= mwisnicki+freebsd@gmail.com
COMMENT= QT Gadu-Gadu client
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
LIB_DEPENDS= gadu.3:${PORTSDIR}/polish/libgadu\
sndfile.1:${PORTSDIR}/audio/libsndfile
+# TODO enable devel/libexecinfo
-TABS_MOD_DISTFILE= kadu-tabs-1.1.6.tar.bz2
-ASPELL_MOD_DISTFILE= spellchecker-20071230.tar.bz2
+TABS_MOD_DISTFILE= kadu-tabs-1.2.3.tar.bz2
+ASPELL_MOD_DISTFILE= spellchecker-20080821.tar.bz2
GG6_EMOTS_DISTFILE= kompatybilne_z_GG6.tar.gz
GG7_EMOTS_DISTFILE= dodatkowe_emoty_GG7.tar.gz
USE_BZIP2= yes
-USE_GMAKE= yes
+USE_CMAKE= yes
+# remove option with typo when they fix it
+CMAKE_ARGS= -DENABLE_AUTDOWNLOAD:BOOL=OFF \
+ -DENABLE_AUTODOWNLOAD:BOOL=OFF
+CMAKE_USE_PTHREAD= yes
USE_OPENSSL= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --with-existing-libgadu="${LOCALBASE}" \
- --with-includes="${LOCALBASE}/include" \
- --with-libs="${LOCALBASE}/lib" \
- --program-transform-name='' \
- --disable-autodownload
-CONFIGURE_ENV= QTDIR="${QT_PREFIX}"
-
-USE_QT_VER= 3
-QT_NONSTANDARD= yes
+
+USE_QT_VER= 4
+QT_COMPONENTS= gui dbus linguist network qt3support webkit xml \
+ qmake_build moc_build rcc_build uic_build
WANT_GNOME= yes
INSTALLS_ICONS= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
-OPTIONS= ASPELL "Build spell checking module" off \
+OPTIONS= AO "Build AO sound module" off \
+ ASPELL "Build spell checking module" off \
ARTS "Build aRts sound module" off \
- ESOUND "Build Esound module" off \
GG_EMOTS "Install GG-compatible emoticons" off \
- PHEADERS "Use precompiled headers to speed up build" on \
TABS "Build tabs module" off
.include <bsd.port.pre.mk>
+.if defined(WITH_AO)
+LIB_DEPENDS+= ao.3:${PORTSDIR}/audio/libao
+PLIST_SUB+= AO_SOUND_MOD=""
+KADU_SHARED_MODULES+= ao_sound
+.else
+PLIST_SUB+= AO_SOUND_MOD="@comment "
+.endif
+
.if defined(WITH_ASPELL)
LIB_DEPENDS+= aspell.16:${PORTSDIR}/textproc/aspell
PLIST_SUB+= ASPELL_MOD=""
@@ -74,14 +81,6 @@ KADU_SHARED_MODULES+= arts_sound
PLIST_SUB+= ARTS_MOD="@comment "
.endif
-.if defined(WITH_ESOUND)
-USE_GNOME+= esound
-PLIST_SUB+= ESOUND_MOD=""
-KADU_SHARED_MODULES+= esd_sound
-.else
-PLIST_SUB+= ESOUND_MOD="@comment "
-.endif
-
.if defined(WITH_GG_EMOTS)
PLIST_SUB+= GG_EMOTS=""
DISTFILES+= ${GG6_EMOTS_DISTFILE}:additions \
@@ -90,10 +89,6 @@ DISTFILES+= ${GG6_EMOTS_DISTFILE}:additions \
PLIST_SUB+= GG_EMOTS="@comment "
.endif
-.if !defined(WITHOUT_PHEADERS)
-CONFIGURE_ARGS+= --enable-pheaders
-.endif
-
.if defined(WITH_TABS)
PLIST_SUB+= TABS_MOD=""
DISTFILES+= ${TABS_MOD_DISTFILE}:modtab
@@ -105,23 +100,20 @@ PLIST_SUB+= TABS_MOD="@comment "
KADU_DISABLED_MODULES= alsa_sound
post-patch:
-
+ @${FIND} ${WRKSRC} -exec ${GREP} -q "#!/bin/bash" {} \; \
+ -exec ${REINPLACE_CMD} -e 's|#!/bin/bash|#!/usr/bin/env bash|g' {} \;
.for module in ${KADU_DISABLED_MODULES}
@${REINPLACE_CMD} -e 's|module_${module}=.|module_${module}=n|g' ${WRKSRC}/.config
.endfor
-
.for module in ${KADU_SHARED_MODULES}
@${REINPLACE_CMD} -e 's|module_${module}=.|module_${module}=m|g' ${WRKSRC}/.config
.endfor
-
.for module in ${KADU_STATIC_MODULES}
@${REINPLACE_CMD} -e 's|module_${module}=.|module_${module}=y|g' ${WRKSRC}/.config
.endfor
-
.if defined(WITH_ASPELL)
@cd ${WRKSRC}/modules && ${TAR} -zxf ${_DISTDIR}/${ASPELL_MOD_DISTFILE}
.endif
-
.if defined(WITH_GG_EMOTS)
@${REINPLACE_CMD} -e 's|emoticons_gg6_compatible=n|emoticons_gg6_compatible=y|g' ${WRKSRC}/.config
@cd ${WRKSRC}/varia/themes/emoticons && \
@@ -129,13 +121,8 @@ post-patch:
${MV} kompatybilne_z_GG6 gg6_compatible && \
cd gg6_compatible && ${TAR} -zxf ${_DISTDIR}/${GG7_EMOTS_DISTFILE}
.endif
-
.if defined(WITH_TABS)
@cd ${WRKSRC}/modules && ${TAR} -zxf ${_DISTDIR}/${TABS_MOD_DISTFILE}
.endif
-post-install:
- ${MKDIR} ${PREFIX}/share/applications
- ${INSTALL_DATA} ${WRKSRC}/kadu-core/kadu.desktop ${PREFIX}/share/applications
-
.include <bsd.port.post.mk>