aboutsummaryrefslogtreecommitdiff
path: root/polish/kadu
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-12-30 20:39:20 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-12-30 20:39:20 +0000
commitaa15b59fa5d0ebff194a5d3c88f66b1e2970e7db (patch)
tree1195bfe43a98af2a2f55b374e158c8df5f0aef61 /polish/kadu
parent05292de616938cf17ec289491b0d7a75339253be (diff)
downloadports-aa15b59fa5d0ebff194a5d3c88f66b1e2970e7db.tar.gz
ports-aa15b59fa5d0ebff194a5d3c88f66b1e2970e7db.zip
Add a patch (submitted upstream) to make the port build with CMake 3.1.0.
Use the proper syntax for configure_package_config_file(). Verified to also work with CMake 3.0.2.
Notes
Notes: svn path=/head/; revision=375855
Diffstat (limited to 'polish/kadu')
-rw-r--r--polish/kadu/files/patch-CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/polish/kadu/files/patch-CMakeLists.txt b/polish/kadu/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..274051887d7b
--- /dev/null
+++ b/polish/kadu/files/patch-CMakeLists.txt
@@ -0,0 +1,29 @@
+Submitted upstream: https://gitorious.org/kadu/kadu/merge_requests/2121
+
+Make the call to configure_package_config_file work with CMake 3.1.0.
+
+configure_package_config_file()'s PATH_VARS option expects several
+separate variable names instead of one list with all the names. Passing
+the values in the expected format fixes the following error:
+
+CMake Error at /usr/local/share/cmake/Modules/CMakePackageConfigHelpers.cmake:231 (message):
+ Unknown keywords given to CONFIGURE_PACKAGE_CONFIG_FILE():
+ "INCLUDE_DIR;SDK_DIR"
+Call Stack (most recent call first):
+ CMakeLists.txt:226 (configure_package_config_file)
+ CMakeLists.txt:279 (kadu_configure_package_config_file)
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -221,11 +221,10 @@
+ elseif ("${_mode}" STREQUAL INSTALL_TREE)
+ set (INCLUDE_DIR "${INSTALL_INCLUDE_DIR}")
+ set (SDK_DIR "${INSTALL_SDK_DIR}")
+- list (APPEND path_vars INCLUDE_DIR SDK_DIR)
+
+ configure_package_config_file ("${_in}" "${_out}"
+ INSTALL_DESTINATION "${INSTALL_CMAKE_DIR}"
+- PATH_VARS ${path_vars}
++ PATH_VARS INCLUDE_DIR SDK_DIR
+ NO_SET_AND_CHECK_MACRO NO_CHECK_REQUIRED_COMPONENTS_MACRO
+ )
+ endif ()