aboutsummaryrefslogtreecommitdiff
path: root/polish/kadu
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-12-30 22:58:07 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-12-30 22:58:07 +0000
commitb7f002f59250ed10d6d2888f8dc79d60bb563f1d (patch)
tree68ea240a1ba2a4d2ecccfb7209928ef1fa89ec9e /polish/kadu
parenteb5093ea5dffe7a7295881f24a778746fda58835 (diff)
downloadports-b7f002f59250ed10d6d2888f8dc79d60bb563f1d.tar.gz
ports-b7f002f59250ed10d6d2888f8dc79d60bb563f1d.zip
Revert r375855 for now.
The issue with CMake 3.1.0 is actually something else. Back the change out for now while a proper fix is being worked on.
Notes
Notes: svn path=/head/; revision=375861
Diffstat (limited to 'polish/kadu')
-rw-r--r--polish/kadu/files/patch-CMakeLists.txt29
1 files changed, 0 insertions, 29 deletions
diff --git a/polish/kadu/files/patch-CMakeLists.txt b/polish/kadu/files/patch-CMakeLists.txt
deleted file mode 100644
index 274051887d7b..000000000000
--- a/polish/kadu/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,29 +0,0 @@
-Submitted upstream: https://gitorious.org/kadu/kadu/merge_requests/2121
-
-Make the call to configure_package_config_file work with CMake 3.1.0.
-
-configure_package_config_file()'s PATH_VARS option expects several
-separate variable names instead of one list with all the names. Passing
-the values in the expected format fixes the following error:
-
-CMake Error at /usr/local/share/cmake/Modules/CMakePackageConfigHelpers.cmake:231 (message):
- Unknown keywords given to CONFIGURE_PACKAGE_CONFIG_FILE():
- "INCLUDE_DIR;SDK_DIR"
-Call Stack (most recent call first):
- CMakeLists.txt:226 (configure_package_config_file)
- CMakeLists.txt:279 (kadu_configure_package_config_file)
---- CMakeLists.txt
-+++ CMakeLists.txt
-@@ -221,11 +221,10 @@
- elseif ("${_mode}" STREQUAL INSTALL_TREE)
- set (INCLUDE_DIR "${INSTALL_INCLUDE_DIR}")
- set (SDK_DIR "${INSTALL_SDK_DIR}")
-- list (APPEND path_vars INCLUDE_DIR SDK_DIR)
-
- configure_package_config_file ("${_in}" "${_out}"
- INSTALL_DESTINATION "${INSTALL_CMAKE_DIR}"
-- PATH_VARS ${path_vars}
-+ PATH_VARS INCLUDE_DIR SDK_DIR
- NO_SET_AND_CHECK_MACRO NO_CHECK_REQUIRED_COMPONENTS_MACRO
- )
- endif ()