aboutsummaryrefslogtreecommitdiff
path: root/polish/qnapi
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2015-08-16 22:02:28 +0000
committerPawel Pekala <pawel@FreeBSD.org>2015-08-16 22:02:28 +0000
commit294c3de5f5140e16af62468f4a21f7d9b257a285 (patch)
tree31f6ce73280feb6016a37fe832843b1b09ad0fef /polish/qnapi
parentee334f5be9935efa9e2b3547bef32551e8cc205f (diff)
downloadports-294c3de5f5140e16af62468f4a21f7d9b257a285.tar.gz
ports-294c3de5f5140e16af62468f4a21f7d9b257a285.zip
- Update to version 1.8, now Qt5 based
- Development moved to GitHub - Drop INSTALLS_ICONS, it's for Gtk apps - Install all desktop files into DESKTOPDIR to be more desktop agnostic
Notes
Notes: svn path=/head/; revision=394428
Diffstat (limited to 'polish/qnapi')
-rw-r--r--polish/qnapi/Makefile27
-rw-r--r--polish/qnapi/distinfo4
-rw-r--r--polish/qnapi/files/patch-qnapi.pro82
-rw-r--r--polish/qnapi/pkg-descr6
-rw-r--r--polish/qnapi/pkg-plist4
5 files changed, 50 insertions, 73 deletions
diff --git a/polish/qnapi/Makefile b/polish/qnapi/Makefile
index 9c02654e52c4..ea10b2cb0bd9 100644
--- a/polish/qnapi/Makefile
+++ b/polish/qnapi/Makefile
@@ -2,37 +2,34 @@
# $FreeBSD$
PORTNAME= qnapi
-DISTVERSION= 0.1.6-rc2
-PORTREVISION= 1
+PORTVERSION= 0.1.8
CATEGORIES= polish multimedia
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTNAME}/
MAINTAINER= pawel@FreeBSD.org
-COMMENT= Qt4 based subtitle downloader
+COMMENT= Qt5 based subtitle downloader
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/doc/LICENSE
+BUILD_DEPENDS= libmaia>0:${PORTSDIR}/net/libmaia
RUN_DEPENDS= 7z:${PORTSDIR}/archivers/p7zip
-USES= qmake
-USE_QT4= corelib gui network xml moc_build uic_build rcc_build
-USE_KDE4= # dummy
-PLIST_SUB= KDE4=${KDE4_PREFIX:S|${LOCALBASE}/||}
-QMAKE_ARGS= KDE4_PREFIX=${KDE4_PREFIX}
-INSTALLS_ICONS= yes
+USE_GITHUB= yes
-PORTDOCS= ChangeLog README.pl COPYRIGHT
+USES= qmake
+USE_QT5= buildtools_build gui network widgets xml
-OPTIONS_DEFINE= DOCS
+CXXFLAGS+= -I${LOCALBASE}/include/maia
+QMAKE_ARGS= LIBS=-lmaia
post-patch:
@${REINPLACE_CMD} 's|/usr/share/icons/||g' \
${WRKSRC}/doc/qnapi.desktop \
${WRKSRC}/doc/qnapi-download.desktop \
- ${WRKSRC}/doc/qnapi-download.schemas
+ ${WRKSRC}/doc/qnapi-scan.desktop
post-install:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/doc/|g} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}/doc && ${INSTALL_DATA} qnapi-download.desktop \
+ qnapi-scan.desktop ${STAGEDIR}${DESKTOPDIR})
.include <bsd.port.mk>
diff --git a/polish/qnapi/distinfo b/polish/qnapi/distinfo
index c58f36eb0bba..3edc2710b3ea 100644
--- a/polish/qnapi/distinfo
+++ b/polish/qnapi/distinfo
@@ -1,2 +1,2 @@
-SHA256 (qnapi-0.1.6-rc2.tar.gz) = a2ae2d0b5d800565493c8840f5f584d480daaee1f01742689d927fdf68c5150a
-SIZE (qnapi-0.1.6-rc2.tar.gz) = 211567
+SHA256 (qnapi-qnapi-0.1.8_GH0.tar.gz) = d74f2a2cf95ff2a39cdbf8164453a16cb17a9455add2971335d65281ecc35aea
+SIZE (qnapi-qnapi-0.1.8_GH0.tar.gz) = 1199273
diff --git a/polish/qnapi/files/patch-qnapi.pro b/polish/qnapi/files/patch-qnapi.pro
index d9370b5abe2d..68c3119c9c74 100644
--- a/polish/qnapi/files/patch-qnapi.pro
+++ b/polish/qnapi/files/patch-qnapi.pro
@@ -1,52 +1,32 @@
---- qnapi.pro.orig 2009-02-28 21:13:01.000000000 +0100
-+++ qnapi.pro 2013-02-14 20:22:45.000000000 +0100
-@@ -91,6 +91,7 @@
- RCC_DIR = tmp
- OBJECTS_DIR = tmp
- INCLUDEPATH = src
-+QMAKE_CXXFLAGS_RELEASE =
- macx {
- QMAKE_MAC_SDK = /Developer/SDKs/MacOSX10.4u.sdk
- CONFIG += x86 ppc
-@@ -102,7 +103,7 @@
- QMAKE_BUNDLE_DATA += 7ZIP_BINARY
- }
- unix {
-- INSTALL_PREFIX = /usr
-+ INSTALL_PREFIX = $$PREFIX
- target.path = $${INSTALL_PREFIX}/bin
- doc.path = $${INSTALL_PREFIX}/share/doc/$${TARGET}
- doc.files = doc/ChangeLog \
-@@ -114,27 +115,24 @@
- doc/COPYRIGHT \
- doc/qnapi-download.desktop \
- doc/qnapi-download.schemas
-- man.path = $${INSTALL_PREFIX}/share/man/man1
-+ man.path = $${INSTALL_PREFIX}/man/man1
- man.files = doc/$${TARGET}.1.gz
-- icons.path = /usr/share/icons
-+ icons.path = $${INSTALL_PREFIX}/share/icons
- icons.files = res/qnapi.png res/qnapi-48.png res/qnapi-128.png res/qnapi-512.png
-- desktop.path = /usr/share/applications
-+ desktop.path = $${INSTALL_PREFIX}/share/applications
- desktop.files = doc/$${TARGET}.desktop
- dolphin_integration.path = /usr/share/apps/dolphin/servicemenus
- dolphin_integration.files = doc/$${TARGET}-download.desktop
- d3lphin_integration.path = /usr/share/apps/d3lphin/servicemenus
- d3lphin_integration.files = doc/$${TARGET}-download.desktop
-- konqueror_integration.path = /usr/share/apps/konqueror/servicemenus
-+ konqueror_integration.path = $${INSTALL_PREFIX}/share/apps/konqueror/servicemenus
- konqueror_integration.files = doc/$${TARGET}-download.desktop
-- kde4_integration.path = /usr/lib/kde4/share/kde4/services/ServiceMenus
-+ kde4_integration.path = $$KDE4_PREFIX/share/kde4/services/ServiceMenus
- kde4_integration.files = doc/$${TARGET}-download.desktop
- INSTALLS = target \
-- doc \
- man \
- icons \
- desktop \
-- dolphin_integration \
-- d3lphin_integration \
- konqueror_integration \
- kde4_integration
+--- qnapi.pro.orig 2015-08-08 19:45:00 UTC
++++ qnapi.pro
+@@ -118,7 +118,7 @@ macx {
}
+
+ unix {
+- INSTALL_PREFIX = /usr
++ INSTALL_PREFIX = $${PREFIX}
+ target.path = $${INSTALL_PREFIX}/bin
+ doc.path = $${INSTALL_PREFIX}/share/doc/$${TARGET}
+ doc.files = doc/ChangeLog \
+@@ -129,17 +129,16 @@ unix {
+ doc/qnapi-scan.desktop \
+ doc/qnapi-download.schemas \
+ doc/qnapi-scan.schemas
+- man.path = $${INSTALL_PREFIX}/share/man/man1
++ man.path = $${INSTALL_PREFIX}/man/man1
+ man.files = doc/$${TARGET}.1.gz
+- icons.path = /usr/share/icons
++ icons.path = $${INSTALL_PREFIX}/share/icons
+ icons.files = res/qnapi.png \
+ res/qnapi-48.png \
+ res/qnapi-128.png \
+ res/qnapi-512.png
+- desktop.path = /usr/share/applications
++ desktop.path = $${INSTALL_PREFIX}/share/applications
+ desktop.files = doc/$${TARGET}.desktop
+ INSTALLS = target \
+- doc \
+ man \
+ icons \
+ desktop
diff --git a/polish/qnapi/pkg-descr b/polish/qnapi/pkg-descr
index d413f29ec47b..788686fd3a2d 100644
--- a/polish/qnapi/pkg-descr
+++ b/polish/qnapi/pkg-descr
@@ -1,5 +1,5 @@
-Free, Qt4-based application designed for automatically downloading and
+Free, Qt5-based application designed for automatically downloading and
matching subtitles for your movie files.
-It uses NapiProjekt and OpenSubtitles databases.
+It uses NapiProjekt, Napisy24 and OpenSubtitles databases.
-WWW: http://sourceforge.net/projects/qnapi/
+WWW: http://qnapi.github.io/
diff --git a/polish/qnapi/pkg-plist b/polish/qnapi/pkg-plist
index ce670c4f96df..e52ede1e730c 100644
--- a/polish/qnapi/pkg-plist
+++ b/polish/qnapi/pkg-plist
@@ -1,8 +1,8 @@
bin/qnapi
-%%KDE4%%/share/kde4/services/ServiceMenus/qnapi-download.desktop
man/man1/qnapi.1.gz
+share/applications/qnapi-download.desktop
+share/applications/qnapi-scan.desktop
share/applications/qnapi.desktop
-share/apps/konqueror/servicemenus/qnapi-download.desktop
share/icons/qnapi-128.png
share/icons/qnapi-48.png
share/icons/qnapi-512.png