aboutsummaryrefslogtreecommitdiff
path: root/polish/qnapi
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-12-21 18:01:16 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-12-21 18:01:16 +0000
commit6e57a40b90beda20c54190b270c9b8cd8a74ce76 (patch)
treeee2a17034d971feaca9bf77468715cb7bae433ae /polish/qnapi
parentc391b20b918c487ffa4606aec5517ab6702619fb (diff)
downloadports-6e57a40b90beda20c54190b270c9b8cd8a74ce76.tar.gz
ports-6e57a40b90beda20c54190b270c9b8cd8a74ce76.zip
- Update to version 1.6-rc2
- Add missing deps - Don't install 3 copies of licensing terms - Replace patches with REINPLACE_CMD - Add port description, new homepage - old one seems dead
Notes
Notes: svn path=/head/; revision=309368
Diffstat (limited to 'polish/qnapi')
-rw-r--r--polish/qnapi/Makefile37
-rw-r--r--polish/qnapi/distinfo4
-rw-r--r--polish/qnapi/files/patch-doc-qnapi.desktop11
-rw-r--r--polish/qnapi/files/patch-doc-qnapi_download.desktop17
-rw-r--r--polish/qnapi/files/patch-doc-qnapi_download.schemas11
-rw-r--r--polish/qnapi/files/patch-src-napi.h20
-rw-r--r--polish/qnapi/pkg-descr6
7 files changed, 28 insertions, 78 deletions
diff --git a/polish/qnapi/Makefile b/polish/qnapi/Makefile
index 9ed39fffc596..47cdca4c3b5a 100644
--- a/polish/qnapi/Makefile
+++ b/polish/qnapi/Makefile
@@ -1,24 +1,30 @@
-# New ports collection makefile for: qnapi
-# Date created: 2008-02-15
-# Whom: Pawel Pekala <c0rn@o2.pl>
-#
+# Created by: Pawel Pekala <c0rn@o2.pl>
# $FreeBSD$
-#
PORTNAME= qnapi
-PORTVERSION= 0.1.5
-PORTREVISION= 4
+PORTVERSION= 0.1.6.r2
CATEGORIES= polish multimedia
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTNAME}/
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}-rc2
MAINTAINER= pawel@FreeBSD.org
-COMMENT= Unofficial napiprojekt.pl qt4 client
+COMMENT= Qt4 based subtitle downloader
LICENSE= GPLv2
+LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
+ pcre:${PORTSDIR}/devel/pcre \
+ png15:${PORTSDIR}/graphics/png \
+ freetype:${PORTSDIR}/print/freetype2 \
+ expat:${PORTSDIR}/textproc/expat2 \
+ xcb:${PORTSDIR}/x11/libxcb \
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig
RUN_DEPENDS= 7z:${PORTSDIR}/archivers/p7zip
-USE_QT4= corelib gui network qmake_build moc_build uic_build rcc_build
+USE_ICONV= yes
+USE_GETTEXT= yes
+USE_XORG= ice sm x11 xau xdmcp xext xrender
+USE_QT4= corelib gui network xml qmake_build moc_build uic_build rcc_build
USE_KDE4= kdehier
QMAKE_ARGS= PREFIX=${PREFIX} KDE4_PREFIX=${KDE4_PREFIX}
MAKE_JOBS_SAFE= yes
@@ -26,16 +32,15 @@ INSTALLS_ICONS= yes
MAN1= qnapi.1
MANCOMPRESSED= yes
-PORTDOCS= ChangeLog changelog.gz README README.pl LICENSE \
- LICENSE.pl COPYRIGHT
+PORTDOCS= ChangeLog README.pl COPYRIGHT
.include <bsd.port.options.mk>
post-patch:
- @cd ${WRKSRC} && ${REINPLACE_CMD} -e 's|@PREFIX@|${PREFIX}|g' \
- doc/qnapi.desktop doc/qnapi-download.desktop
- @cd ${WRKSRC} && ${REINPLACE_CMD} -e 's|@LOCALBASE@|${LOCALBASE}|g' \
- src/napi.h
+ @${REINPLACE_CMD} 's|/usr/share/icons/||g' \
+ ${WRKSRC}/doc/qnapi.desktop \
+ ${WRKSRC}/doc/qnapi-download.desktop \
+ ${WRKSRC}/doc/qnapi-download.schemas
pre-build:
@cd ${WRKSRC} && ${QMAKE} -spec ${QMAKESPEC} ${QMAKEFLAGS} ${QMAKE_ARGS}
diff --git a/polish/qnapi/distinfo b/polish/qnapi/distinfo
index 79ca04616ea0..c58f36eb0bba 100644
--- a/polish/qnapi/distinfo
+++ b/polish/qnapi/distinfo
@@ -1,2 +1,2 @@
-SHA256 (qnapi-0.1.5.tar.gz) = 88ef9e4c8a2e830b0b9b231888e0012d10ac5ab3b8df7a18d09f42ee7de7fa5d
-SIZE (qnapi-0.1.5.tar.gz) = 172405
+SHA256 (qnapi-0.1.6-rc2.tar.gz) = a2ae2d0b5d800565493c8840f5f584d480daaee1f01742689d927fdf68c5150a
+SIZE (qnapi-0.1.6-rc2.tar.gz) = 211567
diff --git a/polish/qnapi/files/patch-doc-qnapi.desktop b/polish/qnapi/files/patch-doc-qnapi.desktop
deleted file mode 100644
index c38cc54c59f4..000000000000
--- a/polish/qnapi/files/patch-doc-qnapi.desktop
+++ /dev/null
@@ -1,11 +0,0 @@
---- doc/qnapi.desktop.orig Tue Feb 26 20:18:29 2008
-+++ doc/qnapi.desktop Thu Apr 10 20:07:03 2008
-@@ -1,7 +1,7 @@
- [Desktop Entry]
- Exec=qnapi
- Name=QNapi
--Icon=/usr/share/icons/qnapi-48.png
-+Icon=@PREFIX@/share/icons/qnapi.png
- Type=Application
- Categories=AudioVideo;
- Comment=Program do pobierania napisów do filmów
diff --git a/polish/qnapi/files/patch-doc-qnapi_download.desktop b/polish/qnapi/files/patch-doc-qnapi_download.desktop
deleted file mode 100644
index f2dfdbc98f4f..000000000000
--- a/polish/qnapi/files/patch-doc-qnapi_download.desktop
+++ /dev/null
@@ -1,17 +0,0 @@
---- doc/qnapi-download.desktop.orig Mon Apr 7 20:55:58 2008
-+++ doc/qnapi-download.desktop Thu Apr 10 20:08:37 2008
-@@ -4,7 +4,7 @@
- Actions=QNapiDownload;
- Name=Pobierz napisy do filmu z QNapi
- GenericName=Pobierz napisy do filmu z QNapi
--Icon=/usr/share/icons/qnapi-48.png
-+Icon=@PREFIX@/share/icons/qnapi.png
- ServiceTypes=video/x-msvideo,video/x-ms-asf,video/mpeg,video/x-ms-wmv,video/mp4,video/quicktime,video/x-theora,video/x-matroska,video/3gpp,application/vnd.rn-realmedia,application/vnd.rn-realmedia-vbr
- X-KDE-ServiceTypes=KonqPopupMenu/Plugin
- Type=Service
-@@ -12,4 +12,4 @@
- [Desktop Action QNapiDownload]
- Name=Pobierz napisy do filmu z QNapi
- Exec=qnapi %F
--Icon=/usr/share/icons/qnapi-48.png
-+Icon=@PREFIX@/share/icons/qnapi.png
diff --git a/polish/qnapi/files/patch-doc-qnapi_download.schemas b/polish/qnapi/files/patch-doc-qnapi_download.schemas
deleted file mode 100644
index 0175e6b86e18..000000000000
--- a/polish/qnapi/files/patch-doc-qnapi_download.schemas
+++ /dev/null
@@ -1,11 +0,0 @@
---- doc/qnapi-download.schemas.orig Sat Feb 23 11:31:20 2008
-+++ doc/qnapi-download.schemas Thu Apr 10 20:11:23 2008
-@@ -32,7 +32,7 @@
- <short>The icon of the menu item</short>
- <long>The icon of the menu item that will appear next to the label in the Nautilus popup menu when the selection matches the appearance conditions settings</long>
- </locale>
-- <default>/usr/share/icons/qnapi.png</default>
-+ <default>@PREFIX@/share/icons/qnapi.png</default>
- </schema>
- <schema>
- <key>/schemas/apps/nautilus-actions/configurations/12e76756-c203-4a27-830f-af5a1527869e/path</key>
diff --git a/polish/qnapi/files/patch-src-napi.h b/polish/qnapi/files/patch-src-napi.h
deleted file mode 100644
index 839944868499..000000000000
--- a/polish/qnapi/files/patch-src-napi.h
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/napi.h.orig 2010-11-27 12:39:09.000000000 +0100
-+++ src/napi.h 2010-11-27 12:40:06.000000000 +0100
-@@ -67,7 +67,7 @@
-
- bool napiMatchSubtitles(const QString & md5sum, const QString & zip_file, const QString & movie_file,
- bool noBackup = false, const QString & tmp_path = "/tmp",
-- const QString & p7zip_path = "/usr/bin/7z");
-+ const QString & p7zip_path = "@LOCALBASE@/bin/7z");
-
- bool napiCheckUser(const QString & nick, const QString & pass);
-
-@@ -76,7 +76,7 @@
- const QString & pass, bool correct = false,
- const QString & comment = "",
- const QString & tmp_path = "/tmp",
-- const QString & p7zip_path = "/usr/bin/7z");
-+ const QString & p7zip_path = "@LOCALBASE@/bin/7z");
-
- napiReportResult napiReportBad(const QString & movie_file, const QString & language,
- const QString & nick, const QString & pass, const QString & comment,
diff --git a/polish/qnapi/pkg-descr b/polish/qnapi/pkg-descr
index c0c994537552..d413f29ec47b 100644
--- a/polish/qnapi/pkg-descr
+++ b/polish/qnapi/pkg-descr
@@ -1 +1,5 @@
-WWW: http://krzemin.iglu.cz/?page_id=29
+Free, Qt4-based application designed for automatically downloading and
+matching subtitles for your movie files.
+It uses NapiProjekt and OpenSubtitles databases.
+
+WWW: http://sourceforge.net/projects/qnapi/