aboutsummaryrefslogtreecommitdiff
path: root/polish/tleenx2
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /polish/tleenx2
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'polish/tleenx2')
-rw-r--r--polish/tleenx2/Makefile8
-rw-r--r--polish/tleenx2/files/patch-iksemel-Makefile2
2 files changed, 5 insertions, 5 deletions
diff --git a/polish/tleenx2/Makefile b/polish/tleenx2/Makefile
index 2fc01d444f74..b4d5017c4839 100644
--- a/polish/tleenx2/Makefile
+++ b/polish/tleenx2/Makefile
@@ -7,10 +7,9 @@
PORTNAME= tleenx2
PORTVERSION= 20040214
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= polish net
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= tleenx
+MASTER_SITES= SF/leenx
DISTNAME= TleenX2-${PORTVERSION}
MAINTAINER= mkorzen@gmail.com
@@ -20,6 +19,7 @@ LIB_DEPENDS= tlen.1:${PORTSDIR}/polish/libtlen
USE_GNOME= gtk20
GNU_CONFIGURE= yes
+USE_XORG= xscrnsaver
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
WRKSRC= ${WRKDIR}/TleenX2-${PORTVERSION}
@@ -27,7 +27,7 @@ MAN1= tleenx2.1
PORTDOCS= README gg.txt sms.txt
post-patch:
- @${REINPLACE_CMD} -e 's,/usr/X11R6,${X11BASE},g' ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e 's,/usr/X11R6,${LOCALBASE},g' ${WRKSRC}/src/Makefile.in
post-install:
.if !defined(NOPORTDOCS)
diff --git a/polish/tleenx2/files/patch-iksemel-Makefile b/polish/tleenx2/files/patch-iksemel-Makefile
index 5d1cb30495c5..ffb2d67ec3a8 100644
--- a/polish/tleenx2/files/patch-iksemel-Makefile
+++ b/polish/tleenx2/files/patch-iksemel-Makefile
@@ -5,7 +5,7 @@
CC = gcc
-CFLAGS = -g -Wall -L/usr/local/lib -I/usr/local/include
-+CFLAGS = -Wall -L$(LOCALBASE)/lib -I$(LOCALBASE)/include -L$(X11BASE)/lib -I$(X11BASE)/include
++CFLAGS = -Wall -L$(LOCALBASE)/lib -I$(LOCALBASE)/include
OBJS = convert.o iks.o ikspool.o jabber.o sha.o core.o iksid.o io.o parser.o \
utility.o
all: $(OBJS)