aboutsummaryrefslogtreecommitdiff
path: root/polish/trf
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-09-10 17:17:25 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-09-10 17:17:25 +0000
commit203ac88b7240f24914ee7b9bc719788b0cec5009 (patch)
treee01dda621f8dbd073258f8f62211ff403f195242 /polish/trf
parent4a30ecc6c7c7466df62de83d615acc549c982a85 (diff)
downloadports-203ac88b7240f24914ee7b9bc719788b0cec5009.tar.gz
ports-203ac88b7240f24914ee7b9bc719788b0cec5009.zip
- Allow staging as a regular user
- Remove DOCS conditions
Notes
Notes: svn path=/head/; revision=367875
Diffstat (limited to 'polish/trf')
-rw-r--r--polish/trf/Makefile4
-rw-r--r--polish/trf/files/patch-Makefile15
2 files changed, 12 insertions, 7 deletions
diff --git a/polish/trf/Makefile b/polish/trf/Makefile
index a03a07843018..9932261cc892 100644
--- a/polish/trf/Makefile
+++ b/polish/trf/Makefile
@@ -11,14 +11,10 @@ COMMENT= Billing software for traffic counting working with most Polish ISPs
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
post-install:
-.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in README CHANGELOG
${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>
diff --git a/polish/trf/files/patch-Makefile b/polish/trf/files/patch-Makefile
index d2590dda5f4e..d9ff5c05ce48 100644
--- a/polish/trf/files/patch-Makefile
+++ b/polish/trf/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Fri Oct 3 18:00:32 2003
-+++ Makefile Fri Oct 3 18:01:51 2003
+--- Makefile.orig 2003-02-02 18:33:55 UTC
++++ Makefile
@@ -1,5 +1,7 @@
+CC ?= gcc
+CFLAGS+=-DFREEBSD
@@ -9,7 +9,7 @@
all:
@case "`uname -s`" in \
-@@ -19,7 +21,7 @@
+@@ -19,14 +21,14 @@
gcc -DLINUX -Wall -o trfs trfs.c
freebsd:
@@ -18,3 +18,12 @@
trfs:
make all
+
+ install: trfs
+- install -o root -g wheel -m 755 trfs $(DESTDIR)$(prefix)/bin
+- install -o root -g wheel -m 755 trf $(DESTDIR)$(prefix)/bin
++ $(BSD_INSTALL_PROGRAM) trfs $(DESTDIR)$(prefix)/bin
++ $(BSD_INSTALL_SCRIPT) trf $(DESTDIR)$(prefix)/bin
+
+ clean:
+ rm trfs || true