aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/chucky
diff options
context:
space:
mode:
authorSteven Kreuzer <skreuzer@FreeBSD.org>2013-08-23 17:39:54 +0000
committerSteven Kreuzer <skreuzer@FreeBSD.org>2013-08-23 17:39:54 +0000
commit21ab6e7e0ddb8caa054ea581d62040317fc62c44 (patch)
tree63f67d7378526010e5704ce60658d50a0f341b0c /ports-mgmt/chucky
parentf32d4df9609a7c565042d3b58c3e823ee69d0cab (diff)
downloadports-21ab6e7e0ddb8caa054ea581d62040317fc62c44.tar.gz
ports-21ab6e7e0ddb8caa054ea581d62040317fc62c44.zip
This program reads /var/db/pkg/local.sqlite and compares install timestamp with
date in $FreeBSD header in the Makefile of the port. If there is no $FreeBSD header then it is assumed to be a beta port. Chucky also features a shar file backup feature, which is normally used to backup 'beta' development ports. WWW: https://dx.burplex.com/bin/chucky.html PR: ports/177220 Submitted by: Waitman Gobble <uzimac@da3m0n8t3r.com>
Notes
Notes: svn path=/head/; revision=325275
Diffstat (limited to 'ports-mgmt/chucky')
-rw-r--r--ports-mgmt/chucky/Makefile44
-rw-r--r--ports-mgmt/chucky/distinfo2
-rw-r--r--ports-mgmt/chucky/files/pkg-message.in14
-rw-r--r--ports-mgmt/chucky/pkg-descr8
-rw-r--r--ports-mgmt/chucky/pkg-plist1
5 files changed, 69 insertions, 0 deletions
diff --git a/ports-mgmt/chucky/Makefile b/ports-mgmt/chucky/Makefile
new file mode 100644
index 000000000000..418cbbac1cbb
--- /dev/null
+++ b/ports-mgmt/chucky/Makefile
@@ -0,0 +1,44 @@
+# Created by: "Waitman Gobble" <uzimac@da3m0n8t3r.com>
+# $FreeBSD$
+
+PORTNAME= chucky
+PORTVERSION= 1.0
+CATEGORIES= ports-mgmt
+MASTER_SITES= GH
+DISTNAME= ${GH_ACCOUNT}-${GH_PROJECT}-${PORTVERSION}-0-g${GH_COMMIT}
+
+MAINTAINER= waitman@waitman.net
+COMMENT= Port installed version check/report with shar archival
+
+LICENSE= CHUCKY
+LICENSE_NAME= CHUCKY BSD LICENSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= ${_LICENSE_PERMS_DEFAULT}
+
+LIB_DEPENDS= pkg:${PORTSDIR}/ports-mgmt/pkg \
+ sqlite3:${PORTSDIR}/databases/sqlite3
+
+USE_GITHUB= yes
+GH_ACCOUNT= waitman
+GH_PROJECT= chucky
+GH_TAGNAME= 075defe
+GH_COMMIT= ${GH_TAGNAME}
+
+WRKSRC= ${WRKDIR}/waitman-chucky-075defe
+
+MAN7= chucky.7
+
+SUB_FILES= pkg-message
+SUB_LIST= MAN7PREFIX="${MAN7PREFIX}"
+PORTDOCS= *
+
+.include <bsd.port.options.mk>
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/ports-mgmt/chucky/distinfo b/ports-mgmt/chucky/distinfo
new file mode 100644
index 000000000000..0090a828bf5c
--- /dev/null
+++ b/ports-mgmt/chucky/distinfo
@@ -0,0 +1,2 @@
+SHA256 (waitman-chucky-1.0-0-g075defe.tar.gz) = bf7fa32c5584725fa6c2d1d0951cf0f29488307d5a73d81b2df47d59617bc6d6
+SIZE (waitman-chucky-1.0-0-g075defe.tar.gz) = 4367
diff --git a/ports-mgmt/chucky/files/pkg-message.in b/ports-mgmt/chucky/files/pkg-message.in
new file mode 100644
index 000000000000..f60c5fd85de6
--- /dev/null
+++ b/ports-mgmt/chucky/files/pkg-message.in
@@ -0,0 +1,14 @@
+************************************************************************
+
+NOTICE
+
+man page is installed in %%MAN7PREFIX%%/man/man7, if you do not yet
+have the configuration in /etc/man.conf, add
+
+MANPATH /usr/local/share/man
+
+to view all man pages which are installed in /usr/local/share/man/manX/
+
+
+************************************************************************
+
diff --git a/ports-mgmt/chucky/pkg-descr b/ports-mgmt/chucky/pkg-descr
new file mode 100644
index 000000000000..fadb382bcca3
--- /dev/null
+++ b/ports-mgmt/chucky/pkg-descr
@@ -0,0 +1,8 @@
+This program reads /var/db/pkg/local.sqlite and compares install timestamp with
+date in $FreeBSD header in the Makefile of the port. If there is no $FreeBSD
+header then it is assumed to be a beta port.
+
+Chucky also features a shar file backup feature, which is normally used to
+backup 'beta' development ports.
+
+WWW: https://dx.burplex.com/bin/chucky.html
diff --git a/ports-mgmt/chucky/pkg-plist b/ports-mgmt/chucky/pkg-plist
new file mode 100644
index 000000000000..1ad594e5f8a0
--- /dev/null
+++ b/ports-mgmt/chucky/pkg-plist
@@ -0,0 +1 @@
+bin/chucky