aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/distilator
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2010-10-19 15:50:02 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2010-10-19 15:50:02 +0000
commit2bdee0af7213b2cb8cea60a94b0c8cecfee8ec4b (patch)
tree0f0eb0d8ccbfe4a579aadbacccf1c84fc20e699b /ports-mgmt/distilator
parent81ca01f537f346360605cad9826a9bae7a2b0c21 (diff)
downloadports-2bdee0af7213b2cb8cea60a94b0c8cecfee8ec4b.tar.gz
ports-2bdee0af7213b2cb8cea60a94b0c8cecfee8ec4b.zip
Add ports-mgmt/distilator, a command-line script to check the availability of a
ports distfiles. This script can take advantage of perl threads if available.
Notes
Notes: svn path=/head/; revision=263291
Diffstat (limited to 'ports-mgmt/distilator')
-rw-r--r--ports-mgmt/distilator/Makefile22
-rw-r--r--ports-mgmt/distilator/distinfo3
-rw-r--r--ports-mgmt/distilator/pkg-descr4
-rw-r--r--ports-mgmt/distilator/pkg-plist11
4 files changed, 40 insertions, 0 deletions
diff --git a/ports-mgmt/distilator/Makefile b/ports-mgmt/distilator/Makefile
new file mode 100644
index 000000000000..faf06f0a44ad
--- /dev/null
+++ b/ports-mgmt/distilator/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: distilator
+# Date created: 19 Oct 2010
+# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= distilator
+PORTVERSION= 0.1
+CATEGORIES= ports-mgmt perl5
+MASTER_SITES= CRITICAL
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= A command-line script to check the availability of a ports distfiles
+
+RUN_DEPENDS= p5-URI>=1.56:${PORTSDIR}/net/p5-URI \
+ p5-HTTP-SimpleLinkChecker>=1.16:${PORTSDIR}/www/p5-HTTP-SimpleLinkChecker
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= 5.8.0+
+
+.include <bsd.port.mk>
diff --git a/ports-mgmt/distilator/distinfo b/ports-mgmt/distilator/distinfo
new file mode 100644
index 000000000000..1b7ee78c3d56
--- /dev/null
+++ b/ports-mgmt/distilator/distinfo
@@ -0,0 +1,3 @@
+MD5 (distilator-0.1.tar.gz) = 74a272a9b090abc6f3dbff8356433665
+SHA256 (distilator-0.1.tar.gz) = 12ba0d17d223ddad70bb85ef28eaba7e7b801fdc56953af2f99641f7113e2a7f
+SIZE (distilator-0.1.tar.gz) = 3654
diff --git a/ports-mgmt/distilator/pkg-descr b/ports-mgmt/distilator/pkg-descr
new file mode 100644
index 000000000000..30e64e0d1f0f
--- /dev/null
+++ b/ports-mgmt/distilator/pkg-descr
@@ -0,0 +1,4 @@
+A command-line script to check the availability of a ports distfiles. This
+script can take advantage of perl threads if available.
+
+WWW: http://people.freebsd.org/~ehaupt/distilator/
diff --git a/ports-mgmt/distilator/pkg-plist b/ports-mgmt/distilator/pkg-plist
new file mode 100644
index 000000000000..af888fb42a01
--- /dev/null
+++ b/ports-mgmt/distilator/pkg-plist
@@ -0,0 +1,11 @@
+bin/distilator
+%%SITE_PERL%%/FreeBSD/Ports/Distilator.pm
+%%SITE_PERL%%/FreeBSD/Ports/DistilatorCommon.pm
+%%SITE_PERL%%/FreeBSD/Ports/DistilatorSingle.pm
+%%SITE_PERL%%/FreeBSD/Ports/DistilatorThreaded.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/FreeBSD/Ports/Distilator/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/FreeBSD/Ports/Distilator
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/FreeBSD/Ports
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/FreeBSD
+@dirrmtry %%SITE_PERL%%/FreeBSD/Ports
+@dirrmtry %%SITE_PERL%%/FreeBSD