aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/distilator
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2018-08-27 16:28:42 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2018-08-27 16:28:42 +0000
commitbd5027391f84c4d53f3419ce5f189ccc30515ace (patch)
treebe59ef0eec2edc3a0a32ab7fbd904c0d44ae0bba /ports-mgmt/distilator
parenta0ee1eca691605a7d8d3b56dc09de11eb6ef2d1a (diff)
downloadports-bd5027391f84c4d53f3419ce5f189ccc30515ace.tar.gz
ports-bd5027391f84c4d53f3419ce5f189ccc30515ace.zip
- Update to 1.0
- Add WWW and provide an additional mirror - Provide a longer description as requested by portlint - Distilator will now report when an URL gives a redirect - Rewritten in python using requests and requests_ftp - Licensed under BSD2CLAUSE PR: 215425 Requested by: mat
Notes
Notes: svn path=/head/; revision=478219
Diffstat (limited to 'ports-mgmt/distilator')
-rw-r--r--ports-mgmt/distilator/Makefile26
-rw-r--r--ports-mgmt/distilator/distinfo6
-rw-r--r--ports-mgmt/distilator/pkg-descr5
-rw-r--r--ports-mgmt/distilator/pkg-plist2
4 files changed, 17 insertions, 22 deletions
diff --git a/ports-mgmt/distilator/Makefile b/ports-mgmt/distilator/Makefile
index efe114c4c402..786f4970164a 100644
--- a/ports-mgmt/distilator/Makefile
+++ b/ports-mgmt/distilator/Makefile
@@ -2,29 +2,23 @@
# $FreeBSD$
PORTNAME= distilator
-PORTVERSION= 0.3
-PORTREVISION= 1
-CATEGORIES= ports-mgmt perl5
-MASTER_SITES= LOCAL/ehaupt
+PORTVERSION= 1.0
+CATEGORIES= ports-mgmt
+MASTER_SITES= https://critical.ch/distilator/ \
+ LOCAL/ehaupt
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Command-line script to check the availability of a ports distfiles
-LICENSE= ART10 GPLv1+
-LICENSE_COMB= dual
+LICENSE= BSD2CLAUSE
-BUILD_DEPENDS= ${RUN_DEPENDS}
-RUN_DEPENDS= p5-URI>=1.56:net/p5-URI \
- p5-libwww>=0:www/p5-libwww \
- p5-Parallel-ForkManager>=0:devel/p5-Parallel-ForkManager
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.18.4_1:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests-ftp>=0.3.1:ftp/py-requests-ftp@${PY_FLAVOR}
-USES= perl5
-USE_PERL5= configure
+USES= python shebangfix
NO_ARCH= yes
+NO_BUILD= yes
-OPTIONS_DEFINE= SSL
-OPTIONS_DEFAULT=SSL
-
-SSL_RUN_DEPENDS= p5-Crypt-SSLeay>=0:security/p5-Crypt-SSLeay
+PLIST_FILES= bin/distilator
.include <bsd.port.mk>
diff --git a/ports-mgmt/distilator/distinfo b/ports-mgmt/distilator/distinfo
index d0ae27bfcf50..835986bfa73e 100644
--- a/ports-mgmt/distilator/distinfo
+++ b/ports-mgmt/distilator/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1481022611
-SHA256 (distilator-0.3.tar.gz) = 19d299036d55eb25812aec3740015397097432a541d25983322d85fdbaab9030
-SIZE (distilator-0.3.tar.gz) = 3736
+TIMESTAMP = 1535383437
+SHA256 (distilator-1.0.tar.gz) = c09f966506cc1cdd77cca3a16a01ce8b009e0fab525cf39cb4041aba30717d42
+SIZE (distilator-1.0.tar.gz) = 3022
diff --git a/ports-mgmt/distilator/pkg-descr b/ports-mgmt/distilator/pkg-descr
index b0d8b0155faa..02ef86a59c5e 100644
--- a/ports-mgmt/distilator/pkg-descr
+++ b/ports-mgmt/distilator/pkg-descr
@@ -1 +1,4 @@
-A command-line script to check the availability of a ports distfiles.
+A command-line script to check the availability of a FreeBSD ports
+distfiles in parallel.
+
+WWW: https://critical.ch/distilator/
diff --git a/ports-mgmt/distilator/pkg-plist b/ports-mgmt/distilator/pkg-plist
deleted file mode 100644
index 29c34db04092..000000000000
--- a/ports-mgmt/distilator/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-bin/distilator
-%%SITE_PERL%%/FreeBSD/Ports/Distilator.pm