aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/jailaudit/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-11-25 02:31:06 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-11-25 02:31:06 +0000
commit172444444e7175544cfbf610963c21411fba7eb9 (patch)
tree1bf8996987cfaa175f1a4d533410571496437048 /ports-mgmt/jailaudit/Makefile
parentb6c3d863e25343c996077a58f12d1f672de37cf6 (diff)
downloadports-172444444e7175544cfbf610963c21411fba7eb9.tar.gz
ports-172444444e7175544cfbf610963c21411fba7eb9.zip
[NEW PORT] security/jailaudit: Generate portaudit reports for jails from the hostsystem
This port contains a script for generating portaudit reports for jails running on a FreeBSD system. Jailaudit runs in the Host-system and uses portaudit to create reports for every jail currently running. It can also be used to send specific report-mails to the owner of a jail by running it as a cronjob. /etc/crontab example: 0 4 * * * * root /usr/local/bin/jailaudit mail admin@foo.bar "foo.example.com bar.example.com" Sends reports-mails of the jails with the hostnames foo.example.com and bar.example.com to the mailaddr. admin@example.com. WWW: http://outpost.h3q.org/software/jailaudit/ PR: ports/87581 Submitted by: Philipp Wuensche <cryx-ports@h3q.com>
Notes
Notes: svn path=/head/; revision=149353
Diffstat (limited to 'ports-mgmt/jailaudit/Makefile')
-rw-r--r--ports-mgmt/jailaudit/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/ports-mgmt/jailaudit/Makefile b/ports-mgmt/jailaudit/Makefile
new file mode 100644
index 000000000000..fe863b7c342f
--- /dev/null
+++ b/ports-mgmt/jailaudit/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: jailaudit
+# Date created: 21 October 2005
+# Whom: cryx
+#
+# $FreeBSD$
+#
+
+PORTNAME= jailaudit
+PORTVERSION= 1.1
+CATEGORIES= security
+MASTER_SITES= http://outpost.h3q.com/software/jailaudit/
+
+MAINTAINER= cryx-ports@h3q.com
+COMMENT= Script to generate portaudit reports for jails
+
+RUN_DEPENDS= ${LOCALBASE}/sbin/portaudit:${PORTSDIR}/security/portaudit
+
+USE_BZIP2= yes
+
+PERIODICDIR?= ${PREFIX}/etc/periodic
+REPORTDIR?= ${PREFIX}/jailaudit/reports
+TMPDIR?= ${PREFIX}/jailaudit/tmp
+
+PLIST_SUB+= PERIODICDIR="${PERIODICDIR:S,^${PREFIX}/,,}" \
+ REPORTDIR="${REPORTDIR:S,^${PREFIX}/,,}" \
+ TMPDIR="${TMPDIR:S,^${PREFIX}/,,}"
+
+.include <bsd.port.pre.mk>
+
+.if ( ${OSVERSION} < 501000 )
+IGNORE= needs the jls utility which was added in FreeBSD 5.1
+.endif
+
+.include <bsd.port.post.mk>