aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/pkg-rmleaf/Makefile
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-05-15 22:21:30 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-05-15 22:21:30 +0000
commitbe70590d523f5ab521bdce72aa398e4560eaac7a (patch)
tree5e18b1193c0a0b0a698132183176030b7c52ce33 /ports-mgmt/pkg-rmleaf/Makefile
parent2931f65e37596cae6de663dfbe1c15c68c8cf3c4 (diff)
downloadports-be70590d523f5ab521bdce72aa398e4560eaac7a.tar.gz
ports-be70590d523f5ab521bdce72aa398e4560eaac7a.zip
Notes
Diffstat (limited to 'ports-mgmt/pkg-rmleaf/Makefile')
-rw-r--r--ports-mgmt/pkg-rmleaf/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/ports-mgmt/pkg-rmleaf/Makefile b/ports-mgmt/pkg-rmleaf/Makefile
new file mode 100644
index 000000000000..4fc88ade4afd
--- /dev/null
+++ b/ports-mgmt/pkg-rmleaf/Makefile
@@ -0,0 +1,29 @@
+# Created by: Yanhui Shen <shen.elf@gmail.com>
+# $FreeBSD$
+
+PORTNAME= pkg-rmleaf
+PORTVERSION= 0.2
+CATEGORIES= ports-mgmt
+MASTER_SITES= # none
+DISTFILES= # none
+
+MAINTAINER= shen.elf@gmail.com
+COMMENT= Remove leaf packages
+
+LICENSE= BSD
+
+RUN_DEPENDS= ${LOCALBASE}/sbin/pkg:${PORTSDIR}/ports-mgmt/pkg
+
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}
+
+PLIST_FILES= sbin/pkg-rmleaf
+
+do-extract:
+ ${MKDIR} ${WRKSRC}
+ ${CP} ${FILESDIR}/pkg-rmleaf ${WRKSRC}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/pkg-rmleaf ${PREFIX}/sbin/pkg-rmleaf
+
+.include <bsd.port.mk>