aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/pkg/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2013-11-29 18:34:34 +0000
committerJohn Marino <marino@FreeBSD.org>2013-11-29 18:34:34 +0000
commit2600ce4b431adfdab72ccd9932c19f548c5825dd (patch)
tree59a2c7e8bebbc5e5f22209674b264ca44df1b2e7 /ports-mgmt/pkg/Makefile
parent27955500a75b2f33e3bdbb6b58d0da5394e7034c (diff)
downloadports-2600ce4b431adfdab72ccd9932c19f548c5825dd.tar.gz
ports-2600ce4b431adfdab72ccd9932c19f548c5825dd.zip
ports-mgmt/pkg*: Prepare for alternative PORTSDIR support
With the PKG_PORTSDIR make argument set, Release 1.2.2 will properly build pkg when PORTSDIR doesn't equal the default /usr/ports, as is the standard case with DragonFly. Additionally, pkg(8) and pkg-static(8) man pages are conditionally edited to remove references to the -j option when libjail isn't found on the system. This extra-patch should never be used on FreeBSD.
Notes
Notes: svn path=/head/; revision=335210
Diffstat (limited to 'ports-mgmt/pkg/Makefile')
-rw-r--r--ports-mgmt/pkg/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/ports-mgmt/pkg/Makefile b/ports-mgmt/pkg/Makefile
index d6c45151ce02..77af1e7eae14 100644
--- a/ports-mgmt/pkg/Makefile
+++ b/ports-mgmt/pkg/Makefile
@@ -20,6 +20,7 @@ NO_CCACHE= yes
USE_LDCONFIG= yes
USES= uidfix shebangfix
SHEBANG_FILES= scripts/completion/_pkg.bash.in
+MAKE_ARGS+= PKG_PORTSDIR=${PORTSDIR}
MAKE_ENV+= WITHOUT_PROFILE=yes __MAKE_CONF=/dev/null SRCCONF=/dev/null \
PORTREVISION=${PORTREVISION}
@@ -28,6 +29,10 @@ MAKE_ENV+= WITHOUT_PROFILE=yes __MAKE_CONF=/dev/null SRCCONF=/dev/null \
# so that pkg-static is used from the wrkdir
USE_SUBMAKE= yes
+.if !exists(/usr/include/jail.h)
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-pkg_pkg.8
+.endif
+
.include <bsd.port.pre.mk>
.if defined(WITH_DEBUG) && !defined(WITHOUT_DEBUG)