aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/pkg/Makefile
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2020-06-20 21:22:55 +0000
committerXin LI <delphij@FreeBSD.org>2020-06-20 21:22:55 +0000
commit5321f236b37597497a962a3e70ab5b5b1044fff9 (patch)
tree25de812d91a02d83a41e685cdea5cf3ce8d1b2ca /ports-mgmt/pkg/Makefile
parentf109479ecbe1b3cac6ff1f490a98839826296595 (diff)
downloadports-5321f236b37597497a962a3e70ab5b5b1044fff9.tar.gz
ports-5321f236b37597497a962a3e70ab5b5b1044fff9.zip
Notes
Diffstat (limited to 'ports-mgmt/pkg/Makefile')
-rw-r--r--ports-mgmt/pkg/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/ports-mgmt/pkg/Makefile b/ports-mgmt/pkg/Makefile
index cb6d18fa408e..0d37ac085a5b 100644
--- a/ports-mgmt/pkg/Makefile
+++ b/ports-mgmt/pkg/Makefile
@@ -2,6 +2,7 @@
PORTNAME= pkg
DISTVERSION= 1.14.4
+PORTREVISION= 1
_PKG_VERSION= ${DISTVERSION}
CATEGORIES= ports-mgmt
#MASTER_SITES= \
@@ -71,6 +72,13 @@ pre-everything::
.endif
.endif
+.if !exists(/usr/libdata/pkgconfig/liblzma.pc)
+LIBLZMA_LIBS= -llzma
+.else
+LIBLZMA_PC!= ${EGREP} ^Libs /usr/libdata/pkgconfig/liblzma.pc
+LIBLZMA_LIBS= ${LIBLZMA_PC:M-l*}
+.endif
+
#define PKG_DEPENDS to nothing to avoid infinite loop looking for pkg :)
PKG_DEPENDS=
.undef INSTALLS_DEPENDS
@@ -81,6 +89,10 @@ PKG_DEPENDS=
PKG_BIN= ${WRKSRC}/src/pkg-static
.endif
+post-patch:
+ ${REINPLACE_CMD} -e "s|-llzma|${LIBLZMA_LIBS}|g" ${WRKSRC}/auto.def \
+ ${WRKSRC}/src/Makefile.autosetup ${WRKSRC}/tests/Makefile.autosetup
+
post-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/compat/pkg