aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/pkg/Makefile
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2012-12-22 19:58:04 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2012-12-22 19:58:04 +0000
commit5d26e224e28f1e14e5a350d2d3e78a7c3bb7fc4d (patch)
tree219190b7144e13f64e081f71675e1f737d11bb64 /ports-mgmt/pkg/Makefile
parent8918570cea73e7944fe930b7bbd7586c9ab71f43 (diff)
downloadports-5d26e224e28f1e14e5a350d2d3e78a7c3bb7fc4d.tar.gz
ports-5d26e224e28f1e14e5a350d2d3e78a7c3bb7fc4d.zip
- Enable seatbelt again after further testing. It will
work fine as is with portmaster distfiles. pkg_info -Ea will list invalid packages, while pkg_info only gives a warning for the packages. This is already handled due to stderr being sent to /dev/null. The NB_OLDPKGS does come out correct. Approved by: bapt (implicit)
Notes
Notes: svn path=/head/; revision=309403
Diffstat (limited to 'ports-mgmt/pkg/Makefile')
-rw-r--r--ports-mgmt/pkg/Makefile50
1 files changed, 25 insertions, 25 deletions
diff --git a/ports-mgmt/pkg/Makefile b/ports-mgmt/pkg/Makefile
index 9b723d59b751..97288a209c4a 100644
--- a/ports-mgmt/pkg/Makefile
+++ b/ports-mgmt/pkg/Makefile
@@ -56,31 +56,31 @@ MLINKS= pkg-delete.8 pkg-remove.8 \
.include <bsd.port.pre.mk>
-#.if defined(WITH_PKGNG)
-#.if exists(${LOCALBASE}/sbin/pkg_info) || exists(/usr/sbin/pkg_info)
-#NB_OLDPKGS!= pkg_info 2>/dev/null | wc -l
-#.if ${NB_OLDPKGS} > 0
-#
-#pre-everything::
-# @${ECHO_CMD} "You are about to convert your system to pkgng while you have ports/packages"; \
-# ${ECHO_CMD} "installed with the old pkg_install tools."; \
-# ${ECHO_CMD} ""; \
-# ${ECHO_CMD} "You can choose to: "; \
-# ${ECHO_CMD} "- keep pkg_install as the package management system by adding this line to /etc/make.conf:"; \
-# ${ECHO_CMD} ""; \
-# ${ECHO_CMD} " WITHOUT_PKGNG=yes" ; \
-# ${ECHO_CMD} ""; \
-# ${ECHO_CMD} "- switch to pkgng:"; \
-# ${ECHO_CMD} " 1) Add WITHOUT_PKGNG to /etc/make.conf"; \
-# ${ECHO_CMD} " 2) Install ports-mgmt/pkg"; \
-# ${ECHO_CMD} " 3) Convert your package database by running pkg2ng"; \
-# ${ECHO_CMD} " 4) Remove WITHOUT_PKGNG from /etc/make.conf"; \
-# ${ECHO_CMD} ""; \
-# exit 1
-#
-#.endif
-#.endif
-#.endif
+.if defined(WITH_PKGNG)
+.if exists(${LOCALBASE}/sbin/pkg_info) || exists(/usr/sbin/pkg_info)
+NB_OLDPKGS!= pkg_info 2>/dev/null | wc -l
+.if ${NB_OLDPKGS} > 0
+
+pre-everything::
+ @${ECHO_CMD} "You are about to convert your system to pkgng while you have ports/packages"; \
+ ${ECHO_CMD} "installed with the old pkg_install tools."; \
+ ${ECHO_CMD} ""; \
+ ${ECHO_CMD} "You can choose to: "; \
+ ${ECHO_CMD} "- keep pkg_install as the package management system by adding this line to /etc/make.conf:"; \
+ ${ECHO_CMD} ""; \
+ ${ECHO_CMD} " WITHOUT_PKGNG=yes" ; \
+ ${ECHO_CMD} ""; \
+ ${ECHO_CMD} "- switch to pkgng:"; \
+ ${ECHO_CMD} " 1) Add WITHOUT_PKGNG to /etc/make.conf"; \
+ ${ECHO_CMD} " 2) Install ports-mgmt/pkg"; \
+ ${ECHO_CMD} " 3) Convert your package database by running pkg2ng"; \
+ ${ECHO_CMD} " 4) Remove WITHOUT_PKGNG from /etc/make.conf"; \
+ ${ECHO_CMD} ""; \
+ exit 1
+
+.endif
+.endif
+.endif
#define PKG_DEPENDS to nothing to avoid infinite loop looking for pkg :)
.if defined(WITH_PKGNG)