aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/pkg/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-07-23 14:22:09 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-07-23 14:22:09 +0000
commitd68c200ddcf310f3264a2bf7f0562a123d660a25 (patch)
tree4b15d25b323725a7816c5fc28d56de58c0d70b3a /ports-mgmt/pkg/Makefile
parentbf0272f8b8ef2804cf4bbcd31ddaaa2258b40477 (diff)
downloadports-d68c200ddcf310f3264a2bf7f0562a123d660a25.tar.gz
ports-d68c200ddcf310f3264a2bf7f0562a123d660a25.zip
Update to 1.3.0
Since pkg 1.2: - 373 files changed, 66973 insertions(+), 38512 deletions(-) - 29 differents contributors - Merge of one of the 2013 Summer of code project Changelog: - New solver that can support external solvers using the CUDF format and the internal SAT solver - pkg-ssh(8) is now sandboxed with capsicum if it is available - pkg-ssh(8) now uses poll(2) - Remove StringList usage to improve portability - Rework the build system to use autotools to help portability - Now fetching is done to a temporary location and cleaned up if it fails - Remove PACKAGESITE - pkg-audit: remove support for portaudit compact database (only VulnXML will be used) - Improved UI experience based on jmmv write up (http://julipedia.meroh.net/search/label/cli-design) - Reworking the database locking mechanism into a finer grain and more clever system - Dynamic conflict handling if a conflict on files is detected at the sanity check level, try to solve the problem again with the new conflict information - Fix %t (timestamp) modifier in pkg_printf(3) - Full output now has a new field "date installed" - New pkg -o A=B to overwrite configuration from command line without the need of defining environment variables - pkg-install now can handle local files - pkg-add is now an alias on pkg-install - Simplify API by using more and more libucl objects (hidden behind an opaque 'pkg_object') - Rework multirepository handling - Prepare code for repository abstraction support - Sandbox signature checking and extraction - Support long options - Rework the extraction process - unicity of a package is now origin~name allowing subpackages and flavours - Improve ui for all commands - pkg lock -l now list the locked packages - symlinks now has a checksum to ensure they are valid - pkg backups generated by the distributed script are now plain sql files - Tons of bugfixes - Tons of behavour fixes
Notes
Notes: svn path=/head/; revision=362699
Diffstat (limited to 'ports-mgmt/pkg/Makefile')
-rw-r--r--ports-mgmt/pkg/Makefile21
1 files changed, 8 insertions, 13 deletions
diff --git a/ports-mgmt/pkg/Makefile b/ports-mgmt/pkg/Makefile
index 300a18f52367..0e8821a4ac02 100644
--- a/ports-mgmt/pkg/Makefile
+++ b/ports-mgmt/pkg/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= pkg
-DISTVERSION= 1.2.7
-PORTREVISION= 4
+DISTVERSION= 1.3.0
CATEGORIES= ports-mgmt
MASTER_SITES= \
http://files.etoilebsd.net/${PORTNAME}/ \
@@ -20,17 +19,16 @@ USES= tar:xz uidfix
# With no dependency at all
NO_CCACHE= yes
USE_LDCONFIG= yes
-MAKE_ARGS+= PKG_PORTSDIR=${PORTSDIR}
-
-MAKE_ENV+= WITHOUT_PROFILE=yes __MAKE_CONF=/dev/null SRCCONF=/dev/null \
- PORTREVISION=${PORTREVISION} NO_PIE=yes
+USES= libtool tar:xz
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
# Use a submake as 'deinstall install' needs to reevaluate PKG_CMD
# so that pkg-static is used from the wrkdir
USE_SUBMAKE= yes
.if !exists(/usr/include/jail.h)
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-pkg_pkg.8
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-docs_pkg.8
.endif
.include <bsd.port.pre.mk>
@@ -81,15 +79,12 @@ pre-everything::
PKG_DEPENDS=
.undef INSTALLS_DEPENDS
.if !exists(${LOCALBASE}/sbin/pkg)
-PKG_BIN= ${WRKSRC}/pkg/pkg-static
+PKG_BIN= ${WRKSRC}/src/pkg-static
.endif
.endif
-PERIODIC_DAILY= 400.status-pkg 411.pkg-backup 490.status-pkg-changes
-PERIODIC_SECURITY= 410.pkg-audit 460.pkg-checksum
-PERIODIC_ALL= ${PERIODIC_DAILY} ${PERIODIC_SECURITY}
-
post-install:
- @${INSTALL_DATA} ${WRKSRC}/pkg/pkg.conf.sample ${STAGEDIR}${PREFIX}/etc
+ @${MV} ${STAGEDIR}${PREFIX}/lib/libpkg_static.a \
+ ${STAGEDIR}${PREFIX}/lib/libpkg.a
.include <bsd.port.post.mk>