aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/pkg/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-09-10 13:14:50 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-09-10 13:14:50 +0000
commite1bfdfbe5665c963621e06f6bbfbbc2c000a804e (patch)
treeeaf052562fa1ad9b232918eb5e617ac1df0dd725 /ports-mgmt/pkg/Makefile
parentf57bc4af665126de839ff734a08e57726e84da84 (diff)
downloadports-e1bfdfbe5665c963621e06f6bbfbbc2c000a804e.tar.gz
ports-e1bfdfbe5665c963621e06f6bbfbbc2c000a804e.zip
Notes
Diffstat (limited to 'ports-mgmt/pkg/Makefile')
-rw-r--r--ports-mgmt/pkg/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/ports-mgmt/pkg/Makefile b/ports-mgmt/pkg/Makefile
index fddf0a1d922e..36ac998733da 100644
--- a/ports-mgmt/pkg/Makefile
+++ b/ports-mgmt/pkg/Makefile
@@ -28,6 +28,8 @@ PORTSCOUT= ignore:1
USE_SUBMAKE= yes
CFLAGS+= -Wno-error
+OPTIONS_DEFINE= DOCS
+
.if !exists(/usr/include/jail.h)
EXTRA_PATCHES= ${FILESDIR}/extra-patch-docs_pkg.8
.endif
@@ -79,9 +81,11 @@ PKG_BIN= ${WRKSRC}/src/pkg-static
.endif
post-install:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/NEWS ${STAGEDIR}${DOCSDIR}/NEWS
@${MV} ${STAGEDIR}${PREFIX}/lib/libpkg_static.a \
${STAGEDIR}${PREFIX}/lib/libpkg.a
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/NEWS ${STAGEDIR}${DOCSDIR}/NEWS
+
.include <bsd.port.post.mk>