aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/pkg/files
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2013-12-06 16:14:27 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2013-12-06 16:14:27 +0000
commit36eebfc58aac4acc4e21a6316bc44621262f80ee (patch)
treea98027f23e7a47f0d9c78f1d0db5ca35cb576d12 /ports-mgmt/pkg/files
parent0c725ea5cd167df223e331aebfdedeee7acee26a (diff)
downloadports-36eebfc58aac4acc4e21a6316bc44621262f80ee.tar.gz
ports-36eebfc58aac4acc4e21a6316bc44621262f80ee.zip
Notes
Diffstat (limited to 'ports-mgmt/pkg/files')
-rw-r--r--ports-mgmt/pkg/files/patch-libpkg__Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/ports-mgmt/pkg/files/patch-libpkg__Makefile b/ports-mgmt/pkg/files/patch-libpkg__Makefile
new file mode 100644
index 000000000000..8cd27109f71b
--- /dev/null
+++ b/ports-mgmt/pkg/files/patch-libpkg__Makefile
@@ -0,0 +1,14 @@
+--- ./libpkg/Makefile.orig 2013-12-06 10:09:09.945131112 -0600
++++ ./libpkg/Makefile 2013-12-06 10:10:36.944131558 -0600
+@@ -255,3 +255,11 @@
+ sed -e "s,__PREFIX__,${PREFIX},g" \
+ -e "s,__VERSION__,${PKGVERSION},g" \
+ ${.IMPSRC} > ${.TARGET}
++
++# Workaround 8.3/8.4 bug
++OSVERSION!= /sbin/sysctl -n kern.osreldate
++
++.if ${OSVERSION} < 901000
++.c.o:
++ ${CC} ${STATIC_CFLAGS} ${CFLAGS} -c ${.IMPSRC} -o ${.TARGET}
++.endif