aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/pkg/files
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2019-05-31 09:54:49 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2019-05-31 09:54:49 +0000
commitb49bc9fc24aaf88da80f3d99a53af3f773f613c4 (patch)
tree617665c22ba7795a680865287e4e5c4eb61c895a /ports-mgmt/pkg/files
parent938674217f0c2b1477b1b6732cbf000a030d1bd6 (diff)
downloadports-b49bc9fc24aaf88da80f3d99a53af3f773f613c4.tar.gz
ports-b49bc9fc24aaf88da80f3d99a53af3f773f613c4.zip
Notes
Diffstat (limited to 'ports-mgmt/pkg/files')
-rw-r--r--ports-mgmt/pkg/files/patch-166328
-rw-r--r--ports-mgmt/pkg/files/patch-170213
-rw-r--r--ports-mgmt/pkg/files/patch-60666a116
-rw-r--r--ports-mgmt/pkg/files/patch-javavmwrapper34
-rw-r--r--ports-mgmt/pkg/files/patch-src_Makefile.in11
5 files changed, 0 insertions, 102 deletions
diff --git a/ports-mgmt/pkg/files/patch-1663 b/ports-mgmt/pkg/files/patch-1663
deleted file mode 100644
index e2c9c6a00cb4..000000000000
--- a/ports-mgmt/pkg/files/patch-1663
+++ /dev/null
@@ -1,28 +0,0 @@
-diff --git a/libpkg/pkg_jobs_conflicts.c b/libpkg/pkg_jobs_conflicts.c
-index 886e100c..141c69f9 100644
---- libpkg/pkg_jobs_conflicts.c.orig
-+++ libpkg/pkg_jobs_conflicts.c
-@@ -477,7 +477,8 @@ pkg_conflicts_check_chain_conflict(struct pkg_job_universe_item *it,
- it->pkg->uid);
-
- if (p != NULL) {
-- pkg_jobs_universe_process_item(j->universe, p, &cun);
-+ if (pkg_jobs_universe_process_item(j->universe, p, &cun))
-+ continue;
- assert(cun != NULL);
- pkg_conflicts_register_chain(j, it, cun, fcur->path);
- }
-diff --git a/libpkg/pkg_jobs_universe.c b/libpkg/pkg_jobs_universe.c
-index 1a5a2c72..725825ac 100644
---- libpkg/pkg_jobs_universe.c.orig
-+++ libpkg/pkg_jobs_universe.c
-@@ -570,6 +570,9 @@ pkg_jobs_universe_process_item(struct pkg_jobs_universe *universe, struct pkg *p
- * flag that means that we have already tried to check our universe
- */
- rc = pkg_jobs_universe_add_pkg(universe, pkg, false, &found);
-+ if (rc == EPKG_CONFLICT)
-+ return (rc);
-+
- if (result)
- *result = found;
-
diff --git a/ports-mgmt/pkg/files/patch-1702 b/ports-mgmt/pkg/files/patch-1702
deleted file mode 100644
index c6f52daa58e6..000000000000
--- a/ports-mgmt/pkg/files/patch-1702
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/libpkg/pkg.c b/libpkg/pkg.c
-index 0c472b39..b4ee9ec3 100644
---- libpkg/pkg.c
-+++ libpkg/pkg.c
-@@ -1668,7 +1668,7 @@ pkg_is_config_file(struct pkg *p, const char *path,
- return (false);
-
- kh_find(pkg_config_files, p->config_files, path, *cfile);
-- if (cfile == NULL) {
-+ if (*cfile == NULL) {
- *file = NULL;
- return (false);
- }
diff --git a/ports-mgmt/pkg/files/patch-60666a1 b/ports-mgmt/pkg/files/patch-60666a1
deleted file mode 100644
index 73527ddd2403..000000000000
--- a/ports-mgmt/pkg/files/patch-60666a1
+++ /dev/null
@@ -1,16 +0,0 @@
---- libpkg/pkg_ports.c
-+++ libpkg/pkg_ports.c
-@@ -353,13 +353,6 @@ meta_file(struct plist *p, char *line, struct file_attr *a, bool is_config)
- pkg_addconfig_file(p->pkg, path, content);
- free(content);
- }
-- } else {
-- if (is_config) {
-- pkg_emit_error("Plist error, @config %s: not a regular "
-- "file", line);
-- free(buf);
-- return (EPKG_FATAL);
-- }
- }
-
- if (S_ISDIR(st.st_mode) &&
diff --git a/ports-mgmt/pkg/files/patch-javavmwrapper b/ports-mgmt/pkg/files/patch-javavmwrapper
deleted file mode 100644
index 1d3c37c0c041..000000000000
--- a/ports-mgmt/pkg/files/patch-javavmwrapper
+++ /dev/null
@@ -1,34 +0,0 @@
-diff --git libpkg/pkg_add.c libpkg/pkg_add.c
-index 87fb248..778336c 100644
---- libpkg/pkg_add.c
-+++ libpkg/pkg_add.c
-@@ -859,14 +859,21 @@ pkg_add_cleanup_old(struct pkgdb *db, struct pkg *old, struct pkg *new, int flag
- * Execute pre deinstall scripts
- */
- if ((flags & PKG_ADD_NOSCRIPT) == 0) {
-- if ((flags & PKG_ADD_USE_UPGRADE_SCRIPTS) == PKG_ADD_USE_UPGRADE_SCRIPTS)
-- ret = pkg_script_run(old, PKG_SCRIPT_PRE_UPGRADE);
-- else
-- ret = pkg_script_run(old, PKG_SCRIPT_PRE_DEINSTALL);
-- if (ret != EPKG_OK && pkg_object_bool(pkg_config_get("DEVELOPER_MODE")))
-- return (ret);
-- else
-- ret = EPKG_OK;
-+ bool buggydeinstall = false;
-+ if (strcmp(old->name, "javavmwrapper") == 0 &&
-+ (strcmp(old->version, "2.5") == 0 ||
-+ strcmp(old->version, "2.5_1") == 0))
-+ buggydeinstall = true;
-+ if (!buggydeinstall) {
-+ if ((flags & PKG_ADD_USE_UPGRADE_SCRIPTS) == PKG_ADD_USE_UPGRADE_SCRIPTS)
-+ ret = pkg_script_run(old, PKG_SCRIPT_PRE_UPGRADE);
-+ else
-+ ret = pkg_script_run(old, PKG_SCRIPT_PRE_DEINSTALL);
-+ if (ret != EPKG_OK && pkg_object_bool(pkg_config_get("DEVELOPER_MODE")))
-+ return (ret);
-+ else
-+ ret = EPKG_OK;
-+ }
- }
-
- /* Now remove files that no longer exist in the new package */
diff --git a/ports-mgmt/pkg/files/patch-src_Makefile.in b/ports-mgmt/pkg/files/patch-src_Makefile.in
deleted file mode 100644
index c92666b8d983..000000000000
--- a/ports-mgmt/pkg/files/patch-src_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Makefile.in.orig 2018-02-14 23:08:02 UTC
-+++ src/Makefile.in
-@@ -619,7 +619,7 @@ pkg_static_LDADD = @OS_LDFLAGS@ $(pkg_OBJECTS) \
- $(top_builddir)/libpkg/libpkg_static.la \
- $(top_builddir)/compat/libbsd_compat.la @LIBJAIL_LIB@ \
- @LDNS_LIBS@ @OS_LIBS@ -larchive -lz -lutil -lbz2 -llzma -lssl \
-- -lcrypto -lm $(am__append_2) $(am__append_3) $(am__append_4)
-+ -lpthread -lcrypto -lm $(am__append_2) $(am__append_3) $(am__append_4)
- DYNPROG = pkg
- @BUILD_STATIC_TRUE@pkg_static_LDFLAGS = -all-static
- dist_sysconf_DATA = pkg.conf.sample