aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/pkg
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-04-01 18:34:03 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-04-01 18:34:03 +0000
commitfb61d858dfe40bb304d20fb47df0324b2b371e98 (patch)
tree5c929d346c5fe7d21e2a600b746db4fe2e934e89 /ports-mgmt/pkg
parente73884abc9df874c854aad784051bc0156f4cb13 (diff)
Notes
Diffstat (limited to 'ports-mgmt/pkg')
-rw-r--r--ports-mgmt/pkg/Makefile1
-rw-r--r--ports-mgmt/pkg/files/patch-libpkg__pkg_ports.c18
2 files changed, 19 insertions, 0 deletions
diff --git a/ports-mgmt/pkg/Makefile b/ports-mgmt/pkg/Makefile
index a7e76ab67e6a..7059515e3306 100644
--- a/ports-mgmt/pkg/Makefile
+++ b/ports-mgmt/pkg/Makefile
@@ -2,6 +2,7 @@
PORTNAME= pkg
DISTVERSION= 1.2.7
+PORTREVISION= 1
CATEGORIES= ports-mgmt
MASTER_SITES= \
http://files.etoilebsd.net/${PORTNAME}/ \
diff --git a/ports-mgmt/pkg/files/patch-libpkg__pkg_ports.c b/ports-mgmt/pkg/files/patch-libpkg__pkg_ports.c
new file mode 100644
index 000000000000..bd6538c46bc4
--- /dev/null
+++ b/ports-mgmt/pkg/files/patch-libpkg__pkg_ports.c
@@ -0,0 +1,18 @@
+--- ./libpkg/pkg_ports.c.orig 2014-03-15 13:15:46.000000000 +0000
++++ ./libpkg/pkg_ports.c 2014-04-01 18:20:02.000000000 +0000
+@@ -318,9 +318,14 @@
+ buf = NULL;
+ regular = false;
+
+- if (S_ISREG(st.st_mode))
++ if (S_ISDIR(st.st_mode)) {
++ pkg_emit_error("Plist error, directory listed as a file: %s", line);
++ free_file_attr(a);
++ return (EPKG_FATAL);
++ } else if (S_ISREG(st.st_mode))
+ regular = true;
+
++
+ /* special case for hardlinks */
+ if (st.st_nlink > 1)
+ regular = is_hardlink(p->hardlinks, &st);