aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/pkg_cleanup
diff options
context:
space:
mode:
authorStephen Hurd <shurd@FreeBSD.org>2014-10-30 07:47:05 +0000
committerStephen Hurd <shurd@FreeBSD.org>2014-10-30 07:47:05 +0000
commit35538ba361f669740b35dfb6987cf7f1e87d91a4 (patch)
tree5d040a4c77c0bc917ee8b68e3a66077b20466b08 /ports-mgmt/pkg_cleanup
parentd65422eaa33890e5db6b4c766d4414969326c638 (diff)
downloadports-35538ba361f669740b35dfb6987cf7f1e87d91a4.tar.gz
ports-35538ba361f669740b35dfb6987cf7f1e87d91a4.zip
Fix segfault caused by passing a string literal pointer to mkstemp()
Submitted by: Oki Sawada <oki@tamon.co.jp>
Notes
Notes: svn path=/head/; revision=371724
Diffstat (limited to 'ports-mgmt/pkg_cleanup')
-rw-r--r--ports-mgmt/pkg_cleanup/Makefile2
-rw-r--r--ports-mgmt/pkg_cleanup/files/pkg_cleanup.c2
2 files changed, 2 insertions, 2 deletions
diff --git a/ports-mgmt/pkg_cleanup/Makefile b/ports-mgmt/pkg_cleanup/Makefile
index cce5c66b55bb..09294c7027d7 100644
--- a/ports-mgmt/pkg_cleanup/Makefile
+++ b/ports-mgmt/pkg_cleanup/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= pkg_cleanup
-PORTVERSION= 2.0
+PORTVERSION= 2.1
CATEGORIES= ports-mgmt
DISTFILES=
diff --git a/ports-mgmt/pkg_cleanup/files/pkg_cleanup.c b/ports-mgmt/pkg_cleanup/files/pkg_cleanup.c
index 9e282719c42f..0531ab5a2008 100644
--- a/ports-mgmt/pkg_cleanup/files/pkg_cleanup.c
+++ b/ports-mgmt/pkg_cleanup/files/pkg_cleanup.c
@@ -28,7 +28,7 @@ static char **pathv;
static bool uses_pkg;
static int menulen=0;
static int helpfile=-1;
-static char *helpfname="/tmp/pkgcleanup.XXXX";
+static char helpfname[]="/tmp/pkgcleanup.XXXX";
#ifdef OLD_DIALOG
typedef dialogMenuItem ListItem;