aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/pkg_replace
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2014-09-06 18:51:46 +0000
committerAlex Kozlov <ak@FreeBSD.org>2014-09-06 18:51:46 +0000
commit42558a6f14254216578ebe2ebbd1ec2fa42e068d (patch)
tree2ea2655ee3fcf86bc18efddff6a6b64ca4f9a762 /ports-mgmt/pkg_replace
parent483dc28c1217f9c115c3dce5f5c3deb2f2273d81 (diff)
downloadports-42558a6f14254216578ebe2ebbd1ec2fa42e068d.tar.gz
ports-42558a6f14254216578ebe2ebbd1ec2fa42e068d.zip
- Update to 20140721
* Increase pkg_replace compatibility with portupgrade - Update MASTER_SITES - Remove support for pkg_tools - Use PLIST_FILES PR: 193304 Submitted by: Ken DEGUCHI <kdeguchi@sz.tokoha-u.ac.jp> (maintainer)
Notes
Notes: svn path=/head/; revision=367466
Diffstat (limited to 'ports-mgmt/pkg_replace')
-rw-r--r--ports-mgmt/pkg_replace/Makefile48
-rw-r--r--ports-mgmt/pkg_replace/distinfo6
-rw-r--r--ports-mgmt/pkg_replace/files/pkg-message.in16
-rw-r--r--ports-mgmt/pkg_replace/pkg-descr2
-rw-r--r--ports-mgmt/pkg_replace/pkg-plist8
5 files changed, 42 insertions, 38 deletions
diff --git a/ports-mgmt/pkg_replace/Makefile b/ports-mgmt/pkg_replace/Makefile
index 7693a2865940..4a7ca9889f69 100644
--- a/ports-mgmt/pkg_replace/Makefile
+++ b/ports-mgmt/pkg_replace/Makefile
@@ -2,41 +2,41 @@
# $FreeBSD$
PORTNAME= pkg_replace
-PORTVERSION= 0.8.0
-PORTREVISION= 10
+PORTVERSION= 20140721
CATEGORIES= ports-mgmt
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_JP}
-MASTER_SITE_SUBDIR= portutil/22116
-
-PATCH_SITES= http://member.tokoha-u.ac.jp/~kdeguchi/download/
-PATCHFILES= ${PKGNAME}.patch
+MASTER_SITES= http://member.tokoha-u.ac.jp/~kdeguchi/download/
MAINTAINER= kdeguchi@sz.tokoha-u.ac.jp
COMMENT= Utility for upgrading installed packages
-USES= tar:bzip2
+USES= tar:xz
NO_ARCH= yes
+NO_BUILD= yes
-MAKE_ARGS= PREFIX="${PREFIX}" \
- PORTSDIR="${PORTSDIR}" PKG_DBDIR="${PKG_DBDIR}"
+PLIST_FILES= sbin/pkg_replace \
+ man/man1/pkg_replace.1.gz \
+ "@sample %%ETCDIR%%/pkg_replace.conf.sample"
+PLIST_DIRSTRY= %%ETCDIR%%
-OPTIONS_DEFINE= PKGDB_FIX ZSH
-PKGDB_FIX_DESC= Fixing tool of installed package dependencies
+SUB_FILES= pkg-message
-OPTIONS_SUB= yes
+PORTDOCS= README README.ja
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
post-patch:
- @${REINPLACE_CMD} -e 's/pkg_replace/pkg_replace pkgdb_fix/' ${WRKSRC}/sbin/Makefile
- @${REINPLACE_CMD} -e 's/mkdir -p $${FILESDIR}/@true/' ${WRKSRC}/share/zsh/Makefile
-
-pre-install:
- @${MKDIR} ${STAGEDIR}${PREFIX}/share/zsh/site-functions
-
-.if defined(WITH_PKGNG)
-post-install:
- @${REINPLACE_CMD} -e '/pkgdb_fix/d' ${TMPPLIST}
-.endif
+ @${REINPLACE_CMD} -e 's|%%ETCDIR%%|${ETCDIR}|g;s|%%PKGCOMPATDIR%%|${PKGCOMPATDIR}|g' \
+ ${WRKSRC}/${PORTNAME}.sh
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.sh \
+ ${STAGEDIR}${PREFIX}/sbin/${PORTNAME}
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 \
+ ${STAGEDIR}${MANPREFIX}/man/man1/
+ @${MKDIR} ${STAGEDIR}${ETCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf \
+ ${STAGEDIR}${ETCDIR}/${PORTNAME}.conf.sample
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>
diff --git a/ports-mgmt/pkg_replace/distinfo b/ports-mgmt/pkg_replace/distinfo
index e1cb103eb926..7b38cfa8a662 100644
--- a/ports-mgmt/pkg_replace/distinfo
+++ b/ports-mgmt/pkg_replace/distinfo
@@ -1,4 +1,2 @@
-SHA256 (pkg_replace-0.8.0.tar.bz2) = 3092f5fc0d18529eb5d38776941c0ee4d0073ecb524ab17671c81ca69c29e214
-SIZE (pkg_replace-0.8.0.tar.bz2) = 17296
-SHA256 (pkg_replace-0.8.0_10.patch) = a34f12d261e4b273adb35faabe3551a783ae34a8ff8c626a444c7001a398e351
-SIZE (pkg_replace-0.8.0_10.patch) = 13283
+SHA256 (pkg_replace-20140721.tar.xz) = da26e02304850b295491f3e4526051ac2f414c87be0837dc611cf8aff0dbd24f
+SIZE (pkg_replace-20140721.tar.xz) = 16232
diff --git a/ports-mgmt/pkg_replace/files/pkg-message.in b/ports-mgmt/pkg_replace/files/pkg-message.in
new file mode 100644
index 000000000000..24b1317a6fab
--- /dev/null
+++ b/ports-mgmt/pkg_replace/files/pkg-message.in
@@ -0,0 +1,16 @@
+!!! ATTENTION !!!
+
+pkg_replace options changed. For more information,
+refer to pkg_replace(1).
+
+-----------------------------------------------------
+You can use various features.
+
+-IGNORE, USE_PKGS
+-BEFOREBUILD, AFTERBUILD, BEFOREINSTALL, AFTERINSTALL
+-User defined functions
+
+See examples in %%ETCDIR%%/pkg_replace.conf.sample.
+
+If you want to use those features,
+edit "%%ETCDIR%%/pkg_replace.conf".
diff --git a/ports-mgmt/pkg_replace/pkg-descr b/ports-mgmt/pkg_replace/pkg-descr
index 0aefdde29dae..1e485d0c2cfa 100644
--- a/ports-mgmt/pkg_replace/pkg-descr
+++ b/ports-mgmt/pkg_replace/pkg-descr
@@ -3,5 +3,3 @@ It is compatible with portupgrade and can be used as
an alternative to portupgrade and portmaster.
WWW: http://portutil.sourceforge.jp
-
-Securedog <securedog@users.sourceforge.jp>
diff --git a/ports-mgmt/pkg_replace/pkg-plist b/ports-mgmt/pkg_replace/pkg-plist
deleted file mode 100644
index 9ee4b50e5f86..000000000000
--- a/ports-mgmt/pkg_replace/pkg-plist
+++ /dev/null
@@ -1,8 +0,0 @@
-etc/pkg_replace.conf.sample
-man/man1/pkg_replace.1.gz
-%%PKGDB_FIX%%man/man1/pkgdb_fix.1.gz
-sbin/pkg_replace
-%%PKGDB_FIX%%sbin/pkgdb_fix
-%%ZSH%%share/zsh/site-functions/_pkg_replace
-%%ZSH%%@dirrmtry share/zsh/site-functions
-%%ZSH%%@dirrmtry share/zsh