aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/pkg_tree
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2010-05-27 12:58:20 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2010-05-27 12:58:20 +0000
commit07689f0ab79c090d77eca349bb56d5be267deabc (patch)
tree0fa36bcccf8dc23c64c3e35ac4a04f058fae2594 /ports-mgmt/pkg_tree
parent956efdb6fa8c010aba1b5d23ff0e175f5be22b70 (diff)
downloadports-07689f0ab79c090d77eca349bb56d5be267deabc.tar.gz
ports-07689f0ab79c090d77eca349bb56d5be267deabc.zip
From Tom Hukins:
I notice it looks for a perl executable in /usr/bin/perl. However, a perl executable may not exist here, so this small patch changes the port to use the PERL5 variable to determine the correct location of perl as determined by the ports system.
Notes
Notes: svn path=/head/; revision=255178
Diffstat (limited to 'ports-mgmt/pkg_tree')
-rw-r--r--ports-mgmt/pkg_tree/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/ports-mgmt/pkg_tree/Makefile b/ports-mgmt/pkg_tree/Makefile
index d3199fc41b26..84d4c386e1e4 100644
--- a/ports-mgmt/pkg_tree/Makefile
+++ b/ports-mgmt/pkg_tree/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pkg_tree
PORTVERSION= 1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= ports-mgmt
MASTER_SITES= http://www.mavetju.org/download/
@@ -23,5 +23,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|__PREFIX__|${PREFIX}|g ; \
s|__INSTALL_MAN__|${INSTALL_MAN}|g ; \
s|__INSTALL_SCRIPT__|${INSTALL_SCRIPT}|g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|#!/usr/bin/perl -w|#!${PERL5} -w|' \
+ ${WRKSRC}/pkg_tree
.include <bsd.port.mk>