aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/pkg_tree
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-11-02 04:06:06 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-11-02 04:06:06 +0000
commitdb4f31d13e630a8b0cc668a9d7ac93f6bb8d1fea (patch)
tree1c37c5a19214e5fee808f22ee68ad6f676f13a54 /ports-mgmt/pkg_tree
parent87784d20c8d17d4e4e87e39d6178188efdf80879 (diff)
downloadports-db4f31d13e630a8b0cc668a9d7ac93f6bb8d1fea.tar.gz
ports-db4f31d13e630a8b0cc668a9d7ac93f6bb8d1fea.zip
[Patch] pkg_tree additional switches
I found convinient some additional key to the pkg_tree utility, and I propose to include them. The patches can be placed in files directory. PR: ports/46810 Submitted by: Vladimir I. Chukharev <chu@gpi.ru> Approved by: moi
Notes
Notes: svn path=/head/; revision=92822
Diffstat (limited to 'ports-mgmt/pkg_tree')
-rw-r--r--ports-mgmt/pkg_tree/Makefile1
-rw-r--r--ports-mgmt/pkg_tree/files/patch-pkg_tree65
2 files changed, 66 insertions, 0 deletions
diff --git a/ports-mgmt/pkg_tree/Makefile b/ports-mgmt/pkg_tree/Makefile
index 622d628a7d2b..bd30aec2f775 100644
--- a/ports-mgmt/pkg_tree/Makefile
+++ b/ports-mgmt/pkg_tree/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pkg_tree
PORTVERSION= 1.1
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://www.mavetju.org/download/
diff --git a/ports-mgmt/pkg_tree/files/patch-pkg_tree b/ports-mgmt/pkg_tree/files/patch-pkg_tree
new file mode 100644
index 000000000000..b2b81728e81b
--- /dev/null
+++ b/ports-mgmt/pkg_tree/files/patch-pkg_tree
@@ -0,0 +1,65 @@
+--- pkg_tree.orig Wed Dec 12 13:44:40 2001
++++ pkg_tree Mon Jan 6 23:02:31 2003
+@@ -26,7 +26,7 @@
+ # updated by a newer version. In case of tcl-8.3.3_3, this is tcl-8.3.3_4.
+ #
+ # PKG-TREE is (c) Edwin Groothuis, edwin@mavetju.org
+-# For license issues, see the file LICESE.
++# For license issues, see the file LICENSE.
+ # For more information, see the website: http://www.mavetju.org
+ #
+
+@@ -34,10 +34,13 @@
+
+ use Getopt::Std;
+
+-use vars qw/ $opt_v /;
++use vars qw/ $opt_b $opt_q $opt_t $opt_v /;
+
+ $opt_v=0;
+-getopts("v");
++$opt_t=0;
++$opt_b=0;
++$opt_q=0;
++getopts("bqtv");
+
+ my $PKGDIR="/var/db/pkg";
+
+@@ -46,6 +49,7 @@
+ closedir DIR;
+
+ @dirs=grep !/^\./,@dirs;
++@dirs=grep !/^pkgdb.db$/,@dirs;
+ @dirs=sort @dirs;
+
+ my @args=@ARGV;
+@@ -150,8 +154,10 @@
+ }
+ next if (!$found);
+ }
++ next if ($opt_t && $required{$pkg}[0]!=0);
++ next if ($opt_b && $requires{$pkg}[0]!=0);
+ print "$pkg\n";
+- if ($requires{$pkg}[0]!=0) {
++ if (!$opt_q && $requires{$pkg}[0]!=0) {
+ print_deps("|"," ",1,$pkg);
+ }
+ }
+--- patch-aa ends here ---
+
+--- patch-ab begins here ---
+--- pkg_tree.pod.orig Wed Dec 12 13:44:40 2001
++++ pkg_tree.pod Mon Jan 6 23:20:49 2003
+@@ -53,6 +53,12 @@
+ |\__ freetype2-2.0.5
+ \__ XFree86-libraries-4.1.0 (unknown)
+
++Use the B<-t> parameter to show only top level packages,
++and B<-b> to show only bottom level packages. And B<-t> B<-q>
++together will give the list of top level packages without their
++dependencies, installing only these packages should install all
++currently installed packages.
++
+ =head1 RETURN VALUES
+
+ Always 0.