aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/portconf
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2008-07-11 10:48:35 +0000
committerAlex Dupre <ale@FreeBSD.org>2008-07-11 10:48:35 +0000
commitaa10d1c25b9abde067532f462e5e1fb1d7220296 (patch)
treeabf60db1e2c376305c6de2c32ece6aa66d4b160f /ports-mgmt/portconf
parent85f5c9faad00c8dd7ac5b9c7c596fadc639bb198 (diff)
downloadports-aa10d1c25b9abde067532f462e5e1fb1d7220296.tar.gz
ports-aa10d1c25b9abde067532f462e5e1fb1d7220296.zip
New feature: undefine variables.
PR: ports/125273 Submitted by: Yi-Jheng Lin <yzlin@cs.nctu.edu.tw>
Notes
Notes: svn path=/head/; revision=216688
Diffstat (limited to 'ports-mgmt/portconf')
-rw-r--r--ports-mgmt/portconf/Makefile2
-rw-r--r--ports-mgmt/portconf/files/pkg-message.in6
-rw-r--r--ports-mgmt/portconf/files/portconf.sh.in2
3 files changed, 6 insertions, 4 deletions
diff --git a/ports-mgmt/portconf/Makefile b/ports-mgmt/portconf/Makefile
index d27b29262305..e0422753537a 100644
--- a/ports-mgmt/portconf/Makefile
+++ b/ports-mgmt/portconf/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= portconf
-PORTVERSION= 1.3
+PORTVERSION= 1.4
CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portconf/files/pkg-message.in b/ports-mgmt/portconf/files/pkg-message.in
index 51f2fcea11e0..dfc8b199c4f9 100644
--- a/ports-mgmt/portconf/files/pkg-message.in
+++ b/ports-mgmt/portconf/files/pkg-message.in
@@ -6,8 +6,10 @@ with the following syntax:
---------------------------------------------------------
# this is a comment
-editors/openoffice*: WITH_CCACHE|LOCALIZED_LANG=it
-print/ghostscript-gpl print/lpr-wrapper: A4
+*: NOPORTDOCS
+editors/openoffice.org-2: WITH_CCACHE|LOCALIZED_LANG=it
+print/ghostscript-* print/lpr-wrapper: A4
+sysutils/fusefs-kmod*: !KERNCONF | !NOPORTDOCS
www/firefox-i18n: WITHOUT_SWITCHER | FIREFOX_I18N=fr it
x11/fakeport: CONFIGURE_ARGS=--with-modules="aaa bbb ccc"
---------------------------------------------------------
diff --git a/ports-mgmt/portconf/files/portconf.sh.in b/ports-mgmt/portconf/files/portconf.sh.in
index 98b8252f5262..e40e2468cfaf 100644
--- a/ports-mgmt/portconf/files/portconf.sh.in
+++ b/ports-mgmt/portconf/files/portconf.sh.in
@@ -36,7 +36,7 @@ _pwd=`pwd`
sed '/^#/d;/^[[:space:]]*$/d' "${_conf}" | while read _line; do
for _port in ${_line%%:*}; do
if [ "${_pwd%%${_port}}" != "${_pwd}" ]; then
- echo ${_line#*:} | sed -E 's/([A-Z0-9_]+)(=([^|]+))?/\1=\3/g;s/ *\| */|/g;s/ /%/g'
+ echo ${_line#*:} | sed -E 's/([A-Z0-9_]+)(=([^|]+))?/\1=\3/g;s/!([A-Z0-9_]+)=([^|]+)?/.undef \1/g;s/ *\| */|/g;s/ /%/g'
fi
done
done