aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/portgraph
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-19 07:45:25 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-19 07:45:25 +0000
commit7aafb41498f07a7ae36d8eef27f3049ef9e89ea4 (patch)
tree60dbe2cab6b76c3933ea33e9421d752e0499acb4 /ports-mgmt/portgraph
parent3eb6f25d8c8d0c1d6ac0550702ca53c8a7d6458f (diff)
downloadports-7aafb41498f07a7ae36d8eef27f3049ef9e89ea4.tar.gz
ports-7aafb41498f07a7ae36d8eef27f3049ef9e89ea4.zip
New port: ports-mgmt/portgraph: Create a dependencies graph of a(all) port(s)
PR: 225969 Submitted by: lbartoletti@tuxfamily.org
Notes
Notes: svn path=/head/; revision=464994
Diffstat (limited to 'ports-mgmt/portgraph')
-rw-r--r--ports-mgmt/portgraph/Makefile24
-rw-r--r--ports-mgmt/portgraph/distinfo3
-rw-r--r--ports-mgmt/portgraph/pkg-descr8
3 files changed, 35 insertions, 0 deletions
diff --git a/ports-mgmt/portgraph/Makefile b/ports-mgmt/portgraph/Makefile
new file mode 100644
index 000000000000..c5e1ae347059
--- /dev/null
+++ b/ports-mgmt/portgraph/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= portgraph
+PORTVERSION= 0.0.1
+CATEGORIES= ports-mgmt python
+MASTER_SITES= CHEESESHOP
+
+MAINTAINER= lbartoletti@tuxfamily.org
+COMMENT= Create a dependencies graph of a(all) port(s)
+
+LICENSE= BSD2CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}graphviz>=0.8.2:graphics/py-graphviz@${PY_FLAVOR}
+
+USES= python:3.4+
+USE_PYTHON= distutils autoplist noflavors
+NO_ARCH= yes
+
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's|/usr/ports|${PORTSDIR}| ; s|ports-mgmt/py-portgraph|ports-mgmt/portgraph|' \
+ ${WRKSRC}/portgraph/portgraph.py
+
+.include <bsd.port.mk>
diff --git a/ports-mgmt/portgraph/distinfo b/ports-mgmt/portgraph/distinfo
new file mode 100644
index 000000000000..96dd5c042dbc
--- /dev/null
+++ b/ports-mgmt/portgraph/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1518849908
+SHA256 (portgraph-0.0.1.tar.gz) = 49ad0700f8c64e3ea4c84201d11b60bfdc09778100abc8b106be36c1f111b6cb
+SIZE (portgraph-0.0.1.tar.gz) = 1006733
diff --git a/ports-mgmt/portgraph/pkg-descr b/ports-mgmt/portgraph/pkg-descr
new file mode 100644
index 000000000000..552fda2b1acb
--- /dev/null
+++ b/ports-mgmt/portgraph/pkg-descr
@@ -0,0 +1,8 @@
+Started from an idea on twitter and used to reduce the dependencies of a port,
+here is a python script to produce dependencies' graph of a(ll) FreeBSD port(s).
+
+'portgraph' produces a graph (.dot and svg) representing the dependencies needed
+for a given port or all ports thanks to graphviz and the power of make
+{build,run}-depends-list.
+
+WWW: https://gitlab.com/lbartoletti/portgraph